Is there an option to auto-feed and continue cutting when the file is larger than the bed

My company has a flatbed Ruida controlled 150w CO2 laser that we use to cut out our Dye-sublimated fabric products (Feather Flags, Logo Flags, Tradeshow Displays, Banners, Table covers, etc…)

Our laser bed is 3240mm x 1540mm with a rotary auto-feed.

We are currently trying to cut out hundreds of Feather Flag liners which are longer than the working bed size (1540mm) Generally that isn’t an issue as we would print registration dots on the fabric rolls and the Mindvision camera attached searches them out and cuts the prints, one after another feeding the roll through the laser and dropping the prints in baskets in front. However because we are not printing the liners, just cutting from the rolls, we are trying to create the template and nests in Lightburn, and have them cut directly from the material. Unfortunately we are running into the issue of bed size.

Any help is appreciated

  • Chris
Feeder Setup (Menus - LightBurn Software Documentation)

This will open the auto-feed setup dialog. Use this to set up the auto-feed table controls for Ruida controllers with an auto-feeding table.

Awesome man, we’ll try first thing in the morning! Thank you!

1 Like

I don’t see the feeder option under laser tools…

Do I need to enable it somewhere?


I think it pops up automagically when the controller has a feeder option, because the manual claims my low-budget KT332N can do that trick.

However, the option seems buried in the manufacturer-only config, beyond even the Vendor Settings.

Feeder mode apparently repurposes the U axis outputs and no longer drives the platform up-and-down, which is definitely a change I’d be unwilling to make. :grin:

Good Morning, we tried it out and the machine began feeding the roll which is awesome, however before it cut it threw an error message “frame slop” and then stopped and continued to origin and did nothing

Caveat: My laser does not have a roller feed, so what follows is guesswork.

That message usually indicates an engraving requires motion beyond the axis limit, but I wonder if it also applies to roller motion.

The RDC6445G manual (p 59) suggests there’s a Feeding Mode config option:

Feeding Mode: it has single-way mode and two-way mode for option. If it is of single-way feeding, it is unnecessary to check the coordinates. Feeding can be conducted in the single-way mode; if it is of two-way feeding, the system will check the maximum and minimum coordinates. The odd sequence means feeding should be done to one direction and the even sequence means feeding done to the other direction. The initial direction for the first time can be changed through setting the directional polarity or modifying the plus and minus values of the feeding length.

I have no idea what that means, but perhaps flipping it the other way would make it “unnecessary to check the coordinates” and keep the controller happy.

If the breeze from that handwaving hasn’t ruffled your fur, try it out.


Hahaha thanks man, we’ll give it a go

I offer these as assistance.

Please keep us informed as to how you progress. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.