Jerky, pausing engraving on subsequent shapes when Z-axis is enabled

I have a “Fill” layer, “fill groups together,” with a 2mm Z offset. Device is set to “Enable Z axis” and “Relative Z moves only.”

If I have 2 or more groups to be engraved the first engraves as expected. The 2nd and subsequent groups engrave much slower. I think it’s pausing between each letter in a group of letters. This results in much slower operation and a lot more power being burned into the material.

EDIT: When you turn off “Enable Z axis” it works correctly as expected.

Did I set something wrong or does this look like a bug? Here’s a video of the behavior and attached are shots of the settings.

Machine is an Omtech Polar, with Ruida 6442 controller.

I would double check how each are being filled. They seem to change to flood fill on me. Maybe upload your file.

They’re copies of each other, on the same and only layer. File attached.
lightburn-zdemo.lbrn2 (20.3 KB)

How does it work if you fill all shapes at once?

It works as expected when you fill all at once.

That’s odd. Preview shows both ways working as expected. Some one else will need to jump in here.

Yes, for what it’s worth, I’m seeing the same. The preview for the misbehaving version looks as expected, and doesn’t match the actual unexpected behavior.

I believe your machine depends on absolute Z-axis positioning. Try disabling “Relative Z-moves only” and enable “Optimize Z moves”.

  1. Reading the Lightburn docs, it’s not clear how to use it without “Relative” set.

Enabling Z control means that LightBurn will always emit Z values for a running job, and therefore requires that you set either the “Relative Z moves only” toggle below, or a material height value on the main cut panel. If you to not set relative mode, and do not set a material height, the default of 0 may cause LightBurn to raise your bed to a point where the workpiece could contact the head of your laser.

Where or how do you set the material height?

  1. I’m only doing this to help gather info and narrow down the bug. If I have to set material height for every job, 99.9% of which don’t require Z movement, I simply won’t do it.

Even if this machine requires absolute Z positioning, I don’t think anyone can argue with a straight face that this is expected or desirable behavior.

Have you seen this Operational Tutorial from OMTech? It describes the focusing method. In the video they change the focus distance in the controller for each job.

Billie offers an alternative approach using material height in her Gweike Cloud FAQ. The machines are highly similar.

It seems to me that you could also focus manually and use Relative Z moves only and don’t use “Focus Z” but I haven’t heard of anyone attempting that.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.