Language Translation?

Hello there again,
I seem to be having an issue between computers and their languages. (this is an assumption)
I was given a file to do a custom job, and that file opens up and is perfectly beautiful in/on a Linux machine. And the xTool D1 obviously has to be connected to a Windows computer, so I put the file on a chipstick and move it from the one computer to the other, and the file is all ‘wrong’. As in, revisions from a number of steps back are showing up. It is even a surprise to the maker, whom has tried to ‘re-send’ the file even after re-revising it, to ensure that none of the issues are there.
And yet they are, and still are absolutely wrong/bad/waste-of-time.

The primary thing I’m saying here, is my absolute unhappiness with the fact that while LightBurn DOES work with Linux, the laser machine DOES NOT. So having to constantly be going back between one computer an another is ridiculous. And yes, so far this is unchangeable because the actual laser drivers are Windows based. (if anyone out there knows of a way around this… that’d be awesome.) What was supposed to be a simple/fast job for Christmas presents has sure turned into a gong-show. Add to the fact that our Laser machine took an extra 2 weeks to get to us, we’ll be just in time for everything to be completed in time for Chinese New Year.

Has anyone else experienced any of this situation, described above?

Data in a Lightburn file cannot change from system to system. The only thing that could would be fonts that aren’t available.

More specifically, it is an .svg file.
I open the file on a Linux computer, using the Element messaging program, and it is a perfectly beautiful drawing.
I open the file on a Windows computer, using the Element messaging program, and it is a perfectly beautiful drawing.
I open the file on the Windows computer, using LightBurn program, and it is a very gibbled-up drawing.

(more fuel for the fodder, if that helps at all?) Also, this is not a ‘font’ issue at all. This actually pertains to the drawing itself. Lines where there shouldn’t be, mirroring where there shouldn’t be, etc.

Do you know in what program the SVG file was created? Seems to me there may be something proprietary going on. When you say you’re opening this in Element messaging, are you talking about an email program? So you’re seeing this in a preview?

Can you share the SVG file to test?

Separately, LightBurn now works on the D1 if you didn’t get the news. Very recent:
User Manual For Configuring LightBurn – xtool

Granted, reports here show that there are still issues with the implementation but might help in you some way.

Thank you, and here are some answers:
The drawing was created in Adobe Illustrator.
Element messaging is a messaging program similar to FB, except it is not monitored/governed by others and is supporters of Freedom and Communication.
No, I can’t share the svg file, as it is personal and proprietary to the artist.
Sure, LightBurn works for the D1, as I’ve said. But the D1 does NOT work on a Linux computer. Has to be a windows.
As it is, I’ve loaded the Element program onto the Windows computer, and the file still opens perfectly in Element, (which is how he’s transferred the file to me) but ‘terribly’ in LightBurn.
…as the plot (or soup) thickens.

How does the D1 know that LightBurn is running on Linux?

Can the artist send you the .ai file instead of the SVG file to try?

Can you share a screenshot of what you get in Element vs LightBurn instead?

Then have your artist send you an AI file that is saved with PDF preview. Lightburn can import it. If there is still a problem, it would have more to do with your artist not outlining strokes and fonts. If a shape / line has stroke width in Illustrator, it has to be outlined in order for Lightburn to import correctly. Maybe your artist doesn’t understand how a file needs to look for a laser cutter. It’s not necessarily the same as setting a file up for printing verses setting up for laser cutting and engraving.

1 Like

How does the D1 know that LightBurn is running on Linux?
This is because unless you hook up a laser to the computer, LightBurn will not load/run. And since the laser needs to have the Drivers loaded, in order to be seen, it has to be a Windows computer.

Can the artist send you the .ai file instead of the SVG file to try?
I have asked him this, and am awaiting a response.

You’re correct on the first point but may have overlooked something on the second. LIghtBurn just uses libUSB which is builtin to Linux so doesn’t need to install any new driver.

Looks like the D1 uses a very common CH340 USB-Serial interface chip which should work fine in Linux. I know you had trouble with setting up LightBurn on Linux in another topic but there should be no reason this can’t be made to work. The biggest hurdle initially was making sure the firmware on the D1 was updated. Did you do this successfully from Windows?

If so, you should now be able to get this working in Linux if you’re up to trying it.

One key thing is you’ll need to make sure you give yourself permission to access the Serial ports which is documented in the LightBurn Linux installation instructions

sudo adduser $USER dialout && sudo adduser $USER tty

Without this the device may not appear or be available for communication.

Let us know how the Illustrator file plot develops.

There is a very good possibility that I’m completely not understanding something. Bear with me. You start off by stating that “You’re correct on the first point…”

The first point being that the computer I’m trying to put Lightburn on is at one end of the house and is a Linux computer, and that can’t/won’t happen without a laser attached to it.

As stated, the laser is at the other end of the house. I can’t physically be carrying/toting the laser back and forth between “design” and “use” hence the primary question. Let alone all the different hoops and hurdles that are needed to run the xTools D1 on a Linux machine(computer).

Or am I missing the plot somewhere?

I think what @berainlb was trying to say, is that Lightburn is not dependent on drivers like windows. Lightburn will run on the Linux box (with or without the laser connected, I’m doing it now, no laser…)

It does not need drivers, like windows.

If you have an issue where you are stuck with windows out where the machine is, you will have to work that out. Lightburn projects I’ve made, I sneaker netted them to Windows and ran the laser with it. No problems with anything moving or acting up.

If possible you might want to look at connecting something like the Lightburn Pi Bridge with a software layer to help support UDP link to the Ruida via the Ethernet port.

Then you can send it to the laser and do it all from your Linux box, like I do…

Take care… Good luck… Don’t make it more complicated than it is…

:smiley_cat:

I was specifically referring to this portion of your point:

LightBurn forces you to setup a device in order to move forward. You can do this by either having the device detected or creating the device manually. I think where you might have gotten stuck here is that because you were not able to locate the device that you couldn’t proceed. I’m speculating that it could have been caused by either the laser not having the updated firmware or because the necessary change on the Linux side were not completed.

If your goal is to not have to physically move the laser back and forth between the two locations I assume you want to get LightBurn installed on your office (Linux) computer. Unless you want to install Windows on your office computer. I think this should be possible.

Once installed, you should be able to save your LIghtBurn projects to USB drive or alternatively place the file on a network share so that you don’t have to sneaker net it to the current Windows LightBurn machine.

If that’s what you’re looking to do we can help you with that.

The ‘second point’ of this above post, is the intent. Perfectly. Now that things seem to have settled somewhat around the house here, I’m attempting to accomplish this today.

“This” being, getting the LightBurn program to work on this Linux tower I’m sitting at for the moment. It is all connected to the house ‘network’ so in-a-perfect-world all the files shall be stored in a server, all computers wired together via LAN cable.

Now that I can apply undivided attention for a bit, I’m focusing on this task.

OK, I have just ‘added’ the ‘Dummy’ and it SEEMS that I can use the program now.

I had entered the information required, which I’d gleaned from the company details of the xTool D1 spec’s and such.

To say that “it was TOO easy” is an understatement. To the point of, I can’t believe it was that easy to get to this point. It’s almost like I’m still waiting for a shoe to fall, or a drive to catch-fire, because there HAS to be a catch to this. It really IS that simple? wow.

And yes, a full ‘computer restart’ is needed after entering that “sudo adduser $USER…” stuff. Makes all the difference in the world.

So I’m going to go ahead and start to use the program here in the ‘office’ with the hopes that the laptop out there will open the file and burn, when I hit ‘go’ out there.

Thank you everyone for your replies and additions here, and specifically Thank You berainlb… because it is what YOU have typed here that told me I can do it, and how. Before that, it seemed impossibillium to me.

Oh wow. I just got to this and read your 2 message back to back… after the first one I was prepared with “Okay, great. Sounds like Nailer’s going to start hacking on this. Hope it doesn’t go so bad.” Then in the very next message you’re already up and running. Haha. Had a little whiplash.

That’s fantastic. If for any reason you do experience any configuration issues you can actually export your preferences (File->Export Prefs) from your production system and import them into your design system. Prefs will include any devices configured as well Application configurations. It doesn’t include anything that’s stored at the individual LightBurn project level.

Let us know if you get stuck on anything or move on to your next quality of life upgrade.

Progress truly IS wonderful.

Which brings me to the next stop on the confusion-express… and slams me into a wall. I’m ‘presuming’ (I don’t ‘assume’, because that makes an ‘butt’ out of ‘you-and-that-other-guy’ Haaaaaaaa) that there is something I can do about the next step in “language translation”.

I opened up the ubiquitous file that I spoke of before Christmas. (that private artwork piece) and the picture opens up perfectly and beautifully here on this Linux tower. Great, I work with that, do my ‘lines’ and ‘fills’ and get everything all the way I want it to go. I save it to my Linux tower, as well as save it to the Linux server.

I then go into the kitchen (until the Laser-Lab is completed) and using the Windows Laptop, I open the file on the server. It shows up on the Lightburn program as an ‘inversed’ image.

As-in, ‘top is bottom and bottom is top’ and at the same time, the words are ‘inversed’ as well. Still reading ‘left-to-right’ but the letters are also ‘upside down’ and like looking at them from the back of a page of paper.

Please, please tell me that there is something I have to click or unclick, check or uncheck, so that the ‘same’ file that is saved opens up on the Windows machine and doesn’t translate itself to Swahili or something.

Maybe this can/should be asked in a different manner, but I don’t know the terms/jargons to sound professional yet. Gimme another week. Double-Haaaa

Happy New Year!

This is due to a difference in your machine origin. It should have been a part of the device configuration. I’m going to assume that the machine origin set in your kitchen production installation is correct. As in you can jog using Move window buttons as you’d expect and it burns as you expect.

If that’s true then simply lookup the machine origin on that system in Edit->Device Settings:

Make note of the position. I believe your laser should be top-left but I could be wrong about that. Then change that setting to match on your new office Linux installation.

When you open up the file you saved on your Linux system you will need to “fix” the rotation/inversion one time. Save again. Then retry on Windows system.

settings adjusted and corrected and whatnot. Lasering the eleventeenth test-piece! (in progress)

Did you tell the family they won’t need to hold dinner for you? :smirk:

Talk about frustrating. I’m missing the plot somewhere along the line. Here is what I’m doing, out of desperation, just to attempt to do something:

Test Pattern Trial.lbrn2 (73.3 KB)
and here is what it looks like when it’s done:

Now, to my knowledge the ‘device settings’ are the same on both this Linux tower as they are on the Windows Laptop. I’ll look again for the eleventieth time, to see what I have to smack with a hammer to get it to change it’s mind and actually do SOMETHING right, for once. No fault of Lightburn at all, this is wholly an issue with the communication of-and-between a few different computers here… but I truly hope ya’ll see the frustration of the first 15 days of trial period.

And with everything else requiring adulting in the past few weeks… we just want to be able to begin from the starting line, and get going on this race.