Laser delays before starting cut/ engrave

My china yl/bl 60 watt , ruida 6442s, started acting up today. Went to start a run of mugs and the laser moves to the start position then delays for 9 seconds before it starts engraving. It engraves fine once it goes but I’m very confused why it is delaying at the start. two days ago it worked just fine and would scoot to the start position and start engraving/ cutting immediately. I have no errors on the main controller, have tried files straight from the pc and loaded on to the controller. Rotary and no rotary. Doesn’t seem to make a difference. It delays starting for 9 seconds exactly, then on second 10 it starts and works normally for the entire file.
Machine homes just fine, no errors in diag menu, led 9 and 15 on solid, 14 slow flash. Does the same thing with the laser PS turned on or off.

Any ideas? I’m guessing hardware malfunction but didn’t know if there’s anything in lightburn that would affect that.I don’t get why it just started at random and why its such an exact time-frame every time. I would thing a real error would be more sporadic.

Just throwing ideas - Do you have “Ramp Length” enabled/set in cut settings editor?
I wish to know myself what can cause this.

No ramp length set. I didn’t change any settings from the way I’ve always had it setup, just randomly started.

To offer clarity, this is happening with any and all files? What version of LightBurn? OS? Any layer in particular? Layer setting differences in the different files you have tried?

Tried a few different files, all ones that I’ve used for other mug runs. Same result. All single layer. This one in particular is the third set I’ve done with this exact file. Drew a new random file, just some circles to test, same result. Opened a file for some templates that I cut a few days ago and tested those with rotary off in cut mode just like a couple days ago, same thing. 9 second delay after moving to the start point then on second 10 it does what it’s supposed to do.
It like there’s a large pierce delay all of a sudden but it doesn’t fire the laser while it’s sitting there
Lightburn is the latest version, same with windows etc. All layer settings the same between files tested.

And “Cut Through” mode is off? (and no time delay set)

This is what I was thinking but you would see that in your layer settings if you are set to ‘Line’. Does this happen in both ‘Line’ or ‘Fill’ cut settings?


Correct. Same issue whether in line, fill or line+fill mode

Can you post a file that does it for others to try? It sounds like something might be up with your machine.

It even does it when I create a fresh file. I’m going to pull one from my pc inside direct into the machine and bypass the laptop that runs it and see if there’s any difference… I’m leaning toward controller issue myself. I’ll upload the file here soon

D10 final 20 oz ritc tumbler 75mm.lbrn (702.4 KB)

Just one more thing as a long shot. How many files are on your controller? Is it pretty full?
I’ve found the ruida controller can act kind funny sometimes if the memory is way full. Usually it just refuses to accept more files but I’ve also had odd little problems that seemed to be cured by deleting a few files off a full controller.

Got it! after closer scrutinizing. I switched to line mode, and even though “cut through” mode wasn’t active, for some reason there was a 10,000ms start delay in there. but now why would fill mode be following that command, especially if cut through wasn’t selected?

I did dump all the files first thing :slight_smile: Had the same thought.

Well there’s an interesting question. I’ll bet Oz knows the answer. He’ll either have a good explanation for its behavior, or will say “fixed for next release”. :smiley:

Obviously you’ve found the problem. I did send your file to my machine and I didn’t run the whole thing but when I loaded the file and hit Start it started right up and went to business.

Mines being odd it seems that when I open a file now in lightburn, even one with just fill and then switch to line, that 10 second delay is in there, but not active. When i change to zero and run, its fine. It’s doing it for every file I load, even files with fills and cuts. The cut/lines will have no delay, but when I go to the fills and change them to lines, the 10 second delay is there. If I change to 0 and save and re-open they’re all good. Sounds like I have a little bug in the system. Time to try a fresh software install and see if it goes back to normal.

Thanks for your time and insight Hank and Rick! I don’t know how many times I looked at the fill and line settings and didn’t pay attention to the numbers, assuming that If cut-through wasn’t active, it shouldn’t follow the settings under it.

This has just hit me, from a few weeks ago:

Okay, good to know! Now to figure out why it’s affecting fill mode all of a sudden… or showing up as 10 seconds out of nowhere … I’ve never used or set a delay time since I got the machine last September. Gotta love technology sometimes :joy:

I am not sure if these are related so… Looking forward to some of the thoughts from Oz on this.

This is John’s project saved once as a line cut and once as fill (Same layer).
both Gcodes includes G4 10000 in there so it seem like G4 Dwell is just not being shown in fill cut setting window for same layer.

-------------------------LINE CUT ----------------------------------------------------------- FILL------------------

Here below you see the same shape after me assigning it to a different layer (kept as FILL) and no more G4 in gcode.

Compared to FILL in original layer (black color).
In john’s case it is obvious lightburn remembers / link old code for same layer data.