Laser freezes as lightburn goes on

Hi everyone, I have a problem, about halfway through a photo incision lightburn makes the laser stop suddenly and messes up all the work. The green scroll bar and the time continues to go but the laser remains stationary, in the end I am forced to press stop. I attach photos of the screen

Nessuno sa darmi una risposta ?

Can anyone give me an answer?

Does this happen with every job that does “photo incision”? Also what does “photo incision” do? Is this a grey scale image you are trying to burn? Also I have a NEJE MASTER 2S MAX. Would this be similar to your machine?

Succedeva nei lavori un pò lunghi (40 min.) ora pare che va tutto bene, riesce a completarli. Praticamente ho collegato la spina usb C sulla parte dietro del pc dove c’è la scheda madre. Prima la collegavo sulle porte frontali usb

It used to happen in some long jobs (40 min.) Now it seems that everything is fine, he manages to complete them. Basically I connected the USB C plug on the back of the PC where the motherboard is. Before, I connected it to the front usb ports

Aggiornamento… Niente problema ripresentato dopo aver aggiornato la versione 9.23 quindi tutte le prove fatte sono nulle, non centra niente ne il cavetto ne le porte usb ne le impostazioni di lightburn. Ho reinstallato la 9.22 precedente e pare che per ora riesce a completare il disegno

Update … No problem resubmitted after updating version 9.23 so all the tests made are void, nothing has to do with the cable or the usb ports or the lightburn settings. I reinstalled the previous 9.22 and it seems that for now it can complete the drawing

Si è un immagine in scala di grigi

It is a grayscale image

It isn’t Lightburn making the laser stop - your laser controller has stalled and given no indication to LB, which carries on as if it was working normally.

The problem is at the laser controller, quite likely due to poor grounding resulting in static buildup that trips the controller out.

this is a reference, but with the Ortur, which is very similar in construction: ORTUR LASER MASTER 2 - Service Notice - Grounding

Allora come mai lo fa solo con lightburn ? Con il software neje e grbl va tutto ok, non si è mai fermato. Comunque ho scaricato la versione precedente 9.22 e pare che non fa più questo problema nemmeno con lightburn. Vediamo con l’utilizzo se torna questo blocco…

Eventualmente come risolvo il problema della messa a terra ?


So how come it does it only with lightburn? With the software neje and grbl everything is ok, it never stopped. Anyway I downloaded the previous version 9.22 and it seems that it no longer has this problem even with lightburn. Let’s see if this block returns …

Eventually how do I solve the grounding problem?

Thank you

I don’t speak Italian.


Unfortunately after days and days of trying to understand the problem I still haven’t been able to solve it, I changed the USB cable with a quality one, I removed all the power saving functions from the PC, I reinstalled various previous lightburn versions but the problem remains, for example at some point everything stops and the screen that I attach in the photo in the link remains. This problem occurs “only” with lightburn, with all other software the laser (neje master 2s plus) is perfect. I really hope for your help to solve it because unfortunately I gave up …

The linked document provided by Bo above, " ORTUR LASER MASTER 2 - Service Notice - Grounding " is worth review. Have you reached out to the supplier to see if they have recommendations for how to solve?

@NEJE_Laser, Can you offer troubleshooting procedure, please?

This is no longer a valid link:

Sembra abbia risolto il problema. Lightburn non centra nulla, purtroppo è la scheda madre del neje master 2 difettosa, ne ho provata un altra ed era tutto ok. Ho scritto a neje per trovare un accordo per la sostituzione

Hi Alex879, from the sounds of it I have been having the same issue with my NEJE master 2/2s max as well. Project will stop when using Lightburn and timer continues, though progress % does not continue. I have tried a number of different fixes over the last couple weeks with no results,

New USB Cable (even zip tied cable to prevent any wiggle at controller)
Different USB port
Windows settings changed for USB selective suspend setting set to “disabled”
All sleep functions on laptop set to off

Needless to say if you have some success with something or if someone else has seen and fixed this issue I’m all ears.

I may try a different computer as I am worried its a Windows 10 issue…

I just translated your last post, sounds like off to customer support for NEJE if its a motherboard issue

Ciao, si il problema è dovuto a questo:

Anything new? I have the same problem that the laser stops mid-project (40mins+).
Did the same project twice, and it stopped on the exact same position.

I also have this issue. Been talking withAlex870. Between us I think we have tried it all. I have contacted NEJE and sent them video. They seem to think it is the main board. So they are sending me a new board. I have bought my own 2s board and tried it. I engraved 3 Jarvis dithered photos perfect. I tried a grayscale image and it stopped at 82%. Not sure the NEJE 2s max can do the bigger grayscale. Only other thing I have not tried was downloading the 32bit version of LB. Maybe it is a software issue trying to use 64 bit LB on a 32 bit laser. I know it is a long shot but I have tried everything.

There will be no issue with running 64 bit software on your computer to a 32-bit controller.

I did not think there would be. I have seen stranger things. I have tried everything to get it to work. Kind of my last ditch effort.

Bigger than what? Details really help. :wink:

Stopping could be due to a grounding issue, noise or electrical interference, intermittent cable connection or bad or failing cable to mention a few potential causes. You mention, “…my own 2s board and tried it.”, but offer little more. What is this board and what firmware are you using to drive it? Details really help.