Laser Not Detected? Comgrow Mini Laser Engraver

I just got a new Comgrow Mini laser engraver, one of these: Comgrow Mini Laser Engraver DIY Desktop Engraving Tool - Comgrow Official Store.

When I run Lightburn, it doesn’t seem to detect the laser at all, and I’m not sure what the controller is to try to set it up manually. The laser is the only thing plugged into my computer.

I’m on linux, and I ran the adduser commands and logged out and back in.

Here’s the command line output, if it helps:
libpng warning: iCCP: known incorrect sRGB profile
connected
“Integrated Camera: Integrated C” “/dev/video0”
“Integrated Camera: Integrated I” “/dev/video2”
Found port: PID 22336 VID 1155
Manufacturer: “STMicroelectronics”
Product: “STM32 Virtual COM Port” on “ttyACM0”
STM32: Probably Gerbil-STM
opener
Port open succeeded
$i response
$$ response
Found port: PID 41827 VID 32902
Manufacturer: “”
Product: “” on “ttyS4”
opener
Port open succeeded
$i response
$$ response
Found port: PID 41768 VID 32902
Manufacturer: “”
Product: “” on “ttyS5”
opener
Port open succeeded
$i response
$$ response
Vend: 7531 Prod: 3
Vend: 7531 Prod: 2
Vend: 7531 Prod: 3
Vend: 1739 Prod: 189
Manufacturer: Product: Serial: 396365685fb5
Vend: 1266 Prod: 46716
Vend: 32903 Prod: 41
Vend: 1423 Prod: 38208
Vend: 1155 Prod: 22336
Vend: 7531 Prod: 2

Everything on the product page advertises their own App. Typically this would mean that it is a proprietary firmware.

Product: “STM32 Virtual COM Port” on “ttyACM0”
STM32: Probably Gerbil-STM

This is interesting - I assume you don’t have any other lasers or control boards plugged in to your machine?

If it is running GRBL under the hood, then it could very well work with LightBurn.

I don’t have much Linux experience, but you should make sure you have done the correct dialout group things, and in the end you should be able to see a COM Port in LightBurn that you can select. Then we can play with which exact GRBL version you select in LightBurn as your device.

No, this is the only laser connected.

I didn’t see a COM port listed anywhere, but when I went to manually configure the laser there were several GRBL options and I was given the option to connect over serial/USB.

I tried all the GRBL/gerbil options in the list, and I didn’t get a response from the laser on any of them using the Move panel, but perhaps I just wasn’t testing it right?

I found the console panel, and every combination of GRBL/gerbil and tty has the following result: The console just says “waiting for connection” and nothing else, and the laser reports as ready.

I see from here: Only partially connectivity to GRBL I’m supposed to get a prompt, so it doesn’t seem to be working.

To make sure that we are on the same page:

a) you are trying to use a machine that we have never interacted with before and are trying to figure out whether it can work at all, while
b) you are simultaneously using Linux, which may require additional things like this:

This is the part that you need to address first:

It would be easier if you had a windows computer and we could get over part A first, then if successful, we can work on part B.

is it really a chromebook? I didn’t see any statement that it was.

Here’s my $0.02

  1. disconnect the USB cable from the computer
  2. disconnect power cable from the laser
  3. connect power to the laser and power the laser on. Hopefully it has auto home feature and that works properly. This kinda says the firmware is working and homing switches are A-OK
  4. connect the USB cable to the PC and look at your console output to see what the device is. I will open a terminal window and type “dmesg” and see what the final output lines are. It should say something like “ttyACM0”
  5. make the device RWX to everyone just so we know it all works. Do this by typing “sudo chmod 777 /dev/ttyACM0”
  6. Start LightBurn and make sure you device setup is to access device ttyACM0 and when you select that you should see connection information in the Console tab in Lightburn.

If this works then you meerly have a permissions problem and something went wrong when you added yourself/userid to the dialout group. Or you were not connecting to the ttyACM0 but where attempting to connect to the virtual ttySx devices instead.

Neither did I, but that was the closest topic I could find that explained the steps for the setting the dialout permissions.

Thank you for your insight on this, Doug.

IIRC there are instructions for the group setting on the Linux download page… With any luck it was just a permissions thing as many people mistype commands and completely ignore error message return by the system. I’ll continue to help this user through the problem.

1 Like

you are trying to use a machine that we have never interacted with before and are trying to figure out whether it can work at all

Correct.

you are simultaneously using Linux, which may require additional things like this:

I have done that, and verified I’m in the correct groups.

sudo chmod 777 /dev/ttyACM0

Done.

ls -l /dev/ttyACM0:
crwxrwxrwx+ 1 root dialout 166, 0 Feb 4 12:50 /dev/ttyACM0

groups:
deus-ex adm tty dialout cdrom sudo dip video plugdev lpadmin lxd sambashare

I followed all of Doug’s steps, still no response or anything in the console panel.

It would be easier if you had a windows computer and we could get over part A first, then if successful, we can work on part B.

I don’t have a windows computer, but if it simplifies things I can try it with a Mac.

Mac is fine, give it a shot. We want that com port to show up.

Same deal with the Mac. “Waiting for connection” and nothing.

Where would I see the COM port?

This looks very much like the little ACAN, NEJE, Wainlux units and they’re all custom / proprietary as well.

My next comment was going to make sure it was running GRBL firmware or ID the firmware type and check the LightBurn support page to be sure it’s listed as supported.

Trick if you’re up for it:
1)open a console window in Linux and turn on your laser with the USB cable connected.
2)run minicom terminal into the ttyACM0 device using:
minicom -b 115200 -D /dev/ttyACM0
3) now send a soft reset command: ctr-x and you should see something like this if it’s GRBL:
Grbl 1.1f [’#’ for help]
4) if that doesn’t show up, power the laser off and back on and see what shows up on the console.
GRBL shows “ok” and you can send it $$ and $ commands to get information about it’s settings.

Ctr-A-Q will allow you to quit minicom

1 Like

No response to crtl-x and nothing showed up when I restarted the laser.

seems doubtful it is GRBL then. Have you asked the vendor for a GRBL firmware?

I asked and they never responded, so I guess no dice.

Thanks for all your help!