Laser not firing even after replacement of laser

Hello all,
So here the situation. I was using my engraver and all of a sudden started engraving weaker and eventually just gave up and fully stopped firing. So i figure the laser burnt out and bought a NEJE 20W Engraving Module as a replacement.
So when i got it i followed the instructions in the thread on how to attach it my machine.

It still not fire or even turn the laser on. Ive tried updating everything and checked the connections so i am at my wits end on this. here are pictures of my connections maybe i messed something. note the connectors used on the wires were recommended to me by my girlfriends dad who does way more electronic things than i do, as i am a hobbyist at best when it comes to wiring

OK i just relooked at the amazon listing and it saying the green wire is the temperature wire where as in the diagram in the linked thread is saying the temperature wire is the red one. did i just connect it wrong?

Probably. Red is almost always +12v. Black is almost always ground (Even in the crazy Chinese color coding scheme).

Is this the image you were looking at?


If you got the module you posted a link to on amazon that is the 20W module that is in the top of the picture. Looks like you followed the wiring for the 40W module. :flushed:

you are correct i think i have it figured out going t o change it out in a few and see if i fixed it or not

ok so we rewired it and now the fan kicks on but the laser still doesn’t fire. the laser has a soft blinking red light that is on but not firing. when i run something i lightburn it goes to the spot and then just stops with out firing the laser

updated wiring picture

this is the video of what i am talking about.