Laser not firing the Same on Rotary

I am having issues with the laser running differently when using the rotary vs running a flat item.

The latest problem happened when trying to run some JDS Leatherette with the foil.

The settings we settled on that we liked the most for the one with gold/silver are; Speed: 6000mm/m, Power: 15%, Passes: 2, Interval: 0.080, Constant Power: On, Over scan: On +5%
ETA: Xtool D1 Pro 20 watt, with a RA2 rotary

When we did the tests on the flat pieces of leatherette we purchased to test out, everything is coming out perfect with the settings we are using. BUT when I switched to the rotary to do a final design run on one of their leatherette wrapped tumblers it came out horribly.

I did another test on my flat leatherette and it ran great. I swapped over to the rotary, used the exact same file and it came out horribly again with the delay showing in the firing of the laser in comparison to the flat. It also takes almost twice as long on the rotary as it does on the flat

I have tried adjusting my speed down with different power settings but anything higher than about 1200mm/m is giving me this issue, and 1200 is incredibly slow. Its almost like the laser is not firing fully until it reaches almost the center of the design instead of right away.

I also have the same issue on powder coated tumblers though not as noticeable. I uploaded some photos below. And I also have some videos as well showing the difference in how the laser fires. The videos show the exact same file ran flat and then ran on the rotary. Same settings, same everything.

The two videos are here in this playlist

rotary setup

Take heart, It should absolutely run at a different speed, especially if it’s a roller type rotary. If the Cup isn’t belt tooth driven it can’t move like the other engraver parts

I think i see what’s doing this. It’s moving along ‘Cup-vertical’. It’s accelerating at the top and bottom of the image being engraved on the cup. It may be reducing power because it’s not at the requested engrave speed. In the second video, you can see the engrave head decelerating, the flashes of light getting dimmer as the engrave head decelerates and reverses.

If you timed 20 lines with a stopwatch you’d probable see the effects of the deceleration. I might see it in the GCode LightBurn sent to the engraver. If you’re interested, in LightBurn, click File, click Save GCode. This file will be a little too big to share here. Please open a new text file and Copy the first 50 lines of the GCode out of the GCode file and paste it into the text file to share.

You can attach the text file to a reply by dragging and dropping it in here or you can use the Upload button in the reply box to share it.

I hope i can find it in the first 50 lines. :slight_smile:


gcode.txt (685 Bytes)

Thank you! This rotary does have a toothed belt, it is the RA2 Pro from Xtool. Other people who use it have said they can run things at the same speed that i am trying to do.

I don’t see the starting info in the first 50 lines. The Beginning and the setup are where several key parameters are.

sorry! here is the correct one

gcode2.txt (752 Bytes)

1 Like

Absolutely. The toothed wheels that the belt runs on take a lot of force to make them slip so they can accelerate quickly. The Tumbler doesn’t have the same grip on the roller as the toothed pulley does, so that tumbler-to-roller surface (without teeth) is the weak spot.

Chuck-driven rotary engravers allow you to drive the tumbler directly because the tumbler is fixed to the chuck which is fixed to the toothed pulley. The whole works is much heavier so it’s a trade-off.

It’s not the speed that causes stuff to slip. Acceleration is more to blame. It looks like acceleration is turned way down, which has plusses and minuses.

I see a fairly small line interval (0.037-0.038mm) which is a little less than (.0015") that’s 660 Lines per inch.

It could be an artifact of the rotary roller and how it’s set up, or it could be a setting.

Please double click ‘on the layer’ in the Cuts / Layers window to open the Cut Settings Editor. Please capture that window.
Whatever you used in the first post to capture those screen-shots worked great!

The acceleration is a further curiosity.
I’d like to look at the Machine Settings report.
In the Console window in LightBurn, Please type the Following:
then press Enter.

Please Scroll back in the Console window and Select the report from the $$ to the end, copy the selected text and paste it into a reply here.

  1. $$ ok $0=1 $1=0.03 $2=0 $3=0 $4=0 $5=0 $6=0 $10=255 $11=0.0 $12=0.0 $13=0 $20=0 $21=1 $22=1 $23=0 $24=25.0 $25=3000.0 $26=250 $27=1.0 $30=1000 $31=0.1 $32=1 $100=100 $101=100 $102=0 $110=18000 $111=6000 $112=6000 $120=2500.000000 $121=300.000000 $122=300 $130=432.000 $131=406 $132=0 ok

Did I grab the right images or do I need some others?

1 Like

You’ve enabled ‘Constant Power Mode’. The switch is on in the Cut Settings Editor and the M3 command was sent in the GCode. This can be seen in line 17 of the screen capture in post #6.

Agreed, the Laser does not appear to be delivering constant power.

I found this post from another community member saying that M3 Constant Power mode is not supported by xTool D1.

Just to make things ‘interesting’ xTool has limited the speed of the Z-Axis rotary along with speed limitations on the X-Axis. Others have also discovered that it’s limited to the 1200mm/min as you observed.

I haven’t tested it, but I have read that the Y axis rotary control isn’t locked the same way. There was a Hint toward that at the end of this article:

and here as well:

I haven’t found the settings for Y-axis control but that might allow you to move past the ‘interesting’ feature that xTool added.

I’ll attempt to figure out why the LaserGRBL wants 12,800 divided by the circumference of the object as the Y-Axis travel resolution.

Oh wow, I guess I will give the Y-Axis a shot and see where that gets me? I wonder why others don’t have issues going at higher speeds using the same equipment. And if constant power mode isnt doing anything i might as well turn it off.

I went looking here and found 4 or so reports of the 1200 mm/min speed limit. I selected the Xtool d1 pro post - Linked above to offer that it’s not happening to just you.

I feel it will be beneficial once the Y-Axis is calibrated for the rotary.

I will give it a shot! I’m messing up a mirror right now, but once I have it down I should be able to test the y-axis tomorrow.

It took me way longer to be able to test it out, but it works so much better after switching to the Y-Axis. I have to make sure to tell it to mirror output now, and I have to redo all of my earlier test grids but its so much faster.

Thank you so much for your help!

1 Like

Great, Glad to hear it!
Please share your X-Axis and Y-Axis settings when you get it set up. It will certainly help others get up and running.

The only thing I had to do was change my rotary setup from X-Axis to Y-Axis and select “Mirror output to Rotary” I left everything else alone.

I have noticed if I enable the rotary then move my design around then my little green origin point moves in a mirrored opposite direction until I disable then re-enable the rotary. But I can also hit P and it centers everything all together so its really just a minor annoyance at worst.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.