Laser position messed up

Hi guys, I have been having issues when trying to print and cut on paper and I can understand why this is happening. Basically I have followed through the print and cut video setting the wizard with both reference points. All good to this point, but when I go to preview my design does not show at all. Something that I have noticed is that the laser position in the lightburn software is messed up, and the job origin is also messed up. I do have it set to absolute coords.

Actually why does my laser does not center it self in the center of the actual working area? If that make sense…

Maybe you found a solution here:

Apparently Snapmaker has been messing with the GRBL and G-Code conventions everybody assumes should work:

So it may be broken as intended …

1 Like

Is there a way around Absolute coords for print and cut? Like a way to set reference points and still manage to cut a specific location?

You might be able to set a User Origin at the machine’s home position and use that mode, but I have no idea if that will (or ever did) work on a Snapmaker.

@berainlb: Am I overlooking the obvious, like a coordinate system offset affecting everything else?

What Snapmaker device do you have?

You list GRBL as the controller type in your profile. If you indeed have a GRBL based Snapmaker device can you run these commands in Console?


I run an Snapmaker Ray 40w. It’s GRBL based, I did run that code and I think it has reset the home position or something like that! But still haven’t been able to do a print and cut. I have taken a video showing the whole procedure… maybe you can spot something that I do wrong…? But I can not upload it here though

Ok I have made a progress! Now, the machine working area does not much the lightburn working area. How to fix that?

I have manage to set the wizard and found it in the preview window. When I started the job it did the indeed shape cut but in a completely wrong location.

These commands wouldn’t have reset any persistent configuration. These should only output data. However, the first command homes the machine which would re-establish your origin position. If that gave you different results that makes me think that you’re losing steps somehow.

Are you by chance moving the laser head by hand at any point? If so, that’s not going to work as that will cause motion that’s not tracked by the controller. Use the jogging controls in Move window or on an offline controller exclusively after the machine has been homed.

If that’s not the problem, then run these commands and return the output here please.


You can host the video at a 3rd party site and link here.

What is your expected machine area?

Can you take a screenshot of Edit->Device Settings?

1 Like


I run the codes, it didn’t do anything as far as I can tell… same outcome as before. I uploaded a video that I took while going through the wizard to set up my reference points and got a link with We Transfer.

Here is a print screen with my Device Settings.

By the way thank you guys for your time trying to help me out! Much appreciated!!




Another think, here is a screen shot of the lightburn. Please notice the laser position, note that its in Absolut coords. And the second screen shot shows the actual laser position. The two of them do not correspond. Isn’t that an issue as well?

I need you to run the commands, then once the commands return output to the Console, copy the text output and return that in a response here. I need to see the output.

It seems the upload failed. Can you try again? Make sure that the upload complete before pushing the Reply button.

Position of laser head and Absolute Coords is not directly correlated. However, I suspect that your laser is not configured properly. It seems that the Ray is shipping with an incorrect configuration. I have not seen anything definitive that explains how it should be setup. There are a number of Topics here with the same problem.

Take a look at this one.

I’d suggest not simply applying the listed fix as your conditions could be different unless you first work through the entire Topic and confirm that you have the exact same situation and output from the commands I requested earlier.

Its strange, from my site it seems that the screen shots have been uploaded.
I’ll try again below with device settings

Here I have run the commands and below is the output










[I][PLAT]Machine: Snapmaker Ray Controller

[I][WIFI]Mode=STA:SSID=:Status=Not connected:IP=






























































This puts you in the same position as the others.

Try running these commands. Then test again.

G10 L2 P1 X0Y-400

I thing it worked!!
I will try a testing to make sure. Do i need to run this codes every time I open lightburn though?

Nice. Let us know how your testing goes.

No. The changes are permanent until you actively change them again.

1 Like

It worked! It totally worked! I really want to thank you guys for your help! I appreciate your time and effort so much! It means a lot to me! Thank you!!

It works perfectly, now I finally can communicate with my laser fully!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.