Layer's colors on canvas drawing priority

Why not all colors are drawn as i would expect them to?
some colors are drawn on top of the image, and some are behind it. what am i missing?

And I see more related issues with layers.
In a new project i am working now, I have three layers, each with a different color.
when done - all looks good. when i save it and reopen it - something gets messed up. one of the layers wont show on canvas - it’s there in the cut info window but reordered on canvas. i will make a similar project and share it here. i don’t know how will it open on your side since as i said - saving and reopening is not working as it should.

Ver 0909 (Most latest up to this moment 0909…)
Stay tuned.

Here’s what goes.
This is before saving LB project

This is what opens up

Preview is always showing the correct outcome and the cut info window is showing the same layer order, but the canvas is not showing all layers as they were at the time i saved them. the image is taking over and blocks all that is “behind” it. this might be on purpose but is not making sense to me. please correct me if I’m wrong.

4Oz2.lbrn (117.1 KB)

Things are drawn in the workspace in the order in which they are created or added to the internal drawing list, not the order of the layers. You can select an item and press Tab or Shift+Tab to move to the next / previous item in the creation order. If you turn off all cut optimizations, this is also the order that things are sent to the laser. There is no requirement that layer order be respected - it’s an optimization setting like many others that affects planning of the job, not how it’s stored.

If you want to change the drawing order, use push forward / back or push to front / back:

Hi Oz, Why LB opens saved project differently to begin with?
And this push back/front order does not work for me. maybe i don’t understand how to use this but if i select the text and push forward i expect to see it in front of others but this is not the case - i see no change on screen. I wonder if one should practice this routine each time opening a saved project. I think that LB should at least open a project as saved. it’s like opening a different project. Yesterday i worked on few designs and today i opened them and couldn’t recognize them. during few first seconds i was quite sure the files got corrupted and i need to start all over again from scratch.

Hmm. I just opened LB and put a few shapes and some text on screen and I couldn’t get push forward or back to work either. Everything just stays in the order it’s drawn.

1 Like

The ‘Push to…’ features are working in my testing of 0.09.09 on Mac. Imported image, then created some text that overlapped the image and is seen on top of the image. Duplicated both and move copy below the original. Then I selected the new copy of text and selected ‘Arrange’→’Push to Back’.

Notice how the text on the set below is now behind the image.

And then a third copy, pushing the text back to the front using the ‘Arrange’→’Push to Front’.

You may need to execute these “Push” moves multiple times to get them in the order you’d like.


I practiced the very same in my test case above. This does not work on Win10/64/Nvidia.
Maybe this got to do with Nvidia driver settings? …

And @Rick
Care to save your test in different layers positions (front/back) and reopen these?
I wonder if on your mac you get to see what i am talking about which is you save a state and when you reopen the project the layers are all messed up - For exp the image, even when saved behind the text, when you open your project it will block the text - being in-front of it.

Nope. Can’t get it to work on Linux.
I tried several images along with several drawn shapes and text. Clicked move to (up/down) about 50 times on each selected object and can’t get any of em’ to budge in any direction.

1 Like

Changed layers, saved and reopened. Not seeing what you are.


And your file opened with my Ruida profile.

And with a Smoothie profile (no adjustments to your file).

Just to be clear (I assume this is misstated - “Clicked move to (up/down) about 50 times”), you want to use the tools found under the ‘Arrange’ menu. :slight_smile:


Are you using the menu system or hot keys to execute these commands?

@Rick Could i be missing a setting somewhere to make my project open the way it opens on your end? we are experiencing very different results.

I’m sorry Rick, my bad wording. Yep I’m using the 4 “Push” (wherever) tools shown in your photo. No joy with the hot keys either.

Edit to add: Interesting that the hot keys in your photo show up/down arrows, and in my menu it shows “PgUP”, “PgDown” “Ctrl+PgUP”, “Ctrl+PgDown”.

Odd, that when there’s a menu window open I can’t get “print screen” to work. Works fine when there’s no menu window open. :scratching head:

No. This is not something controlled with a setting. Are you saying that you can not get the same result doing the simple test I shared above? Show me, and please post your test file.

Edit: I went back and reviewed this thread. I now see that the image posted by @Squid has fill-render on as well, so yes…there is a setting. Turn this off and you should be able to reorder the artwork.

This is very odd. I am going to have to wait for some feedback from behind the curtain on this one. @LightBurn?

Hi @Hank , Care to try my test file i shared in this thread, open it up and screenshot how it opens up for you?

Same here.

This Arrange menu on Oz’s Wintel machine looks the same as on Hank’s and my machine.

Hank - are you in filled rendering mode? In that case, rendering do happen by layer, and has to in order to resolve ‘holes’ in shapes. For example, if you have two circles, one inside the other (the inner one being a hole in the outer one), and you push one of them backwards in the drawing order, what does that even mean?

If you are in wireframe mode, the push to front/back features work as expected.