LightBurn 0.9.08 (and now 0.9.09) - An early holiday gift for our users

thanks for that

Yes it does.

Not yet, but the intention is to update the tool soon to allow it to remove an existing fillet, which would let you remove and re-insert with a different radius. There are no properties stored for this - it’s baked into the shape.

@Rcdeck:
image
Or…
image

Yes - It’s now an option in the prefs, so you can set it however you like. (Edit- I see Rick set you straight).

1 Like

For anyone who has downloaded this, please do another update check and pull 0.9.09. A bug was found that was an interaction between a bugfix for grouped text-on-path objects and the new snapping behaviors that could cause issues with selecting text, and making your selection bounds wrong.

It wasn’t destructive in any way - none of the incorrect information is saved to your project file, as it’s all just stuff used for selection and interaction, but it was really annoying when it happened.

0.9.09 is out, and if you don’t see this message, 0.9.08 should tell you it’s available tomorrow. :slight_smile:

1 Like

Hmmm okay, pulled down 0.9.08 and 0.9.09 this morning and now it seems that my usb/serial connection for GRBL device is no longer listed as an option to use.

It’s getting power, because I can hear the motors start up when I plug the cable in, like usual, but the connection still isn’t listed in the devices section.

I am Mac-tacular and as I said, 0.9.07 was working fine. Yes, I have restarted between versions :slight_smile:

Anyone else seeing this feature (maybe it’s time for CO2?)

Edit: going back to 0.9.07 and the port is available. “Cu.wchusbserialfa120”. If that helps

Thank you so much for this release! Really appreciate all the added features and an extra thank you to adding the new shortcuts :slight_smile:

I have one problem though: framing now always gives me the out-of-bounds error. When I actually start the job (with laser power % set to 0 so it doesn’t actually burn), it runs fine. I always use Cut Selected Graphics, Use Selection Origin and Start From > Current Position. Using Ruida RDLC-V8.01.56. Lightburn 0.9.09.

Edit: I see a post about this has been made on the forums, so i’ll hop on that thread. You can ignore this comment!

A post was split to a new topic: New snap behavior question

Hi and thanks for this software and this update. Looking forward to using it! I am anxious to check it out. :slight_smile:

Another truly amazing update, this has become the best one stop package I have come across. Well done to Oz and the team.

Cheers

David

Fantastic.
Thank you for all new features especially for double click middle mouse zoom - very useful.

Hi Ben - this was reported by another user as well, with a very similar device. Mac ports were being filtered to remove bluetooth devices, as that was crashing some systems (they’d lock up and not return for a while when device scanning). I filtered out anything that wasn’t prefixed with ‘cu.usbserial’ not realizing that the device names were pretty arbitrary. I’ve changed the code and will be posting a patch shortly.

1 Like

Post edit: 0.9.09 has been updated to include fixes for:

  • MacOS port filtering being too aggressive
  • Ruida frame bounds checking not working (this is now on a switch to allow for wider testing, defaults to disabled, and you can now choose to run the frame anyway)
1 Like

A post was split to a new topic: Continuous jog bug in 0.9.09

Thank you, Thank you. Have not had a chance to look at any other update but the preview before open is the best thing since sliced bread. I have spent the last several hours opening and then resaving many of my projects and images to get the previews. This is going to be a tremendous time saver and one step closer to being my only laser program. Again, Thank you.

2 Likes

Confirmed patch for macOS usb/serial port is now working as usual (in the wild)

Love your work!

I just tried the re save option to get the pre-view in windows and it worked only with the very first project I saved. It hasn’t worked with any subsequent saves. The file icon is just blank as before - any ideas?

Thanks

David

3 posts were split to a new topic: CSV file not reading in 0.9.09

If the file in question contains only images, they are previewed as simple rectangles, not images. This is something I’ll be adding soon.

Ok, fine. The only one it seems to have shown correctly so far is a traced image. No problem.

Thanks

David

I have opened about 150 projects that I previously saved in LB last night and resaved them to obtain the preview. I am burning wood, glass, acrylic as fast as I can for a vendor booth this Saturday and now doing so with 95% LB because of this preview feature. It works great and my library has already grown by about 25 more items created or traced and saved last night.

2 Likes