LightBurn 0.9.22 and Mac OS Big Sur

Hello, I upgraded to Mac OS Big Sur and downloaded the appropriate version of Lightburn and the camera won’t update overlay. I see the laser bed in the window but no overlay. I tried running camera alignment and I do all the steps and when it’s time to CAPTURE IMAGE, nothing captures… I’ve checked all the privacy settings…

I guess no one answers…

Sorry, this slipped through but the issue you present has not. I just did a search to find @LightBurn is working this issue.

Any updates yet? I’m having this exact issue right now.

Quoting our latest release announcement: LightBurn 0.9.23 released - a lot of fixes, an apology, and some news – LightBurn Software

There is still an apparent issue with camera use in Big Sur on MacOS - It’s quite possible this is a problem with the framework LightBurn is built on, but we’re actively working on it.

We’re seeing a bunch of issues on Big Sur. Camera is one, and connectivity with some lasers (specifically Ruida and TopWisdom) is another. I’m looking into it, but I don’t see anything concrete yet. I would suggest the best course of action would be to revert back to Catalina for now.

You guys have a heck of a nerve continuing to sell your cameras with no warning to Mac users with Big Sur. I have a brand new MacBook and just received my new Lightburn camera today. I’ve spent about five hours trying to get it to work only to find out you know it doesn’t work with Big Sur and you sold the camera anyway. You should have big red flashing lights that say there is a known issue with Big Sur we are working on this. And besides the camera not working I pretty much can’t send files to my laser. I downgraded to 9.22 but that has issues also. I constantly get a file error “laser is busy”. What happens now is somehow I end up with a temp file on my laser and I can’t send any files to it. I have to shut it off, reboot. Reboot Lightburn and then try three or four times to send a simple file and finally I can send one. Please please fix these issues foe Mac users.

This won’t help your camera issue, but should help sending data to laser.

ok- I tried the Big Sur version this morning. at first it worked for transferring files, but now after cutting, I am trying to send an updated version of the file and I get File Transfer Faild. There was a problem sending data to the laser. The machine may be busy or paused. I try hitting ESC and then try again and get the same error. I will download the Older version and try that.

Nope- same issue with the Older version with my Big Sur OS. I cannot send files to the laser. I am able to update Overlay with the Camera using the Older version, but not with the Big Sur version of 9.23

Do you have more than 1 computer sending data to your laser?
Is your connection to the laser wired or wireless?

No- I only have one computer. it’s a week old. I upgraded it because I thought my old computer was the problem with not being able to send to the laser! I am using the USB cable to send.

by the way, I’m having the same problem with 9.22. Usually I get the file transfer error and I can escape a couple times and eventually it will send. right now I cannot even do that. I sent a file about 20 minutes ago using 9.22. I was able to cut. Now I am trying to send a revised version and I’m getting the same error and esc will not work. I closed Lightburn and re-opened. still cannot send.

How many files do you have in the controller on the laser? You could try deleting some and see if you can get a new file to transfer.

Also from an old message…"Putting a file on a USB stick is easy - click “Save RD File” (below the stop button) and save the file to a USB stick. That’s it - you don’t need to set it up as a USB device in LightBurn - that’s only if you are connecting to the machine with the USB cable, not for using a USB stick.

Thank you Ralph.
ok- I deleted all the files on the controller, we’ll see if that helps. I have no idea what you are talking about regarding using a USB stick, I’m not using a USB stick nor do I plan to. That is a pain in the butt.

The USB stick was just an option that was put in a message by OZ back in 2019. I get what you mean about it being a pain, but it would be another way to eliminate potential problems.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.