LightBurn Bridge LightBurn Camera integration?

I just can’t seem to get this to work. Unsure of what the issue is, but I can connecto to http://lightburnbridge.local/ with no issue, but using http://lightburnbridge.local:8080/?action=stream gives ERR_CONNECTION_REFUSED page. I’ve exhausted my networking knowledge with ensuring my firewall is allowing connections to 8080 through TCP and forwarding the port to my interal IP of the Pi.

Is there any sort of posts about where they are with LighBurn updates, like the camera intergration?

When you connect to the lightburnbridge.local address, do you get the status page?

What does it show? Screenshot would be nice.

It looks like, and I’m not PiSpert that it doesn’t have some kind of access or that you don’t have access to that port. I’ve also seen that when I’ve tried to log into one of the machines with a botched configuration and I can’t connect over the network.

Did this work?

If so, did the build/install of mjpg-streamer complete ok?

We know they are actively working on it…


Ok! Here’s what I see. I can control the laser with zero problems from my upstairs PC and the PC in my shop. Digging through other forums, I tried running some other sudo commands to see if they’d help, but nothing has worked. I’d would love for this to be a simple user error, hah.

Did the mjpg-streamer build/install?

Is the ‘streamer’ running?


Seems to be running? I restarted it, then tested it as well. Although the red text gives me pause :slight_smile:

It’s not executing. Try doing the steps in the .sh manually. I had the same issue and didn’t chase it down.

From a terminal that I ssh’d to the Pi, I enter these by hand…

cd /home/pi/mjpg-streamer/mjpg-streamer-experimental
mjpg_streamer -o " -w ./www" -i " -r 3840x2160" &

It doesn’t restart on its own. I get the same error, I’m sure it’s some form of protection level on the Pi.


You sir, are a gentlemen, and a scholar! It works! Hah. Thank you! Ok, so every time I need to run that to kick on the stream?

I just realized why neither of your services are working properly. I missed a step in my initial instructions. You need to run:

sudo chmod a+x /usr/local/bin/

The script doesn’t have execution permissions otherwise.

1 Like

LightBurn sees the OBS Virtual cam, but doesn’t display anything. Works great in OBS and now when I load the stream via the web. The last piece of the puzzle! Soooo close. Hah.

What version of Windows are you using?

Win10 Pro (64bit)

Also what are you guys running for frame rate on your camera from the pi? Mines currently 4K x 30fps and I think it’s a bit too much for the little guy to handle. Getting soft temp warnings and some hard boots from the pi. It’s only air cooled no fan or heat sink, but I could easily add one if need be. The pi on my mk3s runs at 30 just fine. It’s an actual pi cam camera though so resolution is likely lower.

Threw the Pi in case with a sink and fan. Much more stable now. Pi doesn’t push past 42 c now. Now, if I could get Lightburn to display the OBS Virtual camera image, my laser life would be complete :slight_smile:

You have to have OBS running on the lightburn machine…

Notice mine states ‘OBS Virtual Camera’ in the Lightburn window…?

I’ve had intermittent issues with it not showing the video. The worst turned out to be the laser was in the dark, lol.

Might try restarting one or the other… Mine has been pretty stable, so I’m not complaining. Haven’t figured out to drive the OBS software either…


I have all that visible in LightBurn. I select it and there’s never an image. I’ve tried running OBS as an admin, same with LightBurn. The virtual stream is running. Not sure what the disconnect might be.

Ensure you go to OBS and click on ‘Start Virtual Camera’ or you won’t see it in Lightburn…


As mentioned above, it’s running! Must be something permissions related.

Needed to start the virtual camera?

Don’t think the feed exists if you don’t enable it. So Lightburn can’t find it…


Sorry. Meant that the virtual cam has been running the whole time. So it’s not that, haha.

So the only thing I might guess as a possible issue is that my local PC has a camera attached to it. It’s listed in the drop down of camera, and actually does show an image when selected. And yes, OBS is running and so is the Virtual camera stream.