Lightburn for galvo not working

I am trying to get lightburn to work for my fiber laser but when i try to look for my device it does not find it. When i check my device manager it shows up in a section called BJJCZ device as a laser mark control board (usb). My laser is a cloudray 60w jpt m7 mopa 300 x 300 fiber laser if this helps. I have watched multiple videos on how to set up the software and followed step by step. I will much greatful for any help. Thanks.

Hi Wesley, which software from cloudray do you use. EzCad 2 or EzCad 3 ?
EzCad3 cards dont work with LB

Hey Michael. Sorry i forgot to put that. It runs off of ezcad 2.

Hi, i have the same laser source JPT m7 60w, and i cant select more than 400ns pulse duration (the source it has 500ns)
I select like source the JPT and IPG_YLPM, is the same for both.
Thank you!

Hi Wesley, please read this topic :slight_smile:

I went and followed the directions on how to move the drivers using zadig and it worked, but it still wont find my device on lightburn. When i try to manually put in my laser it still does not work and says my laser is disconnected. Still not sure what to do.

Hi Wesley, i have many EzCad Cards here and i can say :

Only Cards with v4 or newer v2 in the pcb-name can speak with lightburn. My cards, that have the version number v1 or v2 ( old cards ) won´t work with LB.

The v4 versions have the dongle for ezcad on board. If you need a external dongle for your old ezcad, i think you need a new v4 pcb or lightburn will integrate the v2 version ( old ) in a later upgrade.


Oh shi… and what i can see… i have problems with 32bit win7. Under 8.1 64bit runs the Fiber-M and under win7 no chance :confused:

I’m experiencing the same issue, tried uninstalling the driver and installing the drive LB provides but that does not solve the problem. Device manager sees BJJCZ and my board is V4 but LB will not connect to my laser. (JPT 50W EZCAD2). Good thing i opted for the trial instead of $150 that will not work. Looking forward to finding a solution, EZCAD2 is garbage!

I have the same problem, before updating the version to galvo, it detected it, and it said to update, once done, now updated the laser does not detect me either.

Similar issue here, just bought a cloudray 30W and paid for the galvo update. Never got the screen that the video shows to download the lightburn approved driver. I am also running V4. I had previously today downloaded EZCAD latest version. Windows did not recognize the laser, I then tried to find the drivers on Lightburn, what a joke. I went onto EZCAD site to update drivers, no joy. Finally I went onto CloudRay and downloaded the driver, now windows says all is wonderful, Lightburn has other ideas and says I have no recognizable lasers. At the end of my rope. This is starting to be far far more work than what the videos (which I tried to follow but seem to always have screens that either magically appear or are of a different version that what i have.

If you were successful finding the laser once, please explain why you are trying again? This is not needed and will not find again. Do you see the profile you first successfully made in ‘Laser’ window profile drop-down near the bottom, lower-right?

Welcome to the LightBurn forum, and thank you for reaching out - yet this comment is just rude and unneeded.

We produce documentation where we cover this “driver” issue in great detail.


This would be rude as you state but I NEVER got this screen. I have done the uninstall/reinstall the license twice over 4 hours, I have gotten the driver finally from the laser integrator (CloudRay) and STILL it is not recognized by your software even though Windows does recognize it. YES I did follow your Video and verified this prior to getting to this point. Is it possible that even with your uninstall/reinstall routine (done two times) that Galvo has not loaded? How do I confirm that my copy has upgraded to Galvo?

I got the screen when I executed the set up file on my Win 10 laptop.

Were you doing an upgrade or were you running the beta? I have yet to see any setup file from Lightburn.

To test it for myself I went to the folder where my downoads were and executed
LightBurn-v1.2.00.exe I agreed to the windows warning to allow changes to be made to the hard drive. I agreed to the file path suggestions LightBurn offered. I watched the install process. Then the set up screen appeared.

I didn’t remember precisely where/when I had seen it but I was fairly certain I had. I can appreciate how it may have been overlooked as boiler-plate start-up stuff with all the excitement and urgency around the Galvo release.

It is remotely possible that a strange build exists without the setup screen but I’d be astonished to see it in the wild.

Thanks to all your help enable this ancient luddite to get his system up and running on lightburn. I do appologize for my snarkiness as i tend to get very frustrated when things do not work right out of the box. Again thanks to all. Now I just have to figure out how to remove the fumes from my enclosure.

Had you not installed the version of the software that contained the galvo support? I replied to your email asking something along those lines, because that’s the only way I can come up with that you’d not be given the option to install the driver.

Have you tried the ‘Zadig’ method in the docs? LightBurn does work with Windows 7, but you might need to use the Zadig tool to do the driver swap.