Lightburn gcodes sending laser off the bed

Can anyone help me? I want to start using Lightburn with my Snapmaker 2.0. I’ve made the files just fine, but when I load the files on the machine the preview of the boundary is totally off so I have no way of knowing whether the laser is going to engrave in the correct place. On the last file I wanted to test something small, the boundary was within the material, but when I started the job on the machine it sent the laser to the far left off the bed! I’ve set the origin, so I don’t understand what I’m doing wrong. I’m sure there is a trick to the settings but everything I’ve read has confused me and now I’m stuck. Please help! I like to send my gcode via Wifi as access to the ports on my machine is very tricky, I also have an enclosure in the way.

I hold the Shift key down then click on the frame button, to check it’s where I want it.

I like to use absolute coordinate for most of mine, there are three options for this though.

Hope this helps. :smiley:

It’s doing all sorts of weird stuff now - I tried your method but it’s still not right. It’s now only engraving and not cutting :woman_shrugging:t3:

I wish I could be of more help, but my knowledge is limited.

Sounds like we need greater minds like @gilaraujo, @jkwilborn, and a host of others.

These folks are awesome, I’ve seen them help a lot of people.

Sometimes it takes a little while for them to reply, because they are busy helping others.

Hang in there. :smiley:

1 Like

Hi Louise, we need to “troubleshoot” your problem together. It will be nice to see what is going on on your screen, you can make some screen shots of a project. To me, it sounds a bit like your homing position isn’t really configious. How did you set up your machine?, Did you use Lightburn’s fine guide for gerbil machines?

Thank you anyway and thank you for tagging in the others - so appreciated!

So, I’ve attached a screenshot of my settings in Lightburn. I did the firmware update for the Snapmaker 2.0 with 40w laser today. I used this guide to add the correct device - Using Ray / Artisan / 2.0 with LightBurn | Snapmaker Wiki
I’m running on Mac. Ideally I just want to download the Gcode and send the file via wifi as I have little room in my office and having my computer cabled isn’t practical. I have connected my computer to the Snapmaker just to see if it would work and it did. My hunch is that there is something wrong in the gcodes being generated as the laser will engrave but when it should be cutting the laser follows the deisgn but doesn’t come on to cut. It’s also been doing some weird stuff with the boundary and moving things around e.g. have a look at the attached photo of a material test that I tried to run. It split the squares from the axes. So odd. Will also attach the gcode.

material (83.3 KB)

Any help much appreciated!

Your file looks fine except the writing. Whether it is an export/import error or something you have generated, I do not know.

I think @gilaraujo is needed here, he is a professional gerbil man.

The writing, and the squares being so far away from the writing - I don’t understand why they’re split up - so weird.

Is this the case with all designs you try to engrave/cut? Try running this file and see what the result is. Also see what your preview window looks like.

test4.lbrn2 (41.5 KB)

Hi John,
Sorry, it took me a little while to find time to run the file - I think you’ll agree that the result is bonkers - I took a few videos so that you can see what happens. First I ran the boundary, that was quite off. Then even after I set it you can see that the machine engraves beyond where it indicated the boundary is. I ran the test file - engraving is fine (be it off where it’s supposed to be), then it engraved the circle in the wrong place and the laser switched off for the rest of the lines!

If you’re using the Snapmaker A350, your bed size is wrong, should be 320 x 350, also disable pointer offset.
I’ve been using exactly the same Lightburn/Marlin profile successfully for the 1.6W, 10W and 20/40W lasers.
You should also be running “Start from” Absolute Coords.

Screenshot 2024-03-16 171808

Thanks Alan, I will give these settings a try

1 Like

Hi Alan,
So I changed all the settings, switched to the Marlin profile but it’s still doing something weird with the lines, photo included so you can see what I mean!

Luise, does a project with only graphics or only text have the same type of error? or is it only when text is added to some shapes? I have to admit that it is a bit mysterious and I have no idea what the reason could be.

Hi Bernd, to be honest, I’m not sure, I will try with only graphics and see what happens! I know, it’s so odd.

So, I tried with a graphic, the same thing happened - it’s like there is some kind of offset happening when it switches from engrave to line - it also didn’t do the line as expected. There should have been enough power/speed to cut through the piece of ply (2mm) but it only engraved the line. Files and photo for your perusal!
heart (60.4 KB)

When I try to open your file I get “nothing imported”, can you try to make that file as lbnr2 and send it again?, How does your preview look like from that heart? (besides that your focus doesn’t look that sharp)

As far as I know, Lightburn can’t recreate the vector file from the gcode. You can only use it as a sender of the gcode file to the machine.

Save Gcode and Run Gcode are the only usable options.

You need the .lbrn2 file.


I can import .nc files without problems, just not the one from Louise.