Lightburn MOVE tab, X going in opposite direction

After making changes to the machine settings in my 80 watt CO2 laser which is now operating exactly as it should, when I use the Lightburn MOVE tab my “X” travel direction is moving in the wrong direction. The “Y” axis travel is correct.
How do I change this in Lightburn

It sounds like you might have the device origin set incorrectly in LightBurn.

Can you share what it was that you changed? Was it all working as expected before you changed these settings?

I had a major crash in my 80 watt CO2 laser due to trying to add a rotary, see the very recent thread
“problems with my Ruida controller after trying to add new rotary”

You will see I had to change some parameters and that portion using the Ruida keypad now work perfect.
I did not make any lightburn software changes and I dont see where changes could be made to alter directions

For reference, we did a cold-reconfigure of the XY axes:

It’s highly like the origin is now in the wrong corner, because Homing was pretty much wrecked.

ok, since you mentioned device origin, I went back and changed from top left to top right and now it travels in the correct direction. I had seen that before while trying to find where to adjust the direction but the FOUR options didnt make much sense.

The four options are just which corner the machine homes to when you power it on.

The simplest way to figure out if you have the correct corner chosen is to use the ‘Click to jog’ tool in LightBurn:

Click that tool, then click wherever the (0,0) corner is in LightBurn, indicated by the little red square:

Wherever the machine actually jogs to is the correct corner. If I set up my laser wrong, and had chosen the front-left corner (shown in the pic above) and my laser actually went to the rear-right corner, then I’d change it to that corner in the device settings window instead, like this:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.