LightBurn not finding my laser

I am making baby steps, but I am moving forward. I was having trouble getting my garage computer Win 7 upgraded to LB ver. 9.09 and installing the FTDI drivers. So, in the interim I loaded LightBurn on my Win 10 laptop. I hit find my laser and it found my Ruida 6442 controller. After fixing my Garage computer I was able to download the upgrade and driver. Before I upgraded this computer I tried to find my laser and had no luck so I entered it manually. I thought for sure with the upgrade and drivers it would find my controller.
My question is… do I have to find my controller or can I do it manually? Will the software write/read my settings and everything else?
I have tried two usb cables one of which was working with my laptop. Shutting off the computer and the laser.
Thanks for reading this,
Bruce
I can’t wait to get using LB software. That is the only reason I took apart a perfectly good working laser.

I don’t recall having to set anything up manually with USB, but I did once I switched over to Ethernet. LB will read/write controller settings, but you don’t need to change these to use LB, as long as you were running well with RDWorks. You can right click the ‘Devices’ button in LB, and it will attempt to reconnect to your laser. Handy so you don’t have to close and reopen LB.

Blake, if your computer finds your device/laser you don’t have to enter anything. If it doesn’t find it you can try and add it manually. That is where it asks you how your controller is hooked up, how wide and how deep it is and where your origin is.
My computer could not find my controller so I gave it a name and configured it manually. Everything went well except when I tried to connect It couldn’t find it.
Thanks for the help,
Bruce

The reason that your computer could not find it might be the same reason why the manual add fails: the connection between computer and laser might not be OK.

Did you use ethernet or USB? Highly suggesting using ethernet instead of USB.

If using ethernet, please make sure your controller has an ip address in the same range like your computer. (E.g. pc = 192.168.1.10 and laser = 192.168.1.20).

If this is the case, try to ping the laser from the computer and see if that works.

JP, how do I find the ip addresses?

You actually set the IP address. It’s on the laser. This might help:

Oz, I did exactly like you said. My ip address is
192.168.1.23. I then set the controller ip address to 192.168.1.123.
Then I went through the whole manually find my device. Nothing, it couldn’t connect.
Thanks,
Bruce

How have you wired the network cable? You might have to run it through a router or switch, not straight to the PC.

It would also be worth trying to connect with USB with RDWorks, just to see if that software connects. If RDWorks won’t talk to it, there might be something else going on.

Oz, LED number 15 stays lite on my controller. It say 5 volt. Do you know if there is any documentation as to what these LEDs mean. I was just wondering it that was keeping me from connecting to the controller.
I will try connecting with Rdworks later tonight or tommorow.
Thanks,
Bruce

I already provided you some information regarding the LED in another topic of yours. Please check that.

And what if you ping your laser via your PC?
How to ping:

I also found this, maybe it helps:

Jp, I thought I replied to your post, for that I apologize. As for the led on the controller LED #15 it says 5volts. I have not seen anywhere that explains what the five volts error means. I am not sure that isn’t what is keeping me from finding my controller.
Yes the machine is working and cutting, but I still have many issues with my settings.
I did a Whatsapp with Gweike and they thought the stepper led issue is caused by my 36 volt supply. Only issue there why would the z axis be ok? I measured the voltage at the supply and it was 24 volts.
I have decided to take a break from the laser.
Thanks for all you help!

Those LEDs aren’t necessarily errors - you should have a +5v LED lit, because it means that the internal voltage regulator in the controller is producing 5v, used to drive the logic side of some motor controllers, active limit switches, etc.

Thanks OZ, that is really good to know

Jp, I thought I replied to your post, for that I apologize.

It’s ok. Just wanted to make sure you check your topics :slight_smile:

+5V is normal, yes. It means the internal supply voltage for the controller is present. See it as a power on LED. If this LED would be off, that would be a problem. Not it being on.

I still do not quite understand what the problem is now to be honest. In this topic you mention communication problems, the other mentiones hardware problems. I have read your topics multiple times, you mention the drivers and the error LEDs on the ruida, but like said I have no idea how to help you since I do not fully understand your problem(s). How did the comunication tips work out? Did you get some information for us?

Maybe you can elaborate using photos and/or videos to help us identify your problem?

Don’t give up just yet. Make sure to extensively describe what the problem is. We are here to help :wink:

Thanks JP, I keep trying things a they come up. I tried plugging into a different USB port no luck. I don’t have a router in the garage to run the ethernet through, so I will continue to work on my settings and try and dial that part in.
Thanks for all the help,
Bruce

I have a problem sending the file from LB directly to the Ruida controller. I just need to Run FRAME

Did click on find my device?

What does it say in the lower right corner?(devise name)?

I Run the Project from my PC…sometimes i try to just press Send to Ruida i will get a Error message saying “File Transfer Failed”. Then i Press FRAME, it outlines my Project and Now my Computer and Laser are Fully Synced.

How are you connected to the laser? (Ethernet, WiFi, USB? How long is the connection?)