Mac Networking yet again

Moved my stuff once again, made some changes, and now my computer and laser won’t talk…

Any help would be much appreciated. The only real change that I can see is that I no longer use device between the two, just a simple Ethernet cable.

I have attached some screen shots with my “numbers.”

Thanks in advance!


If your computer is connected to the net via WIFI, and you direct connect to the laser with a cable as well, I’ve seen that cause issues, though I don’t recall a specific solution. I’ve always gone through a router for mine.

MacOS is a pretty solid router in its own right. It’s not usually a problem.

Hey, it ain’t windows :wink:

The easiest way is to turn on internet sharing - that way you don’t have to configure anything else on the Mac.

I’m sharing my Ethernet over WiFi, you want to share Wifi over Ethernet.

That will populate your interface with IP address, etc., and set up the route. You don’t need to do this from the laser’s perspective, but it makes it a no-brainer on the config

Put your controller address in the same subnet as your wireless connection and the gateway address the same as your internet gateway.

That’s it.

MacOs handles all the routing and you don’t need to know the address of the ethernet port - you can find it out, but it isn’t visible at the user interface in settings.

All you need to know is that it does it all for you, as long as you have the laser controller in the same subnet and the gateway pointing to your internet gateway.


Turned on the internet sharing with no issue. Changed the numbers like (I think) I was supposed to, but still no connection.

Can you take a fast look and see if I am using the right numbers?

Honestly no idea why I can’t get this… I’m really not that big a dope.

Screen Shot 2021-03-23 at 1.11.35 PM

You have changed round on ip address and subnet mask ?

Thanks, Ok. I will reverse them and see if that does it.

Nope. Still get the same error message.

I believe the first 3 groups of 3 digits need to be the same as your computer and the last 3 different.
On your laser try
and for subnet mask

I’m not a network shark but your settings look a little wrong to me.
The picture with your controller should say something like IP address:
Gateway: (if this is your router you are running through).
Another thing that looks different as I otherwise know it is your Subnet Mask, it is “normal”

If your computer has a number, that is a self assigned number. That means you have not gotten a number from your home network, You should not be able to surf the internet or contact your laser unless they are both on a private network IP number set. 192.168.1.XXX for example.

He’s connecting directly from computer to laser. No home network or internet surfing involved.

ok, that explains a bit. Is it a connection without a router or switch ?, I wonder if there are some network professionals with the same Ruida controller who can enlighten us a little?

Thanks, but no luck. Tried your numbers and still nothing.

That’s where the issue came in.

I had it on a router because I had the internet and another printer on the same network. I moved to a new building where the internet is wireless, so I took the router out of the picture and just ran a cable between the computer and the machine.

There is a guy named Bo who always helps, and he keeps explaining it to me, but for some reason it won’t sink in.

(I think I am getting too old!)

To me, it sounds like it is a peer to peer network that has its own set of rules.
Bo will hopefully show up to help.


If you still want to use wifi for internet access don’t change any of the setting they are fine. The subnet in use for wifi is 192.168.1.n.

To configure the Ethernet port change it to manually configured as opposed to “use DHCP” then set the IP address to subnet mask to leave the gateway blank.

On the laser set it’s IP address to subnet mask again leave the gateway blank

That will put both the Ethernet port on your Mac and the laser on the same subnet and should work. As for wifi it will use a DHCP allocated IP address and will set the wifi gateway (which is what’s needed to connect to the internet). This should mean you talk to your laser over ethernet and talk to the internet over wifi.

Just to add a little more detail to this. A gateway is used to find an IP address that is in a different subnet as your laser and mac’s ethernet port are on the same subnet and the laser needs no access to any other network you omit the gateway.

Your wifi is connected to your home network and already has the correct setting so if it could access the internet before it will still do so.

1 Like

THANK YOU ALL, And Mr. Horsfall, thank you, that worked.

This gets so frustrating it’s idiotic.

I am going to have to see if I can buy something like Networking for Dumnmies.

Thanks again!

My pleasure glad your up and running. I spent a number of my years in IT and networking, it’s a very simple concept but can be a minefield in networks that have more than one subnet! Luckily most home networks are a simple single subnet and DHCP takes care of things automatically.

Your circumstance while I’m sure is pretty common was using a cable for the laser and wifi for internet so you just needed to confuire 2 interfaces (subnets) rather the more common 1 interface.