Monport K40 will not burn line unless Constant Power on

I just received my Monport K40. I have everything setup and using Lightburn. Watched the videos to be sure I was doing everything correctly as this is my first CO2 (with laser power off, connect to laptop, let Lightburn detect laser, workspace was correct finished setup)
I tried to do a material test in Lightburn, but nothing would burn, mA was constant 0.0, knob turned full clockwise.
I made my own material test. Power 20 - 45 step 5, speed 100 - 300 step 50. Shapes were set to fill, text to line. Shapes burned, text did nothing.
I began burning the number ‘8’ as a test. As long as it was set to fill it would burn, power & speed resulted in the changes you would expect. As soon as I change the ‘8’ to line nothing. 100 speed, 100 power, nothing. Change to fill 100 speed, 30 power, nice crisp ‘8’.
After much testing, My over scan has to be set to a minimum of 4% before anything, fill or line, will burn. Test firing using panel works for low or max power. The min power my laser will fire is 13%. I read that this should be approx. 4% for a K40. I set ‘8’ to fill power 12%, speed 100, nothing. Change power to 13%, nice burn. If I change the ‘8’ to line nothing, ran power up to 100% and nothing. Now I turn constant power on, still has min fire power of 13%, but lines burn with overburn on corners.

Have I done something wrong that I have to have a min of 4% over scan to get anything to burn, Min power to get laser to fire is 13% and lastly to burn a line, I must have constant power turned on? I’ve searched and not found aa solution. All help is appreciated.

I’d suggest you put it no more than 70%, I’d set it to 50%… if it’s going to fire, it will fire at either of those. I don’t think it’s a good idea for you to pulse your tube at 100% of some unknown current value.

I assume it’s a grbl board… (it’s in the grbl area) firmware usually announces it’s version and other information when it powers up or when connected to a console.

The console tab in the laser window should show this. You may have to Window → Console to enable that tab.

If you can copy/paste this initial information into a file or reply, it would help us help you… You can drag and drop some file types onto the reply window… Ensure you wait until it completes before proceeding.

The key to most of these issues hinges on what controller is in the machine.

I’ve seen these with a Ruida (dsp), numerous DLC32 (32bit) and Arduino (8bit) based grbl controllers…

If it’s new, it’s probably wired ok and it’s likely a software issue.

The first step will always be, is it the hardware or the software that is not operating as desired…?

So, has this ever worked correctly with Lightburn or any other software?

Might take a few to read this…


This is a brand new Monport K40. It is GRBL control board.

Waiting for connection…
Target buffer size found

LightBurn 1.4.01, windows 10.
As I stated this is a brand new K40, this is the first time I have tried.

Enter a $$ command in the console and post the results here…

Do you mind dropping the .lbrn2 file here also? I understand if it’s personal and/or proprietary, otherwise we like to see it for ourselves… :wink:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.