My Laser produce strange pattern. PWM Problems?

Hey There,

I am a bit desperate and hope that there is someone in this forum who can help me.
As the title say, my K40 produce a line-pattern and i don´t know why.

I run a SKR 1.4 Turbo with Smoothieware. I have tested the “2-wire-method” ( pwm from SKR to IN on Laser PSU) and Pin 2.0 (Servo-PIN) to L. The Result is this pattern.

I have also tested the “1-wire-method” (Potentiometer to IN and 1 Wire from Mosfet Drain to L). Same result.

In addition i have already replaced the Laser-PSU, same result.

I replaced the SKR with a new one, same result.

This is seriously driving me crazy. Does anyone have a clue what else I could do?
Of course I’ve already checked the steppers. The movement is smooth and no rattling.

Fun Fact: My cousin has the same setup and runs his machine without Problems.

Best regards,

same setup with same board? what about put your board on his machine to see if the issue is still there?

Of course I already had this idea, but he doesn’t want his setup to be destroyed. I understand him :slight_smile:
By looking at the pattern i guess there is a problem with the pwm signal.
when increasing the speed, the distance between the vertical rows increase too. So the interference frequence does not change, I guess?

Idk, maybe I’m missing something fundamental…


Can you upload the .lbrn files used to generate the burns? I’d like to know what these are supposed to look like.

What laser pwm frequency do you have configured?

Are you able to get photo of wiring and config file from your cousin’s installation?

Also, where did you get the firmware for the board?

1 Like

well, the setup is written into the board, so is quite difficult to destroy something, also maybe he has done a better cable managing and has no interference. Anyway engrave only a couple of parallel lines 200mm long with 3mm distance from each other.

So here is the file. its just a simple rectangle.

Rectangle.lbrn2 (2.7 KB)

that´s how it looks:

Here is my config:

config.txt (28.6 KB)

Here is a sketch of the wiring:

The only difference to my cousin’s setup is that he used a potentiometer between IN and the level shifter to limit the signal physicaly, as safety precaution. I also tried this, no difference. So frustrating…

@killrob, here are the lines, 300mm/s

btw, I notice here some swinging of the mirrorholder. I need to improve that.

is what i thought, is a mechanical problem no interference

I´m not 100% sure about that. If you look closely at the lines, the look mostly inconsistant. The horizontal rows in the rectangle look 99% regular.

That means the mirror is swinging only in one direction. Try the same line test on the other axis

Haven’t had a close look at the wiring diagram as yet but can you try a couple of things?

  1. Change this line in config.txt from 300 → 20:
laser_module_pwm_period                       20
  1. Does the appearance change if you go from 300 mm/s to 100 mm/s?

Some questions:

  1. I’m not familiar with the SKR 1.4 Turbo. Does it use 3.3V logic? If so, what is the purpose of the 5V connection?
  2. Can you confirm that 3.25 and 2.0 are pin numbers?
  3. Are you getting 24V power from the LPS or is that 24V out to the LPS?
  4. Is your controller modulating power correctly? As in higher power in LightBurn is higher power out of the laser?

So I made further tests, here with pwm 300

here with pwm 20:

  1. Yes, the SKR has 3.3 logic, The 5V is powering the HV-side of the level shifter.
    In general I made it like this…
  1. Yes, these are the Pins on the SKR.

  2. I tried both. An external one with shared Ground and the current version with 24V out of the LPS

  3. I think so. With higher % in Lightburn the engraving is deeper/darker.

The fact that the pattern changes with speed is interesting. I suspect there are a couple of things going on simultaneously.

Perhaps a mechanical issue that’s causing the inconsistent lines and maybe a scanning offset issue or a curtaining issue.

Can you try running a set of a bi-directional engraving with line interval set to 1 mm. Run it at the same 4 speeds in your previous examples. That will tell you if you need to adjust for scanning offset and may reveal other issues.

Also, you should try a test with scan operations at 90 degrees. Do you get the same artifacts or something different?

I will do more tests tomorrow and post the results immediately.
Many thanks in advance for your help!


So I was finally able to do more tests.

First I made scan operations at 90° and got this…

So this looks a lot better ! :slight_smile: It seems the pattern is only made by the x axis.
In the next step I made again 0° engraving with line interval set to 1 mm and got this…

That surprised me a lot! After that engraving I turned the laser off and made some 300 mm/s moves. The Stepper is vibrating like a love toy… :face_with_hand_over_mouth: Interestingly, I didn’t hear that. The faster the stepper, the greater the vibration, so this explains the greater distance in the pattern at 300 mm/s.

Unfortunately, I’m faced with the next problem. To locate the problem I tried this:

  • 3 different steppers, no difference
  • 2 different connection cables, no difference
  • 2 different stepper drivers ( 2208 & 2209), no difference
  • I changed the pins on the SKR, to exclude the malfunction of the driver socket, no difference
  • I tried different steps ( 1/4, 1/8, 1/16), no difference
  • I tried another firmware, same
  • I set up a brand new config, same

I’m running out of ideas :frowning_with_open_mouth:

You are sure? 300mm/s? I hope is 300mm/min anyway try slower, like 150mm/min, or 20mm/s

1 Like

Agree with @killrob, you should try at different speeds. Does the issue entirely disappear at lower speeds?

Some more questions:

  1. Can you describe more the stepper vibration you’re seeing? Do you actually feel the vibration only at the stepper? Do you get the same vibration on the Y under the same circumstances? What happens if you swap cable ends to the motors?
  2. The last horizontal line test, the top line there is going left to right or right to left? This looks like you have overscan set. At what percentage?
  3. Are you certain you have no wobble in your X gantry, the laser head itself, or in the lens/barrel? This looks more mechanical to me.
  4. Did you try different current settings for the motor in your config?
1 Like

Ok guys, I have news.
The y-stepper also rattles. While the stepper is installed you can´t hear anything. Smooth movements. But when I disassemble the motor and hold it in my hand it clearly vibrates. The reason for the visibility on the x-Axis is probably the longer belt (600mm).The rattling + the resonance from the belt leads to this pattern. But this rattling is still not normal.

I think it is unlikely that the 2nd skr board is broken. So maybe the drivers are the problem? I have tested the 2208 and 2209 drivers, and the Vref ist ~0.7 on both. This should be ok, for Nema 17 steppers, I think.

All steppers vibrate so can’t tell from your description if this is some sort of unusual vibration. If so, then most likely a driver configuration or compatibility issue.

Do engravings come out dimensionally accurate? So 100 mm in design results in 100 mm in the burn?

However, I suspect you may be able to work around the vibration issues if you can sort out the mechanical issues on your X.

Question, was your laser working normally prior to the board swap?

Where are you getting Smoothieware from? Have you tried C3D’s build?

i don’t know smoothie as firmware but for example, in marlin, you have to declarate which driver are you using for each stepper motor, maybe there is something similar in smoothie?

it vibrates when idle or when in motion? btw mine don’t do such a thing like this, but i use MKS DLC32 as controller with TMC2225 as drivers and GRBL as firmware.

This is a fascinating discussion. I will contribute my own experience in case it has any bearing.
By accident I dropped the laser diode head of my Sculpfun S9 on the floor. Thereafter it exhibited the pattern described above. Close examination under a high power magnifier showed that the head was vibrating in the Y direction. To test this I mounted the head rotated horizontally by 90 deg. Now the pattern showed vibration in the X direction. Yes, it was a mechanical problem in the laser diode head.

Desperate for a solution, since I could not wait for the replacement diode head from China, I tried my hand at repair. I carefully dismantled the laser diode head. I found that the grub screw which secured the laser barrel assembly in the bore of the heatsink was missing. I reassembled it, making sure the lenses were tightly secured, re-focussed the unit and put in a grub screw to secure the laser barrel in the heatsink bore.

That did it, the problem was eliminated and the laser diode worked properly, like new. In the mean time my replacement diode head arrived from China(at prohibitive shipping costs), making me the happy owner of two laser diode heads!

If my experience is anything to go by, mechanical problems are a likely cause.