Not finished lines when 1 pass selected

What i am using is clasic diode type laser for engraving .
I tried to set its power to max and got the same result. This is why i thought that delay on start would help. But it did not

First picture is one pass with settings i post
Second one two passes with same settings

It is focuser properly , only problem is that is just finish and start too late/ too early.

Edit: adding start and end time pause not helping .
It is like it just move itself first and than switch the laser on and like switch laser of first and than might finish the path

It is like it omits part of the line because if i set two passes it continues on the path and it just finishes erlier …

Device settings Marlin

The time delay you are playing with does not help in your situation. What does your preview window look like when you run a simulation, with only one pass?

In preview it is finished .

Would like also ask how can i reset optimization setting or where i can find default values i played with these because i really did not know what else try and got even worse results.

Photo unfinished circle , unfinished engraving, preview , optimization settings (would like to ask for defaults)

Thanks so much

It could very well indicate that you have pressed the big red button,

just a joke.

You have not activated the Tap function?

If everything goes wrong and you have nothing to go back to, you can always delete the entire LightBurn, incl. your machine profile and start on a fresh start.
It sounds drastic but it is not and it only takes a few minutes.

I am sorry but did not get the “tap” function.
Yes sure reinstall will solve the optimize functionality but not the gap in burning because it happens on fresh installation.

Hm ok. I need to chceck for which purpose is this because it does not seem familair to me.

Can I please ask you if you can share Optimization settings as well ?
It seems that the lightburn stores some settings files in different place than Program Files because after reinstalling ( uninstall install ) I got all the settings back … ( not only these ones )

I also checked tabs and are turned off so there should be no tabs , it only happens at the end/beginning


Just for fun, try flipping its outer circle, just to see if it has an impact on your problem.

1 Like

flipping circle did not help
I t seems the problem is that when it switchs from one “shape” to another … and uses travels
I addded 2seconds start delay and 2 seconds end delay ( I would say it is after it travels from one line to another ) it did not help.
It seems there are completely not finished parts of cutting,
Is there any setting like minimal travel or minimal cutting length ?

Have a look at picture screenshot red lines travels

And result , there is some corelarion but do not know. With which setting i have to play.

Travel speed is same as cutting in my case an start time is 2 sec and end 2 sec …overcut 1mm

Sorry for double post but it seems like start pause time is not working …

I set 10s for start time, it automaticaly gets to the point i want , turn of the laser and starts burning .
No waiting after laser turn on …
I think this causes the issue because there is slight delay betwen it sends signal to turn laser on and real laser ON state

Try sending a .lbrn2 file with a small project where the problem is part of it, maybe we can find some error.

Yes sure.
this is the file I am usingcoin_only.lbrn2 (186.0 KB)

If you engrave this file that you have sent, then cut the top with your machine dimensions. Try the file I send back.

coin_only-retur.lbrn2 (185.2 KB)

The result is same ,
even there is still set 10sec start delay ,
it does not wait , it is like it sends the command for turning the laser on and automatically starts moving on. I would notice 10 seconds with laser on waiting on one place.
So it moves and beam comes after few milliseconds or up to one second.
So that result is same, some small paths between travels are completely missing

even if I set transfer mode from sync to buffered ( I expected no commands will be stored in memory if wait is only software performed - like PC not sending the data ) but without sucess so it seems like start delay feature does not work or works quite differently because I am sure that I would notice machine staying and burning one point for 10seconds … probably some bug

Do I really understand you that all the shapes you draw in LightBurn have this problem or is it just this project that is teasing you?
The time delay should not be used to solve your problem.

Try running this file here, I have modified / cleaned it a bit.
Do not give it a time delay.

coin_only-retur2.lbrn2 (158.1 KB)

What than should solve the problem, for what purpose the feature is if you know please ?

Because I have and had this issue in past. Than I quit the Lightburn and for some time I used different SW but editing in Lightburn is better than the different software and copypasting make no sense to me from one to diff sw since I have licence for lightburn.

I see - visual the delay between the the first cutting starts , can be caused by ramping / switching delay of power source or sth else .

Than tell me for which purpose the start delay is made for ? And why it does not have any impact at all ? if you know please ( thanks in advance )

If i set start delay to 10s definitely MUST be visible somewhere in application run and it just simply is not. Also the same with end delay …

And yes you right , all the shapes or converted paths has the same problem, (according observation I consider it this happens as I described at the beginning)
I tested rectangle , tested circle etc.
If you set 2 passes there is no issue because it continues through missed part of the path (just a tiny lighter part of the path in a beginning - depends on beam strength - power set)

I will test your file and I will do something more (but both at the evening ) , I will create and go through the gcode file. and check how commands are ordered like turn laser on, move to X /Y and will check if there is some daily command or sth like that ( do not know by hearth if this is possible in G code - i will search and will add this manually if there is nothing and see )
I had little experience with G code building.
If it helps I will program application in dotnet or some kind of script for this which can do the stuff for me. Not the best solution but for time being… just kind workaround … will see …

I will edit the post at the evening / night

Thanks for your patience and willingness to help !

My 2 laser machines have never needed start-stop delays, or rather, I have never had jobs for the machines where it was needed. I do not know your machine but it seems like there is something that prevents starting your power at the same time as the movement starts. That you will check your G-code for unwanted delays sounds good, but I could also wish that one of the staff from LightBurn would look at this technical challenge.