Ortur Laser Master 2 - Busy

Hello, I have a Ortur Laser Master 2 and I just upgraded to Light burn 9.16. I was running fine on an older version of Lightburn, but now it seems after so may moves that it goes busy. No error on the consol just busy.

Also, I originally downloaded Lightburn in 8/2018 and do know know which version it was

Greetings, right after connection can you check in console the output when you type in
$#

Post here please?

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0

Here you go Gil

So is not a matter of offsets

Can you tell me in the laser panel, at “job start” what type are you using?
Absolute coordenates, user defined, or current posiution?

Regards

I’ve used all of them with no difference. It’s not even when I’m running a job, its when I’m moving to a work piece. I did notice that my travel speed was over 7k, I just lowered it down to 3k and its been better. Here is what happens now. On start up it homes and when I go to move the machine it goes to busy. Then I have to reset the connection in Lightburn (by right clicking the devices button) and it seems to work after that, at least so far.

1 Like

Do you mean pick it up and move it, or jog it with the jog buttons? You might need to lower the Speed in the Move window - the default is sometimes high enough to trigger the motion sensor in the Ortur, which will kill the job.

I meant jog it

Does motion sensor trigger produce actual error message?
I had really bad experience with this busy state… it did pop up after few gcode commands, after jogging rapidly etc. Buffer just went full and after that buffer overflow etc. and Ortur just shut down. Sometimes if lucky, job was done but busy status did not vanish. After that it was almost certain to halt in next job. And this was not just with lightburn, laserGrbl acted same.
Tried everything (slow/fast job speeds, cables, different computers/OS, serial settings etc) and no clear reason why this busy/buffer problem occured.
Got new mainboard and now it is mostly gone but seems to happen randomly now and then if I do not do powering up in certain order… (Computer first, then connect ortur power cable, switch Ortur on, connect usb from ortur to computer, finally open lightburn)

I usually do test run with 1% power to be sure that “busy” does not appear…

I have these same intermittent issues going on. Jog more than 3 times in a row and it just says busy.

This is my other problem now, I start LightBurn and the Ortur Laser is stuck because it’s busy. I unplug everything and restart LightBurn a time or two and then it goes its way :joy:

Me too, I’m following

I have the same problem and it’s very irritating. In my case, sometimes it happens only a couple of times during a session, other times it happens almost every time I reposition the laser. You can reset the connection by clicking on the Devices button and selecting the Ortur. But unless you disable Homing, it will reset the position, which totally defeats the purpose.

I don’t remember this happing with LaserGRBL, but I almost immediately switched to Lightburn after purchasing the Ortur so I would need to do more testing to validate. I really wish that someone would fix this issue as it seems to be fairly common between Lightburn and Ortur.

The jogging issues should be fixed with the next release. The communications issues I’ve looked for and have never seen on my own hardware, so it’s impossible for me to say why it’s happening.

If you have speakers and your volume up a little, do you hear the Windows USB ‘ding’ when the connection drops? If so, that means Windows thinks the cable was pulled, and if that’s what it is, there’s nothing in LightBurn that I can do about that - it would point to an issue either with the physical connection being spotty, or the Ortur board dropping the connection temporarily.

I have one other possible theory - I believe LaserGRBL defaults to using ‘constant power’ mode (M3), whereas LightBurn uses ‘variable power’ mode (M4). If the Ortur firmware has a bug when using variable power, but not constant power, that could explain why LaserGRBL doesn’t glitch. You could try using the GRBL-M3 device in LightBurn, as that would use the same commands. If that doesn’t drop the connection it would be a good clue for the Ortur folks.

I did some rudimentary testing today and after about four jogs in LightBurn the Ortur reads “Busy” and must be reset. I verified this doesn’t happen in LaserGRBL. If this is indeed fixed in the next release, it will take care of most of my issues. I don’t believe that I’m actually losing serial connectivity, just unable to communicate because of the busy status.

I did however have the Ortur shut off yesterday about three hours into a burn which obviously destroyed the material I was etching. I’ve had this happen a couple of times now. Being as the laser completely shut off, I would assume that is an Ortur issue and not LightBurn. Either way, the combination of LightBurn and Ortur in my experience isn’t reliable in the current state. I will be looking forward to the next release.

Thanks for the info.

What release will contain the fix for the jogging problem? I just installed 0.9.18 and am still having the same issue.

Thanks…

I have never been able to reproduce “the jogging problem” - I cannot fix it if I can’t find a cause in the first place. I have a Laser Master 2 on the way, and I’m hoping that with that I can reproduce the problem and and least figure out if it’s their fault or mine.

LightBurn does not have this issue with other hardware running GRBL, so it’s either the Ortur firmware, or something strange with the interaction between how LightBurn communicates and their firmware.

I’ve just connected my Ortur and I do have it lock when I click one of the move buttons, but it works fine when I use the ‘Click to Position’ button or the number pad keys. I’ll figure out what’s different here. (I rarely use the actual buttons in the move window with my GCode systems)

Yeah, I’m not trying to point fingers. I’m just stating that the combination of LightBurn and Ortur Laser Master 2 at least in my experience is very unstable. I’ve wasted quite a bit of material because the laser status becomes “Busy”. It happens mostly with the jog, but it will happen in other cases as well. Yesterday I was engraving and cutting some 1.5mm plywood. After I started, I realized that I forgot to set the number of passes for the cutting layer. Everything completed as normal, but the laser showed busy after the job completion and I couldn’t go back and run the cutting layer again without resetting, which homed the laser.

I appreciate your work on this, hopefully we can get somewhere now that you can duplicate the issues.

Let me know if there is anything I can do to assist in your efforts.

@OrturTech

This looks like an Ortur firmware bug. When LightBurn connects, I send $I to query the buffer sizes and machine info. If I send ? and a newline (\n), the controller does not respond. If I send ? by itself, I get the expected response.

When jogging, I always send the ? first to get the controller position, and I always follow it with a newline character so that I get the ‘ok’ result back from the controller, just to make coding the interface easier. I can special case the position query and suppress the newline character, but it seems strange that the Ortur is the only controller I’ve seen where this is a problem.