Ortur Laser Master 2 Extension detection

The installation of the longer y-axis frame to have 400x800 was just as easy as the initial assembly. Telling LightBurn that the working area was now 400x800 equally so.

But whenever I put anything into the new area of grid (401-800) and try a frame command I get an error:
Alarm 2 - “G-code motion target exceeded machine travel. Machine safety position retained”

The settings show the updated working area. Any suggestions on how to have LightBurn allow the full use of the 400x800 area?

Things I’ve tried that didn’t help so far:

  • Manually creating another device 400x800
  • Changing the area to 400 x 750, 700 or lower.
  • Putting a square to test/frame at 390 Y works fine. But anything over 400 not.

Thx,
J

This is because the GRBL configuration is unaware of the extension even though you’ve made the physical change and the change within LightBurn.

You can update this in Machine Settings by updating $131 to 800 or by issuing this command in Console:

$131=800
2 Likes