Ortur Laser Master 2 Pro "Error 24" stopping progress mid burn

Hey there,

New to the forums.

I’m getting Error:24 “Two G-code commands that both require the use of the XYZ axis words were detected in the block”. I’ve read quite a bit of the forums and other web sites, I’ve seen all the suggestion to change the usb cable, ground the chassis, new power supply, stop the shaking of the table.

But my problem is I created this file “clock_1.lbrn2” file for a clock face in LightBurn 1.0.02 and using it on my Ortur Laser Master2 Pro with FW 1.55. and it fails every time. I tried different burn methods changed the way it fills, the ordering, and fill shapes from all at once to individually. It still failed.

So as a test, I saved the G-code from LightBurn to my computer, and used it just as saved, on LaserGRBL, and it worked perfect over and over.

I’m going guess it’s not the usb cable, grounding the chassis, new power supply, etc. cuz it all worked.

So, the Ortur product can burn it just fine. And I know the LightBurn team has said the software doesn’t or isn’t able to create “Two G-code commands that both require the use of the XYZ axis words were detected in the block”.

So I’m at a loss…. where is the failure.

Just read try at 1% power see if I get the same error. Happy to see I didn’t get error 24, but now I got.

[MSG:Laser exposure timeout! Check TroubleShooting Section in User Manual.]
Ortur Laser Master 2 Pro Ready!
OLF 155.
[MSG: Warning: Flame Sensor Disabled by User OverRide]
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
$X
[MSG:Caution: Unlocked]

WTF=“had to walk away to get a beer”!!!

Again, saved the LightBurn G-Code w/1% power setting and again it works just fine when run with LaserGRBL. over and over it works.

ok why does LaserGRBL work and not LightBurn with the same file.

So I’m at a loss, I want to use Lightburn. But it won’t let me. What am I missing.

I guess i can create in LightBurn, but do all the burning/etching in LaserGRBL… as a workaround.

Is there any help to be had?
Thanks
ColeR-

If you are able (or willing) to put the lightburn file on the forum, I can run on my setup and see if the same problem occurs.

Thanks Steve.

clock_1_fail.lbrn2 (134.2 KB)

I submitted a ticket to the Ortur site, they suggested I use the “save as” command in LightBurn and save it as a *.lbrn file not the *.lbrn2 file format.
“Save it as *.LBRN not *.LBRN2 this tends to force the file to be redone,”

doing a 1% test run atm to see if any errors pop up.

edit: no problems to be had with the *.lbrn file format. (solved)

Hello, I have exactly the same problem ! I wanted to reflash the motherboard, but the technician from ortur told me that I was in firmware 1.70, which is very surprising considering that only 1.55 is on their site (indeed, in lightburn it says 1.70 !! !) … I even tested under laserGrbl and the problem is still present whether with the machine connected to PC or with the controller offline !!! (besides, I can’t flash and I don’t know why !!)

well I hope that saving as *.LBRN not *.LBRN2 will help you out.

not sure the LM2Pro FW ver. is the prob, though very odd about the FW1.70 on your LM2Pro, i had 1.52 and then updated to 1.55. I haven’t even seen a mention of new FW. ya odd

its seems to have solved my problem. something in the “lbrn2” files is causing my files to be corrupted.

Unfortunately this hasn’t helped me at all, it still stops in the same spot. Any other possible solutions?