Ortur laser won't turn on after attempted firmware update

After trying to install Ortur firmware update ( Ortur Laser Master 1.34), update unsuccessful and now I can’t turn my laser on. I’m on a Mac, unplugged rebooted, faint red light is light on Ortur board.

In that thread are a couple posts that include two firmwares - a 00 one and the proper one. There’s a sequence of steps to take to clear the machine with the 00 one, and then install the other. I’ve done it, so I know it works, but I also got the steps wrong initially, and screwed it up myself, so read carefully and do exactly what it says and you should be ok.

I’ve gone through all the steps many, many times. I’ve taken breaks and came back with fresh eyes. the Ortur just has a dim red light on and I cannot connect to it through the USB port. No folder shows up. Doesn’t seem to even be thinking about it.

I’ve been going through the same exact thing. Didn’t even get a chance to try and update the firmware.

I’m ready to order a new board… doesn’t seem like there is any hope for this one. anyway to do a factory reset on it?

That would be a question for the Ortur thread - I don’t know, myself.

These are the exact steps you did?

Please follow 100% according to the steps as below:

Press and hold power button.

2. While holding power button, Press the Reset Button one time.

3. In your computer, a folder will appear automatically (this folder is just as similar as a flash driver inserted into the computer),

In some computers, it may need to open the driver “ORTUR LASER” from “This PC / My Computer” manually.

Release the power button.

Copy the OLF_000.BIN in the unzipped folder.

Wait a few seconds, then press Reset Button again.

Press and hold power button.

While holding power button, Press the Reset Button one time.

In your computer, a folder will appear.

Release the power button.

Copy the OLF_134.BIN in the unzipped folder.

Wait a few seconds, then press Reset Button again.

Now, the firmware should now be upgraded to the latest version.

PS. To upload the OLF_000.BIN is with the aim to format your machine. And the OLF_134.BIN is the real firmware for your machine.

Yes, I have tried this multiple times in many different was. Including exactly to the letter. I also tried this on a PC

It falls to connect and I never see the “drive” folder appear. There is a faint red light in the board but that’s it. Another suggestion was to hold the reset button until you hear a beep or sound and then try the process. Never heard the beep I’ve been speaking to Gearbest support but they keep sending me these same instructions.

You did install the usb drivers from the zip file?

I can’t install them because I can’t get connected to the Ortur board.

In the back of the manual there is a tiny.url link to download a zip file. Download it and install the windows driver and reboot. Isn’t that where you found the bios update ?

If I can’t connect the the Ortur board to upload a file none of this helps. I need a way to access the board so I can upload the files.

I have no way to install any files to fix the problem.

My question to you is… Did you download the LaserMaster2.zip from https://www.dropbox.com/s/h5xc24l2nb93sjc/LaserMaster%202.zip?dl=0

Did you Unzip the file and then did you install the appropriate windows driver for you operating system?

I am not sure if you got this solved or not, but if not (and for other Mac users) I solved this yesterday by using a virtual machine called VMWare to run Windows 10 on my MacBook so I could upload firmware.

Hope that helps you or someone else.

The driver goes on your computer not the Ortur board!

I installed to PC and then tried to connect to ORTUR to install .BIN files. Still could not connect to the ORTUR through USB

Russell, does this procedure work with a Mac?

I have the same issue at the moment. Red light outta the box. Held power button., not turning on.
little red light always on.
pluig into PC (windows10) and it says the latest USB device malfunctioned.
I went through and found the drivers as someone mentioned above. the readme file states what exe to run for what OS> Does not state windows 10. tried the 64 bit version of the latest possible. The exe said success, yet nothing has changed for the ortur to wake up, let alone communicate with PC.
I read that for windows 10, the windows inbox drivers will do. but clearly thats not the case.
Please oh please help me hahaha. Id really like to not have an expensive paperweight.
Thanks for takin the time to read all this.

I gave up and requested a new motherboard. Hasn’t arrived yet. I am using it on my desk to keep folders in place. I will update when something happens. sorry.

I have the same problem. Was working fine until I attempted the update. I can connect and upload both codes following the instructions but the board wont bootup when I hit the power button just shows the dim red light. Tried Win7 & Win 10…