Placing items equidistant on an arc

How do I create 6 of the rectangles and place them equidistant on the arc with each being perpendicular to the arc. Like the red lines I drew manually.

Start with this

I end up with this

I thought the array would follow the path of the arc. I know it works with circles.

I am also interested to know how to do this. Reading your post, I just spent about 40 minutes trying to come up with a way to matrix copy along a path in some way or another. But I failed.

I did however manage to do it (but on the wrong plane)! :stuck_out_tongue:

(this is nothing like what you were asking, I know).

This should help:

1 Like

This is what happens with “copy along path”

I completely overlooked that feature copy along path! But this is why I read so much of the forum (so I constantly learn about all of the features).

@CXXXV, I got it to work by

  • Drawing an ellipse
  • Converting ellipse to path / node editing the bottom half away
  • Drawing rectangle / converting rectangle to path
  • Placing the rectangle on the starting point of the path to follow (snapping center of rectangle to starting node of arc)
  • Selecting the rectangle (first) then the arc (second) to follow (holding shift to multi- select)
  • Arrange menu : Copy Along Path
  • Enable Rotate Copies

Here you can see the starting point of the arc:

1 Like

I was able to follow your steps and get it to work with an arc. However, I cannot get it to work if the path is a square.

Here is what I did:

I drew a square and converted it to a path.
I set the start of the path to the left bottom corner
I drew a small rectangle and placed it centred on the bottom left corner of the large square.
I selected first the small rectangle, then the square and selected copy along path
I chose 6 copies
The 6 small rectangles were not on the large square

Can you pls tell me what I did wrong.

This is the bit that doesn’t work - I don’t think the system uses the start point of the shape, it uses the first node in the shape, and those aren’t the same. The ‘Start Point’ is just a marker for the cut planner to know where to start. I’ll make changes to the code to make the Copy Along Path use this too, but for now you have to put the shape at the first node. In my case, that’s the upper-right corner.

1 Like

Tks, Oz. I tried that and it worked fine.

Discovered an interesting thing. Using CTRL to select the second item doesn’t work. Using SHFT and selection then makes the copy work.

Very strange.

Reading your post, I tested using CTRL to select the second item and it worked correctly for me (same as if I had used shift).

Shift will select. You should be able to use CTRL to toggle the selection On and Off.

Copy Along Path will respect the user-defined Start Point of a shape as of the next release.

1 Like