Plugged into Snapmaker a350 USB - nothing happens

Hi folks, new Snapmnaker, firmware up to date. Tried auto-detect on installation of Lightburn - didnt find anything. So set up manually - all ok …but my MAc doesn’t find anything and vice-verca. Brand new USB cable tested too. Rebooted everything.
What have I missed here?? Thanks for any advice…

SnapMaker is Marlin based, and Marlin devices are not auto-detected. You have to do the setup using the ‘Create Manually’ button.

Welcome to another Snapmaker user! It’s PHENOMENAL working with Lightburn.
There might also be a baud rate setting you need to change - if you have issues connecting after manual setup, I can get you screenshots of my setup.

Honestly, though, I’m still not sure of the ideal workflow with Snapmaker. It’s really nice to work with Lightburn connected through USB - but then I need to leave my laptop / tablet (MS Surface) connected during the entire print.

I’ve started recently to use Lightburn’s Save GCode, then load it in Luban and send it wirelessly to the device, that way I can take my computer back to the house and work on the next thing I want to print (and plug it in. ;). It’s a few extra steps, but it lets the machine just run headless and frees you to go on to other things.

Thanks for this. I have done this but still didnt work. I have received a direct reply from you guys and will try again tomorrow morning

Thanks for the advice. I agree direct upload liberates dependency on my Mac. I am surprised, however, that I can’t send a file direct to the machine for saving on its own without having once again to open Luban…

Do you (or @GameMaker) know what USB communication chip is used by the SnapMaker? It’s entirely possible it needs a driver. A common one used by Chinese import engravers is the CH340 driver: CH340 Drivers for Windows, Mac and Linux

I guess I can ask. I came to Lightburn because a few Snapmaker owners use you. I wasn’t aware they all had this level of integration needs. Thanks for the tip, will try tomorrow

This is from another SnapMaker member. Snapmaker 2.0 A350 Setup Guide

1 Like

Aw, geez Fran - sorry you’re having a rough time getting started. It was a few years ago for me, switched to LightBurn and haven’t looked back, for sure. And very happy with the SM2.

You will be too, I’m sure. Just to respond to your frustration (which we all have, believe me!) - this kind of making has been, in my experience, pretty ‘bleeding edge’. Even getting a 3D printer / laser engraver to work reliably is a craft in itself. But once it’s working, it takes a minimum amount of maintenance to enjoy the hobby for many years, and you’ll forget about the difficulty you had setting up.

In this case, I think you landed in a local minimum - you’re using third party software (LB) with a machine (SM), and while Oz is extremely helpful and generous with his time, he doesn’t have a SM on which to experiment, so he can only go so far. That’s why the rest of us try to step up and fill in the gaps.

Plus it makes for a great community. :slight_smile:

1 Like

Hey Aaron, just tried and saved my first image to Gcode but it wont upload into Luban. Just appears greyed out when selecting file from Luban. I tried the ‘all files’ option but it comes up as a black filled outline which won;t allow me even to transfer by wifi… any ideas?

Let’s see - when I ran into that, it turns out I needed to make the file extension to .nc, or the button would be greyed out. Luban was a little persickety about that. If that doesn’t work for you, try posting the gcode here and I’ll see if I can get it to work.