Port Failed to Open - already in use? Aufero Laser 2

Hi there

I’ve just received my Aufero Laser 2 and have been having some problems getting it connected to lightburn.

I’m running Lightburn on Linux Mint 20, I have manually created a GRBL device (serial/USB) and have connected to the laser cutter via USB cable. However when I click “Play” nothing happens. On the lightburn console I get the error:
"Waiting for connection…

Port failed to open - already in use?"

I have tried selecting all the available ports in the laser window, however I get this error on whatever port I choose. I have also tried multiple cables/physical USB ports.

Running lsusb on my OS I am able to see the Laser Cutter, so it looks like my OS recognises it’s connected.
usb

From some googling it looks like the driver for my cutter should be included in my kernel, so I don’t believe I need to download and install anything else?

Any help would be appreciated, thanks in advance :slight_smile:

Did you add your user to the appropriate groups as described in the documentation?

Installing Lightburn - LightBurn Software Documentation

sudo adduser $USER dialout && sudo adduser $USER tty

Thanks, I seem to have missed that command!

I’ll give it a try tonight.

Hi Declan,
I had a similar problem after upgrading Ubuntu. See the link below. This may be relevant to your problem:
https://forum.lightburnsoftware.com/t/no-connection-to-lightburn-after-upgrading-to-ubuntu-22-04/67655