Problem with off set image

I’m having a problem at the moment that the laser sometimes skips/ moves part of the engraving to one side? I’ve put this in the software section but it could be the machine. Could someone help!
Another problem I’ve had is that sometimes the laser doesn’t follow the path it should and comes back to a different start position or just goes completely off for part of its run path. This doesn’t happen every time you run a program or even the same part of the job it’s a bit random

Processing: 3B00BD53-33AA-4EF8-AFE6-62A9DEA3F3B5.jpeg…
Processing: 4D5EEC50-BD40-4D8B-A8FD-6A2943195C4B.jpeg…

Looks like the last two of your uploads, didn’t… You can edit the post and try again.

It shifts, but it recovers. I’m assuming a horizontal scan.

It seems like whatever I think of, the fact that it recovers cancels out lots of theories.

Can’t be a belt or slipping or it wouldn’t recover.

Could you post the .lbrn2 file? Doubt anything is there, but I’m still wondering…


The other 2 pictures showed the cut not following the correct path, I can upload the program file, but I’m thinking it could be the machine as I can run the same file in 2 different places and get a different part of the image skip a line. I was wondering if the belt catches the edge of the tensioner pulley (larger diameter) causing it to move further than it thinks it is?

These the machine just isn’t lasing. In the previous set if was ‘offset’, but present.

It would have to ‘jump’ a large amount to make that kind of an issue. If it was off that much, I doubt it would recover as it appears to do.

I’d be happy to look at your .lbrn2 file.

Are you using 90 degree scan?


just sent you a pm with the .ibrn2 file

You should post it here, someone else may have the answer… :grinning_face_with_smiling_eyes:


christmas test.lbrn2 (137.7 KB)

anyone have any ideas as im stuck on what to try next at the moment?

I initially thought this could be something mechanical but I’m wondering now if this is something electrical. Could it be that your power supply or laser is failing? Seems like it’s firing late, holding longer, or not firing which is why it appears like some of the lines are out of alignment or not showing up at all. This would also explain why it “self-corrects” on other lines. If something mechanical I wouldn’t necessarily expect it to recover.

Maybe first check all electrical connections to make sure you’re getting good contact.

the laser power supply has been changed in the laser year and the laser tube has been tested on a meter its a 100w tube but producing 80w on the test.
checking all the electrical connects makes sense to try, as I’ve recently converted to a Ruida RDC6445s controller from a leetro mpc6535 so i could switch to lightburn.

Ive gone through today just checking the electrical connections, and they all seem to be fine. any other suggestions about what i could try/test or start replacing would be welcome? As i would like to get the laser working reliably so i can start using it.
it has had the laser power supply changed, the glass laser tube its self has been tested with a power meter but i dont know how else that could be tested. its had a Ruida RDC6445s fitted and new screen
the laser is currently wired into the high start rather than low as that’s how it was on the previous controller but i could easily changing this to try it.

Finally got change to go and have another attempt today. I’ve change the laser start from high frequency to low frequency, both on the power supply and the light burn software. it still works as it did before I’ve tried to video what its doing, typically it worked fine on the first 3 attempts videoing the issue. but i have 2 videos I’ll up load showing it going wrong on the outer cut line. its suppose to do 3 over lapping cuts but it doesn’t follow the same path each time. the second video shows it deciding to skip part of the image a follow a random path changing direction in both x and y axis before then re joining the correct pattern.
its frustrating where its an intermittent fault and its different each time. i don’t believe its the software side as it works fine some times, but I’m lost as to what to try to change on the machine its self to attempt to fix it. could it be the stepper motor?

It’s possible. The thing that’s pointing away from it in my mind is that I wouldn’t expect the burn to self-correct in later lines. I would expect issues from the stepper to cascade to subsequent lines.

Just from the symptoms it seems like something with timing. Have you tried different operations like line or image? I assumed this was a fill but I guess could be an image.

If you can reproduce this with lines then you may be able to get a clue as to what’s causing it by running different test paths: circle, square, rows of lines, columns of lines, etc.

If you have access to an oscilloscope you could take some timing measurements if nothing pans out.

just been trying to up load the videos and it blocks the .mov file extension. how is it best to do it?

Post it to a cloud service of some kind and paste the link here.

hopefully adding the videos has worked. video 1 you can see the laser does something strange about 1m 23s in for about 10s. video 2 i missed the first bit where its gone wrong on the image but you can see the 3 passes around the outside don’t over lap when they should have. like I’ve said in a previous post it doesn’t do this every time some times using the same file sent to the laser it runs through fine

just realised i up loaded the wrong video for the out side cut it should have been this one…

The 1st video is interesting. Are the shifted lines always associated with the werid laser head movement?
The 3rd video definitely points to missing steps.

Not clear if the issues shown in the 2 videos represent a single issue or multiple issues. I think the missing steps one should be more straightforward to address so suggest you start there and see if it changes the other behavior.

Have you done a thorough mechanical review of your laser? Good belt tension, no binding along the path, no debris in any travelling surfaces, no excessive backlash, etc. Try moving things by hand and feeling for any hitches or friction points, especially on the X-axis.

If you find nothing in that process take a look through this topic as it seems to be similar to what you’re seeing:
Closed shape multiple passes does not cut on same path - Hardware - LightBurn Software Forum
Bottom line reduce acceleration and speed and try to avoid resonance. Maybe try a test where you’ve significantly reduced these and see if you can reproduce the artifact. If not then start dialing up the settings until the issue manifests. Then you can determine your upper limit.

1 Like