Problems with the quality of the subsequent engraving after having changed the motherboard

Can you give me a hand please?
I changed the plate of my recorder and from that moment it records me like this.
Apparently in flat engravings this failure is not seen, but it does occur when I use the rotary laser.
My laser is Cromgrow Z1, I had problems with the controller and they replaced me with a CNC, since they replaced the board I’ve been having this problem and I don’t know what could be going wrong.
I have checked the straps and they are all well tightened.
This problem started with the new plate, with the old one the engraving was perfect.
Any settings I need to change? Any suggestions?
Although I am a computer scientist I am very new to laser engravers.

I managed to correct by changing the values of $120 and $121. But now it comes out as if the lyrics were “duplicated” (The font is Great Vibes).

Any idea what value I would need to change?

There are lots of videos out there about this, but the documentation isn’t bad and you should read it first before a video…

If you mess with the acceleration values, you will, in all likelihood, slow it down.

Good luck


1 Like

Thank you very much for your answer @jkwilborn.
I have already reduced my values of $120 and $121 to 200. Even so, it continues to remain as a shadow in my lyrics.
I have also checked the tension of my straps and everything in theory is perfect.
I am so frustrated. I’ve been struggling with this for 48 hours and I don’t know what to do anymore.

Changing acceleration values is really not the right way to fix this issue…

I’d advise you put them back and use the correct adjustment meant for the problem.


Thanks again for taking the time to give me an answer.
I tried to understand the tutorial that you sent me but I can’t understand certain things.
Could you give me an example of how to start with the offset settings?
Based on the last image I sent, if I do my engraving at 4000 mm/min, should I indicate that value in the first box, is it correct?
Based on the way you are recording me, what values would you suggest I try in the following frames? So I’ll get an idea of how to try.
You are giving me back my hopes of solving this problem. Thank you very much again.

This can be caused by a loose laser engrave head on the gantry.

With the power off gently pull the lens end of the engrave head toward you and then push it away. If it is loose, the engrave head will deflect the laser head toward you moving left to right then away from you moving right to left (or vice versa). If you tape a drinking straw vertically to the laser head and watch it from the side view it will exaggerate the head deflection.

The tell-tale or giveaway that this is what you are facing is that the spacing doesn’t increase through the production of the name. This means the machine is set correctly and the accelerations are not causing wheel-slip. The distance is happening at the beginning and the end of the process. The offset is 90 degrees to the travel.

Your dot spacing appears to be perfect.

Thank you for your answers!!
Apparently the solution is in the suggestion given by @jkwilborn, since I just added a scan offset value: 400mm/min, second value 0.200 and last value left at 0 and I’m getting great results! I think I need to regulate this value more, I’m not sure if I should add a value greater or less than 0.200, but it gave me hope that I could solve this. I am so grateful for your guidance.

1 Like

I may disagree. :slight_smile:

Slip isn’t caused by speed. It’s caused by a lack of acceleration in the body that is slipping.
By lowering the commanded maximum accelerations to what the accelerating body can handle the slipping stops.

Increasing the mass by adding to the tumbler is a common strategy, because it allows more friction force (sometimes called normal force) to be applied to the accelerating tumbler. This ‘in turn’ :wink: requires more force to rotate the tumbler and it can be difficult to get correct.

F=m*a :slight_smile:
But more accuately.
tau = I alpha
Torque = Polar Moment of Inertia x angular acceleration.

Polar Moment of Inertia is something I always thought of as Flywheelness. It’s not a real word but you get the idea.

Been there, done that.
I agree 100%

The factory setting for these Chinese machines is usually more than conservative. Ensuring they don’t have issues for any user. Meaning that the value for the acceleration is based on something valid.

From my view, slowing the acceleration down from a valid value isn’t really what I’d call the proper solution.

I would venture a guess that the machine has some other issues…

We’ve all see the absolute precision, dependability and quality control for these Chinese machines. :face_with_spiral_eyes:

My 2cents worth… :thinking:


The settings (including the acceleration) may have been valid for the original, pristine, hand-tuned factory prototype, back in the day.

At least it worked for them!

Hard agree!

The myriad horror stories around here suggest those original settings have been cargo-culted through multiple unrelated sellers to different hardware variants carrying ever-heavier laser heads. By now, the values are totally invalid for what actually gets assembled on the customer’s kitchen table.

Heck, folks sometimes find CNC-configured GRBL on their shiny new lasers. Doing something like changing the acceleration to match the actual hardware seems reasonable.

Look at the symptoms, assume nothing, and solve the problem from first principles …

IMHO, the hand tuned model may have been where they got the published performance values from the model. Hand tuned models in a production atmosphere will fail and be impossible to support or keep working. Most of us wouldn’t know if it was performing correctly or not.

The people building these are making money from them…

If they can de-tune it sufficiently to greatly increase the dependability they will.

We do exactly the same thing here in the US with vehicles and many other machines/products. The difference is, here, we can go after the manufacturer … there is little recourse when the company is in China.

It’s kind of moot anyway… I think we’re beating a dead horse.

I have more faith in @JohnJohn than most of the people anyway, so I’d listen to him unless proven otherwise, which I’m always open too… :face_with_spiral_eyes:

I’ve found if it’s supported with the correct mathematics, it’s probability is more likely… if applicable.


Here was my solution!
After 4 days of frustration, @jkwilborn came up with the solution.
I followed your instructions, put the default values of $120 and $121 and started working with the offset settings.
First value: 1000 mm/min
Second value 0.200
Third value 0


Thank you all for your help. The person who changed my mainboard insisted that he should change the mechanical parts (100 dollars was his budget) but thanks to you the agony ended :heart:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.