Project as circle cutting as oval ? why

I originally used the circle tool to create an oval with some interior engraving which engraved and cut ok, then I deleted the oval and with the shift key held I created a circle since I liked the round better. I previewed the design and the cut portion shows as a circle as it should , however it cuts as an oval. Why ??

I suggest you observe this Topic as it’s essentially the same type of issue:

A search on this forum will bring up other similar cases if you want to explore.

Have you enabled rotary mode and forgotten to turn it back off?

no, rotary was and is still not enabled, just tried a couple different size full circles and still get perfect shaped ovals, longer in Y direction

Is this a new problem? As in, have you used it before without issue and something changed, or is this your first time using the machine?

In almost all cases where the Y axis is the one scaling, it’s the rotary switch, but if that’s not it, then it’s usually a new machine that’s been configured incorrectly.

Can you show a screen shot of your whole LightBurn window?

yes this is a new problem with my three year old Ruida controller 80 watt CO2 laser. Havent used it for at least two weeks, last month I had tried to install a chuck rotary and got the steps messed up and that screwed up the machine settings and with help from this forum we successfully set the machine up better that when I purchased it used a couple years ago.
There is no icon for the rotary which should show up on the top toollbar however it is disabled in the settings.
no screen shot at this time, let me know what you want to see


I’d suggest going back into Machine Settings to see if the X and Y step length have somehow reverted from when it was fixed.

I have already checked the X and Y step length, both are 6.25000

Is this a generalized problem where everything is elongated or is it limited to that single shape?

Can you take a full screenshot of LightBurn showing the problem circle in question?

this time I sent the file of 4 different circles directly to the Ruida controller and it produced 4 ovals instead of circles. Also tried hitting the start button in Lightburn and it again did the ovals. I cant figure it out !!!

Can you push “Save RD file” and save the file with a .txt extension and then upload here?

file attached with.txt extension

There’s something not right with the attached file and it’s not downloading. Can you try again?

Also, it looks like .rd files may be able to be uploaded directly so not required to change extension.

I,m not very good with computers so will try to attach the original .lbrn2testcircles.lbrn2 file

Same issue with the .lbrn file.

How are you attaching the files? You can push the upload button or drag and drop from File Explorer.

I’m particularly interested in the .RD file because I want to make sure that your system is generating the .RD contents correctly. I suspect it is but would like to confirm.

Screenshot (19).txt (1.1 KB)

I have uploaded 3 versions for you to try, let me know if you are still having issues opening.

No. That’s not working.

To confirm, you’re pushing “Save RD file” in Laser window or File->Save RD file?

After that, you are dragging and dropping that .RD file into the form editor or pushing the upload button?

NO I am not pushing " save RD file"
I have no idea what you are talking about - I have never heard of RD file
Where is that located on toolbar ?

I just found "save RD file, will try to attach it


The file is not uploading properly. To confirm, are you pushing the upload button in toolbar and then selecting the file or dragging and dropging from File Explorer to the form editor? If not, can you use one of those two methods to attach the file?

You should be able to test the uploaded file before sending if you check the preview window on the right side if you’re working from a computer.