Public Beta Release - LightBurn 1.7.00 for xTool S1 and BSL lasers

Did you have to load any other drivers or other files? I will be trying it late this afternoon with my Mr.Carve M1 (NOT pro). I am so excited. I have been a LB user for years and this was announced a year ago I was stoked.
Thanks for your time.

I have been looking forward to this for a long time. Thank you to all that have worked and are working on this. It is a game-changer!

Now for some technical comments:
I have Mr. Carve M1 original laser.
Running 1.7 on my MacBook it did not find the laser.
Running 1.7 on my Dell Latitude Windows 10 machine, it found the laser.
I added Galvo feature to my license.
I drew a small rectangle. I clicked Frame and the red lasers drew it.
I hit start and it worked!!! Added my wife’s name and clicked on Filled and it did it.
So has anyone had success with a Mr.Carve M1 (not pro) running LB on a MacBook and if so please share anything you can.
Thanks so very much!

Running a small image (SVG) file last night on Windows laptop and LB quit. No message, laser was still burning. Was concerned that laser may keep going, but it did not. I opened LB just as it was coming to the end of the image. Opened fine, however no restoration of the image I was working with, just a new blank workspace. I did not necessarily expect it to open back to the work in progress.

bonjour, je suis le seul a avoir un problème avec le G2 Gweike, Lightburn 1.7 et Mac ? j’ai 2 Macbook, un de 2012 system intel avec osx Monterey et un de 2023 system M2 osx Sonoma la licence Galvo est activé sur Lightburn mais pourtant rien ne fonctionne, suis je le seul ? je viens d’installer la dernierer version en date 8 avril 2024 et toujours rien faut il encore attendre longtemps pour avoir un résultat sur Mac? Une info serais la bienvenue je precise que le laser fonctionne bien avec Glaser de Gweike.

Hello, am I the only one to have a problem with the G2 Gweike, Lightburn 1.7 and Mac? I have 2 Macbooks, one from 2012 system intel with osx Monterey and one from 2023 system M2 osx Sonoma the Galvo permit is activated on Lightburn but still nothing works, am I the only one? I have just installed the latest version dated April 8, 2024 and still nothing do I have to wait much longer to have a result on Mac?

Hey,
I;'ve set up my Gweike G2 fiberr laser with Lightburn version 1.7.0.0
I have imported my settings provided for EzyCad and set up the laser.

But it is constantly showed as “disconnected” maybe there is a driver missing?
OSX is decetinmg the laser | ±o SEA-LASER@14341000 <class AppleUSBDevice, id 0x10012f558, register$

I do have daja d3 and i was hopping this release will work with but it doesn’t
Is there any solution?

The Daja D3 appears to use an incompatible board - https://www.reddit.com/r/lasercutting/comments/16khv6k/anyone_tried_daja_dj6_with_lightburn_yet/

We don’t currently have any plans on adding support for this board, but you can voice your opinion over on our feature request site if you’d like to see your machine supported!

A user, Brian Lee on the Gweike site advises


Drawbacks? Judged against other 20w fiber lasers the only drawback is lack of LB support, but that is being worked on


This thread closed mid December of 2023…

I have no clue about it’s current status…

Maybe @Rick knows an updated status…

:smile_cat:

Yes, work is being done to support the G2 and the Mac connection issue experienced is known and still being sorted.

I am going to move this post to the beta group post for better tracking of this 1.7.00 beta capture.

1 Like

Which MacBook and OS version? Is it USB 2.0 or USB 3.0? How did you connect it? (IE, what kind of physical connection, adapter, etc)

A lot of Mac systems use USB 3.0, especially newer ones using the USB-C connectors. For these, you might need to connect the G2 through a USB hub or cable that will handle the conversion from USB 3.0 to 2.0.

I have an Intel based Mac Mini running Big Sur that works, but I connected the G2 through a dock that has USB 2.0 ports on it.

3 Likes

Hi Oz!
I use the 2012 below with LB for my CO2 laser.
Which MacBook and OS version?
MacBook Pro, Catalina
Is it USB 2.0 or USB 3.0?
USB 2
How did you connect it?
USB cable
I also have a much newer MBP 16” from 2020. I haven’t tried it.

Could you provide a little more detail on the USB connection path? Are you using a USB C-C cable, or a hub?

@Colin
USB A to USB - B - it is an old computer. No hub…

Also, just a point of information, my Windows machine sees the laser and I have used it successfully as noted in previous posts.

I have not yet attempted to use my newer MacBook Pro (16" from 2020).

@LightBurn Just to confirm the Mr. Carve M1 has a G2 board in it? I am not familiar with the various boards.
I did have a power isolator on my USB cable and I removed it and tried again with my 2012 MBP running Catalina. LB did not find the laser. I tried multiple times, restarted the computer and the laser. No joy.
If there is anything you can think I could try, I am willing to do so. Perhaps it is Catalina?
I will try my 2020 MBP 16" with a USB hub on it by the weekend, I am running Ventura 13.0.1 on it,
Thanks for helping. Thank you and your team for getting the BSL/SeaCAD version out.

I just tried with my 2020 MBP 16". LB did not find the laser. However, when I checked my system report I found this:

For the Mac, is the BSL config file needed and if so where does it go?

You said “it did not find the laser” - If you create the BSL device manually, does it connect?

The BSL config file is necessary for any system - It contains all the setup that was done by the people who built your laser to tell the software about the laser source, intut/output pins, lens distortion, etc. It can go anywhere you like as long as you can point LightBurn at it to import the file. After that, it’s not used and can be removed from the computer.

1 Like

I created the laser manually. Still does not connect. I tried 2 different USB cables.
To make sure that nothing was wrong with the laser, I connected successfully with my Windows 10 machine.

I tried it too on mbp2012, device disconnected. Also tried on windows 7, device connected but dosnt framing and shooting, galvo dosnt move too

Any other ideas Oz?