RD Controller had been replaced and I cannot connect via WiFi

I had to upgrade the controller in my Co2 laser from RDC64442S to RDS6445S. We cannot get the iMac to link to the Laser via WiFi. We have changed the IP addresses and I entered the model name where LightBurn requires it to be done. What do I do next? The previous controller worked perfectly with this set-up.

Did you set the new controller to the previous controllers Gateway and IP?

Assume it working through a wifi bridge or the Lightburn Pi Bridge?


I did change the IP address yes, and changed the model number to the new one. I cannot attach a picture here, otherwise I could have posted the summary from LB.

I did change the IP address yes, and changed the model number to the new one. I cannot attach a picture here, otherwise I could have posted the summary from LB. I’m using WiFi, not familiar with the Lightburn Pi Bridge. Where can I get info on that? Can I use it in the place of a Wi-Fi connection?

I did yes, do you perhaps have anything to suggest I look at? I have not received any other assistance so far and I am pretty desperate. I did get hold of someone called Oz via e-mail last night who told me that my 2nd problem, which is to use a USB Memory stick (which is a real schlep and much more time consuming) the size of everything I transfer on the USB stick is enlarged by 21% in the machine. He said it is affected by the way I set up the X and Y values. That is incorrect. I tried it now and it has no effect at all. There I also have no idea what to do.

What’s preventing you from uploading the picture here? Have you tried pushing the upload button image? Or alternatively you can drag and drop images to the edit window.

FYI, Oz is the author and owner of LightBurn. He’s pretty familiar with the software.

Take screenshots of your computer IP address as well as a photo Controller configuration.
Trying opening a Terminal window and ping the controller IP. Take a screenshot of that as well.

Thank you for the info, I was not aware that Oz was the author, I have much respect for the man.

<< snipped >>

That is the summary of my set-up. At the moment, whatever I upload to the machine via USB Memory stick gets enlarged by approximately 21%.

My computer IP address:
<< snipped >>

The IP address I used for the laser machine yesterday, is what you see in the summary and that did not work. After checking the IP address of my computer, I changed it to the address below:

<< snipped >>
Still no success.

<< snipped >>

Your last request, pinging the controller IP, I have no idea how to do but if guided, I’ll get it done.

Is this the same address you used on the previous controller.?

Go to a terminal and type


(for example)

What is the normal IP of your lan?

It has to be able to exist on the lan, the first 3 octets need to be the same.

Does your machine home in the right/rear?

Good luck


The reason this is not working is because your IPs and subnet are not properly configured. This is not a LightBurn issue.

First, I suggest you edit your post and remove the mention of your public IP information. It’s not needed and can leave you vulnerable to targeted attacks. This is the one starting with 165.

Open a terminal session in Mac. Press CMD-spacebar, then type ‘terminal’, and open the Terminal program.

Type this into terminal and return results:


We have a connection guide here:

Your public IP address is the IP address used by the outside world to talk to your network, but it’s not going to be what the IP is to other computers within your local network - that will likely be 10 + something, or 192 + something. (192.168.1.xx is common)

Ping is just a command you type from a terminal, like this:

1 Like

Plse tell me how to delete that slide with the IP address in it because what I tried did not work. I am now addressing the IP address instruction you sent.

I’ve removed your IP address from the thread.

The pen icon that’s listed below the post allows you to edit the post.

Also, once you get the IP connection working you’ll still to address the scaling issue that you got using USB. Moving to IP won’t fix that. I’m assuming it’s just a calibration issue.

For the scaling issue, we have configuration instructions for the Ruida controller that might help you:

It walks you through homing, axis directions, step length calibration, etc.

1 Like

Screen Shot 2022-03-13 at 10.32.24 PM
That is the response I got.

The IP address used between the iMac and the previous controller was 50 . 50 .1 .10

I sent to you what I tried before, I think 50 .50 .1 .10 or something like that.
I then checked the IP for the iMac and then decided to change it to the last sample I sent.

Kind regards.

If you follow the instructions on the link I sent, it’ll have you type the ifconfig command to determine the IP address of your computer on your router / internal network.

That’s the one you need to work with. If the address you find is, for example,, you would add some arbitrary amount to the last digit, and use that for the laser, like (added 50).

Is it in the pic I sent to you last, the Terminal screen that I screen copied?

I have been trying this IP thing since Tuesday to no avail. I have been using 50. 50. 1, 50 on the iMac and 50 .50 .1 . 60 on the laser cutter. That did not work. What is wrong with that

No, that was ping, not ifconfig. Different tools.

1 Like

Thank you.