Sculpfun S9 not connecting to Lightburn on MacBook Monterey

Hi, I’ve been trying to connect my Sculpfun S9 for a while now.
I’m running on a MacBook Pro with Monterey.
I have downloaded the the driver CH34 V1.5. Restarted the computer and Lightburn still can’t find my Sculpfun. I’v tried deleting and reinstalling Lightburn. Different USB ports, The older versions on the driver and so on.
I’ve looked everywhere on this forum for a solution and also on google and I just can’t get it to work.
I’v also tried installing manually the laser but it still doesn’t find it, it says port failed to open.
Can someone please please help me ?
Thank you so much

Did u find any solution. I have same issue on mac. I added it manually but still it sayd port failed to open.
Please help if u got any solution.

Installed the driver for mac from github but still same. Restarted macbook and machine ton of times but nothing working.

Hi Azzy,
I’m glad you asked because I did find a solution, well I not sure it’s a solution or just luck, but it worked for me.
I download an other laser software to see if it could find my laser, it is called Laserweb4:

Then I reinstalled the V1.5 CH340 driver:

I opened Laserweb4, connected my Sculpfun on it following this video (you will have to try all the ports until it connects. Mine looked like this:

With this confirming that it connected:

Then I quit Laserweb4, started up Lightburn, created manually my laser because it would still not find it automatically, you can watch this video:

Make sure that on Lightburn the right USB is connected, mine is this one:

And it finally worked !!

I hope it works for you too, it can get quite frustrating.

1 Like

I don’t know if it helps, but I also have a step by step guide here: Setting up the software - Diode Laser Wiki

Thank you so much! I just got my S9 and could not get it going today. This worked perfect for me! Thank you again!!

1 Like

Nice, happy to help.

I followed all the steps suggested in this thread but still sculpfun s9 is not connecting to lightburn. It connects to the program LASERWEB though. What could be a solution?

Are you sure you selected the right USB port ?

1 Like

I did. And meanwhile, after about 20 trials I got it right. Dont know why. Suddenly it worked. But I think the order is important. I reinstalled lightburn again after the other programs and that did the trick. Thanks for the answer.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.