Snapmaker 2.0 40w Air Assist

I just received my 40w laser and can’t seem to get the air assist to turn on. It does work in Luban. Looking at the G code Luban generates, it uses M8 to turn it on, but Lightburn will not. The device settings are set to M8 and the air for the layer is set.

On a slightly related note, is there a way for Lightburn to utilize the laser crosshair on the 40w to set the origin?

@berainlb knows these pretty well… hoping he can give you a suggestion…

Good luck


I’m actually not super familiar with Snapmakers other than what’s been posted here.

How does the g-code differ? LightBurn will generate M8 if you have Air enabled in the cut setting.

Can you share the g-code for identical designs from Luban and LightBurn?

I’m not sure what you mean by origin in this case. Are you asking if the crosshairs can be used to frame or otherwise be used to designate relative job origin position?

How is the Snapmaker controlled? Is it being directly controlled by LightBurn or do you need to generate g-code that’s delivered to the Snapmaker through another mechanism?

Thank you for asking the way you did. I never actually looked at the G code Lightburn was producing. Lightburn is not outputting an M08 in the G code, what could I be missing? I did try to manually send the command and it did in fact turn on and off with M08 and M09.

The Snapmaker is controlled directly from Lightburn via serial over USB.
The 40w laser has a secondary laser crosshair for aligning the work to set the job origin, I just would like to have the command to turn it on.

I just checked this using a Snapmaker device profile and can reproduce what you’re seeing. Seems like for some reason on Snapmaker devices M08 is not produced irrespective of “Air” setting.

Not sure why this is. It might be a bug but could also be intentional.

Let’s ask @Rick to confirm.

I’m not familiar with how this would be turned on. I’m guessing there’s an M command that will do so but not obvious what that would be.

Once enabled, you’d need to setup the “Pointer offset” in Edit->Device Settings to provide the relative distance from the crosshairs to the primary laser.

Likely intentional, it’s only very recently that Snapmaker introduced an air assist, so it was never a thing beforehand.

Just posting this here as I came across one of my answers.

Turn on the crosshair pointer: M2002 T3 P1
Turn off the crosshair pointer: M2002 T3 P0

As for the air assist, I do recognize that it may have been intentional as it is a recent addition, does anyone know, or who would know, if it could be added in the next release? It works for now manually, but I have to remember to turn it on before I start the cycle as it will not activate once the cycle starts.

1 Like

A good workaround is to change the device type to “Marlin” and enable inline features. Snapmaker has recently updated to support inline and M4 trapazoidal power control.

When configured as Marlin/inline, M8 and M9 will turn the air pump on and off and can be enabled in the cuts/layers window.

I have the 40W A350 setup and have enabled the Marlin/inline setting. In the console M8 and M9 turn the air assist on and off, but when I enable air assist in the cuts/layers section the air assist does not come on.
I am on Firmware 1.18. I just checked and there is a 1.18.1 FW update. I will update to that and see if that makes a difference.

Snapmaker FW upgrade did not help. I am trying to run a materials test from LB, and I noticed a “save as gcode” option, so I did just that and looked at the code. There is no M8 in the exported gcode, so I wonder if it is an issue in LB?

Do you have Air turned on in cuts/layers?
Also Air Assist set to M8 in device settings?
LB Capture

Thanks Alan,
I was using the “laser tools/ material test” built into LB. Do I need to make sure the layers that it is using have the air assist turned on in addition? And yes the settings have the M8 selected for the air assist.

I will try to see if setting the individual layer settings to air assist on changes anything.

Okay I tried it on just setting a layer to air on and a quick cut of a rectangle. It’s still no go. The only way I can get the air assist on is to go to the console and type M8. It will stay on until I type M9. For some reason it is not triggering the M8 command if the layer is set to air assist on. If I turn it on it says on while processing,

I have the A350 with 40W and V1.18.0 firmware and the air assist works just fine with the settings I posted above without any added Gcode.
I just upgraded to the 1.18.1 firmware and switched to the 10W for some jobs that I needed to do that didn’t require air. I’ll try with the 40W tomorrow.

Side note: the laser no longer fires when framing as it did before, even if I try to turn it on first. It will manually fire, but shuts down as soon as I activate frame.

ODD! mine fires on framing, but
i had to turn the power on the 40W to like 0.5% because it was leaving a faint line on Baltic birch.

Do you have air assist enabled in the Edit Material window in the laser tools/material test window?
LB 4 Capture

Air assist works fine with 1.18.1 firmware and 40W laser either through running the file or direct command entry, M8/M9.

It does not seem to work with the 10W either through running the file or direct command entry, M8/M9.

OMG! Laser does fire, I just didn’t have the power set high enough to see, SMH

LOL Mine was the opposite, the last time I used LB was with the 10W and I think I had the power set at 1%. With the 40W it would engrave the frame line.

1 Like

I notice when using Luban the laser fire button with the 40W it fires strong enough to burn stuff.