Snapmaker Image Inverting

I’m using the SnapMaker 2.0 with the 16000mW laser. I tried lasering an image and the colors came out inverted. I also ran the same image again but turned on “Negative Image”, but the image still came out inverted.
I’m using Dither Mode with a Line interval of 0.125

So what is the Lightburn question here?

What should I do so that it isn’t inverted?

Convert to B&W. Nothing to do with lightburn, right? Lasers don’t do color. Maybe find a “SnapMaker” help group? Try these people…

My bad, Color wasn’t the right word. Where the image should be light, it comes out dark, and where the image should be dark it comes out light.
Also, If I’m not mistaken it has to be between going from light burn to the machine because when I preview the path in the light burn, it all looks fine(the shading is correct), but once it runs on the machine it comes out inverted.
Thanks for the response

Couple of things… what is your “16000mW laser”? Next, please show us your image. Lastly, if you type the word “DARK” into lightroom, and look at these screens, do they look like this? Send screenshots if different.

Sorry I have the 1600mW laser that comes with the Snapmaker 2.0 A250.

Here is the original image:

Here is the tests that I did:

As you can see both turned out inverted.

And here are the screenshots:

Please show the settings for the image. It looks like it has been edited / prepped outside LightBurn. Is it dithered as well?

Yes, it is Dithered, and I did pre-edit it in order to get rid of the background.

I see you have LightBurn set to dither this image. Sorry, more specifically, was this imaged dithered outside LightBurn along with the background removal editing? If so, turn on Pass-Through so LightBurn will not resample the image.

The only thing I did outside of light burn was remove the background. I directly imported that “Original Image” that I posted earlier. Does this mean I still need to turn on Pass-Through? Thanks

No, if you did not dither outside, you do not need to turn that on.

Is there anything else I can do to fix my problem?

@GravityWarp Does it do the same thing using the proprietary snapmaker software?

We are a bit stumped to be honest. What results do you get from the software that came with this laser?

Using Luban(The proprietary software) the image comes out normal, but I can’t use the dither type which I think looks the best, and you can’t fine tune the settings as much as you can in Lightburn.
Thank you for trying

If you want to attach the LB file, I’ll run a test on my laser. I understand that I’ll actually need to do a burn since the preview looks good.

Heres the filebandit2.lbrn (438.2 KB)

I can’t burn it this evening, but I will tomorrow.

I do have a couple of questions, as I know nothing about your laser.

Is this a grbl laser? If so, do you need to set laser mode to on and set power or is this hard-coded?

To give you an idea of what I’m talking about, my laser is a grbl laser. So I need to send a command $32=1 to turn on laser mode in my grbl controller. Then I need to send $30=1000 to set max speed. Then in LB, I need to set the S-max parameter to 1000. If I don’t do all three of these settings, things go bad.

It is marlin based I believe, and I have never use the Console to input any commands, only used the options in lightburn to change settings.