The circle is not a circle

Hi to everybody!

I’m trying to understand what ails my Gweike LC1390 150W arrived last month. After this simple test (two circle inside a square and an X) i can see the bigger circle coming out from the square (white arrow) and the smaller circle ar not so rounded (red circle overlay).

Note: I know there is a fisheye effect on margins in the picture.

I have already checked if there is any backlash on pulleys, belts or other mechanical parts: seems nothing.

As you can see, straight lines are ok, but is not the same for circles. Any suggestion about what i have/can check or maybe how to solve this problem?

Did you also check for binding scenarios? Could it be that you’ve overtightened something or your laser head motion is being impeded somehow? Check that your laser head moves freely and easily to all corners of the machine. If you feel any binding anywhere try to identify the source of that binding and remove it.

Also, have you checked for dimensional accuracy of the design->burn? Measure the square and calibrate the axes as necessary to adjust.

If i turn off the machine and try to push softly the head with my hand (on X or Y axis is the same) it moves without any problem, but if i push with a little more force the head stop during his movement. Maybe is this caused by the step motors?

No, i have not try this. Tomorrow i will try to measure a square and check if dimensions are right.

Are you doing this with the machine off? It not, shutdown the machine to test this. Steppers should not be powered and certainly not engaged during the test.

I think that will be good. It will help you determine what the problem might be.

sure, only with power OFF

I have made a square with 40 millimeters sides. Its effective dimension was 39.85 and i have correct it (both sides had same dimensions) but after a test nothing changed.

I also tryed to reduce speed to 30 mm/s and it looks better, but not perfect (and also i can’t work with 30mm/s speed)

In the photo last test made:

It looks like the start and end points of the circles aren’t closing. Is that right? Also, the corners of the square don’t meet.

Also, can’t quite tell but the sides of the square look like they may be bowed out. Did you check with a straight edge? This might just be the picture or an optical illusion, however.

Are you certain you’ve removed all backlash and binding from the system?

Try enabling “Hide backlash” in Optimization Settings in Laser window. Does that improve the situation? If so, then there’s likely still some backlash in the system that you’ll want to hunt down.

This is beacause i have set Min. Power too low.

You’re right, this is only a optical illusion caused by fisheye effect of the camera.

Think yes, but maybe there is something else to check i can’t see :sweat_smile:

I have also try do add a backlash correction in Y axis via Machine Settings: better about square and circle overlay in the upper side, but really worst about circle quality

How did you do this?

Machine Settings → Miscellaneus

Ah… somehow I thought you were on a different laser.

And you’re saying it made no difference in behavior?

Did you also try the “Hide backlash” in Optimization Settings?

Yes, i’ve seen some difference but not what i hope

This is with a +0.3 Y backlash correction

Looking at the wobble at the start of some of your diagonals I’m reminded of

and another member said their similar problem was caused by one of the steppers.

Thank you @GingerKarma, i’m reading now. Hope to find a solution, or something to try

After other

@berainlb In the picture below you can see the difference without (lower row) and with (upper row) “Hide Backlash” active.

About speed, from left to right: 100 - 300 - 500

Looks marginally worse or at least no better.

For the wobbly lines, make sure that the lens is firmly secured in the barrel. There’s still something likely mechanical going on.

The thread GingerKarma referenced above is mine. I have been meaning to reply back to it as to where I was with my issue. My issue was happening around radiused corners not circles but maybe you will see some results. It looks like the diagonal direction changes in your X my have slight bump in them? I was forced to cut at 30mm/s which was way to slow. I am now cutting the same materials at 70-90mm/s and have reduced my cut time by at least half. On thinner materials I am cutting well into 160mm/s plus limited only by my 60w tube. This may be a bandaid for something else that is causing the issue but it at least has me up an running with great results

In Lightburn under EDIT> MACHINE SETTING>CUT PARAMETERS I was running my Speed Factor % (0-200) at 80 as you are. I have since reduced that to 10-15% and my issue has disappeared. My direction changes where so abrupt that I actually could feel it in the machine. Worth a try and an easy change to make. Start low and if it smooths it out, increase till the issue comes back and find the sweet spot

Once I get some time I will be going back over everything and see if I cannot increase my Speed Factor but for now I am running smoother and much faster over all.

I have tryed this, but with no significant better results. I have reduced till 5% and yes, the circle line is less wobble (not perfect) but this reduce a lot the speed

I think i have checked everything possible: lens, mirrors alignment, belts, loosed screws.

Now i make a (maybe) stupid question: how can i check if wobble is in X or Y axis? or in both?

Not certain but try running two sets of scanning operations:

  1. create a filled square with low DPI (5 mm spaces between lines) with horizontal scan direction
  2. create a filled square with low DPI (5 mm spaces between lines) with vertical (rotated 90 degrees) scan direction

Try running these 2 jobs. This may reveal additional artifacts or other clues about what’s going on.