There was a problem sending data to the laser

It’s kind of funny that our laser was marketed as having “wifi control” and a large wifi logo on it:

image
But I guess we get what we pay for. At least a lot of laser for the money. :slight_smile:

It works well enough if the environment isn’t noisy (WiFi noisy, I mean). I run my MacBook with WiFi to my router, and have the laser wired to the router, and I almost never have an issue, but if you’re in an dense urban environment with a lot of other signals, or concrete / steel walls, you’ll have more trouble. If you use ‘Send’ instead of ‘Start’, if it does fail, it’ll do so before the job actually begins and you’ll be able to try again without ruining material.

I’ve improved the handling of this slightly - The laser will now continue to respond properly after the transfer fails. There was a missing command to tell the controller that the file transfer is complete. I send that as part of the file itself, but if the file doesn’t finish, the controller will sit & wait for the rest of the data, and it never arrives. This fixes the issue with subsequent failures - you don’t have to reconnect any more.

Having said that, it is a WiFi issue. I reproduced the problem with RDWorks as well as LightBurn, with and without my traffic analyzer in the mix, and it’s just dropped packets. The moment I plugged my PC into the network with a wire everything works. I’ll double check the implementation details for Trocen controllers too - I suspect they work the same.

2 Likes

Hello,
I have a similar problem, but I only use USB connection and I have a win10.
When a laser finishes the project I cant repeat it from a software level. a ruida controller (644xs) responds correctly but a software is disconnected.I noticed that is less common if I wait a long time… for example, if I must change engraving material.
When I disconnecting a usb cable and reconnecting a lightburn works properly.

Check these:

thank’s
Packet/USB - this solution doesn’t work in my case, a machine is disconnected with a lightburn.
However, I think it was similar in rd works, I do not remember exactly. Maybe this is problem with a Ruida controller… :confused:

OK I just started having this problem on my Ruida 6442. Been working for years no problem now all of a sudden get that error. I use Ethernet, but then tried USB and it worked for about an hour. Now get same issue with the USB. No amount of pressing esc or enter or reset has helped.

What “error”, exactly?

Problem sending data to laser. The machine may be busy or paused.

@wentzele, are you going to make me ask for all the details? We don’t charge by the word.

OK windows 10, latest lightburn Ruida 6442, running ethernet. Have deleted all laser files on the controller. Machine is home built. Stopped working yesterday on ethernet, switched to usb and worked for about an hour then same error (busy). Went back to etherenet, no go. Changed back to usb today, no go. rebooted computer, rebooted laser, did reset on controller. Nothing. Checked IP address on lightburn and machine, both the same as I have been using for 3 years or more.

I did get it to run one time today by unplugging usb cable while both lightburn and laser running then plugging usb back in. Able to load two programs, then back to busy error.

Did reset on the communication by right clicking on device.

What else you need?

Thank you for this.

Running fine for 3 years and then poof, on both channels of communication? Something has changed. This is very odd to have two different communication routes both failing and around the same time. This would lead me to try from a different computer to see if it might be a computer hardware issue. I would also look into the recent Windows updates to see if some change there stands out.

Are you wired or wireless?
Known good cables? (just double-checking :wink: )
When you say, “latest lightburn”, please identify the release number for clarity.

9.11
wired

I will try another computer

OK, so now what? It is not the computer.

More info,
It works the same way with both computers whether I control with RDworks or Lightburn. Works somewhat with USB but sometimes I have to remove usb cable and reinstall usb cable, then it will run until I load a new program file. Then have to reconnect usb cable again.

So I have it working now. Really don’t understand but found this on RDworks forum and tried it. It so far has my machine running.
problem solved …not sure how because I didn’t change anything in either Rd or LB but in LB the origin switched from top left to top apparently while in Rd the origin remained in top left…so happy camper once again…just a few less hairs on my head

Could it be you use rdworks and lightburn both at the same time?

No, I haven’t opened RDworks since I installed the controller 2 years ago, been using lightburn only. The problem was ongoing before I tried RDworks to see if problem there also.

I closed all programs on computer, rebooted both computer and laser many times. Only thing that cleared problem was switching the origin one time. Everything working fine since then, running on Ethernet again with no problems.

I think something got stuck in Ruida controller that wasn’t cleared by software after changing origin.

I would have never ever tried that unless I read it on the rd group. Moved origin one time and end of problem.

I have the same problem, any idea on how to solve that problem???

This thread has 80 posts in it - which specific problem do you have?