Totally stuck after a long break away from laser

Hi
Well, I have not used my CNC3018 for a long time due to health problems.
I have come back to the device to do some jobs for Christmas.
I plugged in, the same port as it used to be.
Powered up etc.
LightBurn just will not find my drivers or start-up I’m not remembering much about the device either. So I’m stuck.
A little box comes up searching then not many seconds later tells me the great message ‘Not responding’
Can anyone please advise on what I need to do to get the CNC3018 connected to the LightBurn software and running again?
Regards
Kevin

Is the cable a known good working cable?

Also, make sure that you’re seeing the device listed in the Laser section of the UI and that the interface has been selected. If not, pick the right one depending on your system.

If this doesn’t work, please report back type on computer type and on any observations with the laser as you try to connect.

1 Like

Thanks for the reply.
When plugging the USB cable into the computer I get the usual ding-dong sounds for a new connection.
I have tested the cable on a camera and it works OK for file transfers.
Under Ports (COM & LPT) I have COM1, COM3, COM4, COM5 and something USB-SERIAL CH340 (COM12)
I have just been through the Device manager to see if I see anything I don’t recognise, there are masses of items so did not find anything.
I’ve tried the USB in direct to PC, also into an extender with 7 ports. Makes no difference
For some reason, I don’t seem to be able to get a snapshot of the error message.


Above is the list of what shows in Devices None of which I recognise.
I’ve tried with the laser board switched on and off. Makes no difference. They just don’t want to talk.
I’ve rebooted numerous times.
Stumped!
I would have thought maybe one of the GRBL settings might have given me something.
I’m going to go through it all again and see if I’ve missed anything.
Regards
Kevin

To confirm, this was configured and working before your break, correct? If so, I assume that your configuration should still be valid and working.

If you are getting the ding-dong acknowledgement then that’s good. At least there’s sign of connection life.

The COM12 port you identified as USB-SERIAL CH340 is likely the one you want. CH340 is common in arduino based boards.

In the Laser section of Lightburn (the same screenshot I sent) are you able to see your device listed? Are there available choices in the “(Choose)” section that I highlighted? If so, choose COM12 there.

Can you send a screenshot of that area if this doesn’t work?

1 Like

Hi Berainlb PY
OK Well, I went through each choice again, then again. The third time I managed to get some things working, mainly I have it now talking to the computer.
It has ended up on GRBL-M3 (1.1… using COM12 (as you suggested would be correct).
I managed to print out a single name on a piece of wood, which means it’s now up to me to start remembering how it all works.
Thanks for guidance
I hope to do some etching on some slate if I can work out all the settings for a 15W blue laser.
I’ll probably scream out if I get stuck again.
I do know one thing I will have to ask about again, that is, the orientation of the CNC to the screen layout. I’ll stick it in another question tomorrow.
Thanks very much for you time.
Regards
Kevin

1 Like

That’s great news. Now’s there’s just the job of getting on with it.

Glad you’re able to get back into it and hope you’re feeling better.

1 Like

HI JMichael
Thanks for the message. Just checked and it says 1.1f.
Is it possible to update the firmware?
Regards
Kevin

Hi (hope I’m OK continuing here as it is the same problem, lack of brain cells)
Two things I can’t fathom out.

  1. I have end stops on X & Y but not on Z, for whatever reason, probably a setting I have not found, It thinks it’s 300 max). So when I press (house-Home) it hammers the top and does not stop. Worrying.

  2. Using text, it’s upside down and reversed.

Basically, it looks like I have some of my settings wrong But I am still lost even after reading the various files available.
Help please
Regards
Kevin

When I installed limit switches on my 3018 Pro (and extending the “Y” axis as well) I searched online for examples of what others had already done. When they posted their GRBL settings they had $132= set to somewhere between 40.00 and 50.00 (ie $132=50.00). I would run it to either the top or bottom of travel (close but not touching), zero it out, and then make 1mm steps in the other direction. That should give you the number of millimeters for Z max travel. That way you would know what to enter for your $132 GRBL setting. It took a lot of fiddling to get my 3018 squared away buy I was able to do it. Hope this helps.

1 Like

As long as you make steady progress you’ll get there. Let me ask for clarification on these items.

I want to make sure I’m clear on what you’re saying. Did you add limit switches to all these axes? I recall reading that the 3018 Pro does not come with limit switches out of the box. So should not be set to home on startup and or used as they depend on the limit switches to stop the machine and reset origin.
However, there should still be soft limit distances defined in $130, $131, and $132 for x,y,z respectively.

Is it only text this applies to or also shapes? This could be an issue with how your origin is setup but this should be true for all objects. I believe your machine should have origin front-left (the same as this picture)
Check in Edit->Device settings and make sure the origin matches your machine.

Saw this guide on setting up LightBurn with Sainsmart. Might be worth a look:
LightBurn Quick-Start Guide - SainSmart Resource Center

1 Like

Hi Berainlb,
Thanks again for coming back to me…

I have end stops on the X & Y, Not on the Zaxis … I am partially disabled and have not been able to add the Z-axis switches. I thought I could switch them out somehow.

As for the inverted/reversed text. It seems to have sorted itself out. No idea how it happened.

I changed $132 to 50, but it still insists on showing (Get Position) Z:75.00
Also when I switch off then back on, Z always tries to get to 75.

Device settings are as you show.
Going to read the suggested article. Thanks

I recall from a previous topic that GRBL by default will always try to home all 3 axes if they are available, even if the Z is not “enabled” in LightBurn. This can only be changed by recompiling. Not sure how Sainsmart configured this for their firmware.

You may want to disable homing until you can add the Z-axis switch.

I suspect the problem is that without proper homing it’s unclear where the origin is.

Are you able to set a user origin in the Move panel?

Have you disabled “Auto-home on startup” in device settings?

Hi
I have a cnc 3018. as well. to answer your question. remember all CNC is connect to a com port. your software came with a software you can install to create a virtual com port as well as a rip software for the Gcode which call candle. you can use laser GbL as rip software remember ligthburn safe all Gcode as gc. check out go to start, control panel click on hardware and security will open a new widow click on system and click device manger this is where you cam see what your com port. all com port start with com1 as and example. or you can download the from google. now you can use lightburn with you cnc 3018. I hope this help good luck

Sorry guys (n gals)
I’m still struggling.
Can I start from something which is probably got you all laughing at me haha?
Currently, my table is at the end stop furthest away (Y) from me and the X is at the end stop to my left. Is this the correct position? Z is disabled and focus’d correctly.
I just don’t seem to be able to get the workspace set up. What am I doing wrong (or not doing)?
I will start there, then move on.
I’m suspicious of the controller and have ordered another one.
Regards
Kevin

Hi,
All the Axis are working correctly now. -X to the left and +X to the right. -Y towards me and +Y away from me. -Z is downwards and +Z is upwards. (However I don’t need Z so it’s disabled).
All end stops are functional in setting the alarm off. However I’m still finding they want to continue after the alarm is cleared and don’t back-up the 2mm which is what it’s set to.
Get position seems to give me different figures every time even after switching off etc.
Auto-Home is disabled as is the Z axis.
Has to be the setting of the workspace, me thinks
Regards
Kevin

I’m not following what specifically the problem is at this point. Sounds like motion is now correct. What exactly is not working at this point?

I assume this is a good thing and how you expect it to behave. Can you confirm that the head stops when the stops are reached?

What do you mean by “back-up the 2mm”?

I don’t think you can expect specific position to survive a restart since the machine is not aware of the current position when the machine is turned on. That’s usually the purpose of homing. To reset to a known position and define 0,0.
I’m not super familiar with the behavior on a machine without homing but i suspect you need to move the laser head manually to its expected start position and set the origin there. Subsequent operations will be based from that origin.

Can you confirm that the working size in Device Settings matches your machine?

Alternatively, could you add a limit stop to the Z-axis as well so that you can do a homing operation?

Thanks for reply.
I set up and ensure that all end stops are at least 5mm away from tripping (Alarming).
Closedown LightBurn.
Restart LightBurn.

On restarting I get the following. Iv’e put number so as to be able to ref if necessary.

  1. Waiting for connection…

  2. Grbl 1.1f [’$’ for help]

  3. [MSG:Check Limits]

  4. [MSG:’$H’|’$X’ to unlock]

  5. error:9

  6. G-code locked out during alarm or jog state.

  7. [MSG:Caution: Unlocked]

  8. ok

  9. [VER:1.1f.20170801:]

  10. [OPT:V,15,128]

  11. Target buffer size found

  12. ok

I send $$
$$

$0=10

$1=25

$2=0

$3=0

$4=0

$5=1

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=1

$22=1

$23=4

$24=25.000

$25=500.000

$26=250

$27=2.000

$30=1000

$31=0

$32=1

$100=800.000

$101=800.000

$102=800.000

$110=1000.000

$111=1000.000

$112=600.000

$120=30.000

$121=30.000

$122=30.000

$130=300.000

$131=180.000

$132=48.000

ok

I enter test in the bottom left corner of the screen ‘Test’. As I type the cursor stays put and the text moves to the left.
If I then print it. It starts then the following…
<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:XYZ|WCO:-3.615,41.584,-0.800>

ok

Starting stream

Layer C00

Layer C00

ALARM:1

Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.

On or near line 21:

Job halted

Stream completed in 0:02

[MSG:Reset to continue]

ok

Grbl 1.1f [’$’ for help]

[MSG:Check Limits]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]

ok

The Y-axis has tried to move away from me, but it’s at its limit. Earlier in the day, I was getting an error saying I was going to go negative was that ok? I said yes and got similar results to the above.

What do you mean by “back-up the 2mm”?
Should have read back-off (or pull off) 2mm $27

Any help with that info?
Regards
Kevin

Inversion issues are usually tied to Device Setting origin issues.
image

How is yours currently configured? I believe this should be lower-left for your system.

I found a few topics that seem to address many of the specific challenges you’re seeing with your machine. Check this out. This links to other very relevant topics:
Setting the machine origin - Getting Started - LightBurn Software Forum

Yes, thanks.

image