Unable to connect and get started and can't seem to find this problem on any forms :(

I’m have the Ortur Later Master 2 Pro trying to connect to my Win7 64bit desktop. The Laser tab on LightBurn is saying “ready” but the but under Console it is saying “waiting for connection…” I’ve reached out to the Ortur tech support but responses are infrequent and so far he seems stumped. He asked me to check what came up under “Ports (COM & LPT)” which is "Communications Port (COM1). That is also what is showing up on Lightburn next to the devices button. He said this is very unusual since COM1 is usually system reserved. Full disclosure I don’t really know what that means and I’m very confused. If anyone could please help me I would really appreciate it!

you have to install drivers, COM1 is really system reserved
download them from here… is ch340 serial/usb driver

or this one if the prev doesn’t work as expected

once you have installed drivers plug in your laser and go to device manager under com port to see which is the serial/usb


I tried both links and neither installed correctly. After I tried the second link a window popped up called the “Program Compatibility Assistant” and said that “the program didn’t install correctly, try reinstalling using settings that are compatible with this version of Windows.” Any idea what I should try next?

Thank you BTW!

Have you tried to establish comms with another laser program like Laser GRBL or T2…or what did the Ortur come with. In either of the first two the first thing you do is download and install the ch340 driver for your USB. I found it easier to work on suspected issues with my diode laser through either Laser GRBL or T2. Both are free and to me easier to deal with laser specific stuff like Gcode and some settings.
Both are free downloads…I run Laser GRBL when I need to do machine specific stuff. Use Lightburn for running the laser.
I think Laser GRBL has a pretty good video walk through to get the driver installed…and it is easy as it is in a drop down menu.
Anyway just a thought.

1 Like

I have tried it with Laser GRBL which I believe is what this is meant to be used with from what I’ve read online. Same problem however. Just shows up as COM1 and no other option. I also thought it might be that my version of Windows 7 is out of date but when I looked up updates it said that there are no more updates for WIN7 anymore…

And I assume you installed the 340 driver via laser grbl then. If it installed and try again it will just say it’s already installed I believe. However you didn’t say specifically if you chose this in grbl. It’s like the first thing to do.
Some real simple stuff…when you plug in the usb what does windows say…does it give you the usb connected tone…does it error…or do absolutely nothing.
You are getting the comm 1 option as it is not seeing the laser. Comm 1 is reserved I think but it will be displayed if there are no other usb comm ports detected

1 Like

I have had bad usb micro cables….drove me nuts on my Eleksmaker…actually had two that would not connect. They worked on other devices but not my laser. Less likely is a bad nano board on your laser or whatever Ortur uses for its little processor board.

1 Like

Once you download the drivers, you need to restart your computer (if you haven’t already).

You can also choose it under devices.


1 Like

Thank you, it’s really nice to hear that I’m not alone on this problem! haha…

The first time I plugged in the machine is made the connected tone, started installing something and then the message popped up at the bottom that the driver installation was unsuccessful. When I wrote the Ortur tech he told me to download a Zadig 2.5 driver which I did and I believe it was successful however didn’t change anything…

Also I don’t know if this helps but when I went to install the 340 driver it said “drive is successfully preinstalled in advance”

o.k. so it is installed. SO this is not rocket science so to speak. Either your USB cable is faulty…try several more…or the nano bard (or Whatever Ortur uses ) is faulty. I have had this happen as I said. Not like this chinese made stuff is high end locally made boards.
As long as your computer can see other devices plugged into the same USB port and assigns them a comm port number (each number is unique to THAT device) then it is either the cable or the board on the Ortur.
Simply put…the computer is not even seeing anything plugged into the comm port. trying to do any more communication is pointlesss. Like not getting a dial tone on a phone…trying to continually dial out is an effort in futility.
I would stay with Laser GRBL open for testing until you can establish connections with it since to me it is easier to work in for diagnostics. Once LAser Grbl can comm with the laser and comp then you can swap over to LB.
As said you can try rebooting your computer and see if that helps…I never had to myself for my diode laser but…I have had to for other driver installs so…can’t hurt. Computers are funny things.
Thats my opinion…others may vary

1 Like

Ah thank you for that, I didn’t know that each device was assigned a different number (I’ve got a lot to learn). Maybe this is a very simple question too but if you could humor me I would really appreciate it. So when I plug anything into any of my USB ports it shows (in Device Manger) in the “Universal Serial Bus controllers” tab and there is no change to the "Ports (COM & LPT) section. Wondering if maybe the problem is my computer?

ok is in italian but i hope you got the point…
this is the com port in device manager without laser plugged

and this is the same with laser plugged

you got the difference?

1 Like

Yes I have that same “Port” tab in device manager but that’s not where the USB is showing up. It’s showing up in “Universal Serial Bus controllers” about 4 tabs down. Will attempt to take a screen shot

the issue is that you have to install the drivers, if you don’t do this… you will never able to connect the engraver to your pc. When you installed laserGRBL in menu bar can you see the tab “tools”? in there you can find “install ch340 driver”, have you tried?

1 Like

I have :frowning: I just did it again to show you what happens…

and then when I close that window…