Unable to send file to Ruida controller

Hi,

I have Just upgraded from a diode to 60w co2 Chinese laser with Ruida controller. I could not send file to my controller. No error on lightbrun, no error on controller. I did a test burn and the file was sent in after a few tries but since then its not going at all. The controller show “No file” in the memory. Tried formatting memory, but still does not work.

The frame button and move buttons work fine in lightburn. Neither can i start from lightburn nor from controller.
I have a macbook with MacOs Big Sur and a usb cable to connect to the machine. Lighburn 1.0.01

You need to buy an upgrade from Gerbil to DSP version of LightBurn.

1 Like

I have the same problem, was sending files from computer via usb file sends but nothing in the ruida, now getting error message and is not sending at all. Did you figure yours out? I haven’t a clue

It’s nice to know what the error message says. That’s probably indicative of the issue. :slight_smile:

As Bernd advised you need a license to use the Ruida with Lightburn :slight_smile:

1 Like

i already have. That how i configured ruida device to light burn. As i mentioned in the post i can move laser head and can frame.

I read another thread and the lightburn staff suggested to downgrade to version 0.9.24. I did and it worked. i ll try this update in the link after i finish some job. Don’t want to risk it now. But will definitely leave a feedback on this newer version that you shred in the link.

1 Like

I will try tomorrow morning and get back to you. Thank you so much for a quick fix

I’ll give it a try now. I’m having issues with my lightburn camera talking to my computer. BTW I don’t see a 9.24 version like Qaisar mentioned above. The latest I have access to when I check for updates is 9.23

This Mac build above fixes me! I was in a different thread under camera and someone directed me over here. I just tried it and my camera is working fine now.

1 Like

I lied, it actually doesn’t. Now I’m having issues sending jobs to my laser from my Mac via USB cable. Just keeps telling me “There was a problem sending data to the laser. The machine may be busy or paused.” If I jump back to 9.21 it allows me to send job from my Mac to my laser via USB.

MacOS, it seems, has messed up a fairly critical function in the USB driver used to talk to the chip that the Ruida uses. The best option you have at the moment is to use a network cable, connected between the Apple Ethernet adapter and the Ruida controller. It takes a little more effort to set it up, but it’s not horrible.

We’re working on something that will allow you to use WIFI instead, with a small hardware add-on at the laser, but it’s going to take a little longer before we can start rolling it out.

didn’t work for me. big sur 11.4 MacBook pro i7 2015 model. Ruida 8.0064

Frame works, sending the file gives me the same result of the machine showing it is running and the head doesn’t move.

… this is not one of the new features that come with version 1.0.1, it has been available for quite some time. It’s always annoying when the machine or software teases but we have to stick to the facts.

My Ruida 6445 controller uses the FTDI FT245R USB 2.0 Slave to FIFO Converter with their Vendor ID 0x0403 and Product ID x6001:

image

The FT245R chip uses its own handshaking as an integral part of its design, by proper use of the TXE# line.

  • When high: do not write data into the FIFO
  • When low: data can be written into the FIFO by strobing WR high, then low.
  • During reset this signal pin is tri-state.

So… I think what all of this means (after about two hours of reading) :slight_smile: is that this design relies on the driver for throttling of the data. You know… what I think Oz already said :rofl: (I just wanted to understand this all myself).

So, according to FTDI, utilizing the built in Apple VCP (Virtual COM Port) driver is supposed to work and is compatible with the FT245R as long as the PID and VID are not modified. And as I have found on my own controller, they are not.

I read that removing / uninstalling the FTDI driver from Big Sur or Catalina was a possible fix (as the installation of the 3rd party FTDI driver was causing an issue).

I also see that FTDI has released (as of May 18) a Beta driver for Mac OS X10,15 and macOS 11.

(and maybe for anyone stating they cannot connect or see their machine at all)… There is also a post on FTDI’s community where they discovered that a Wacom Tablet driver was preventing both their VCP driver and Apple’s VCP driver from attaching to devices and providing a COM port.

OR

Just use an Ethernet cable (even if it is off of a USB to Ethernet adapter on the Mac as a second interface).

(I just spent a disturbing amount of time reading about all of this)

4 Likes

I have tried the file from the drop box. and also tried 1.0.2 from the website and it works But not always. A lot of time the when i frame the graphics from lightburn (using my mac), the laser stops in the middle of the framing cycle. Also when i started the job from lightburn (using mac), the laser stoped working in the middle and couldn’t finish the job. it ruined the work piece. I dont know if its the problem of the laser controller and lightburn software. Never had this issue with the older version so since then I have downgraded again to 0.9.24. and now it is working as before.