5mp 140 camera crashes software, has to be realigned every start up

I have emailed a crash report to the support email.
Setup: Calibrate camera lens: from preset 5mp 140
Calibrate Camera alignment: (crash) speed 60/power 50/scale 100 (crash)
When taking the overlay, the axis can be off a few mm to more than an 20-30mm.

When it does work, you cannot update overlay, it crashes. If you try and use it for a different job immediately after the first job, it crashes.

I received a reply from the crash report, but that was it. I’m struggling here and need assistance.

The emailed report mentions that you’re on MacOS 11.2.3 - it’s possible that has something to do with this, as we have done very minimal testing on Big Sur at this point. I need to get a new development machine to install and use it, to make sure it doesn’t completely mess up the machine we use for legacy MacOS builds.

If you choose the built-in camera instead of the LightBurn camera, does that still crash?

I’m using a MacBook Air (13-inch, Early 2014). The built in camera appears to work smoothly. Updating the overlay image repeatedly and smoothly. Drew a shape, cut the line, then imported a file and engraved, updated overlay continued to work.

It’s possible that the newer version of the OS has broken or changed something under the hood in the way that the camera data is presented.

The crash report you provided shows the crash happening deep within Apple OS code, being called by the framework LightBurn is built on - the crash isn’t in LightBurn code, so I’m not going to have an easy time seeing what happened.

Flipping the script a little, what happens if you try to use the LightBurn camera with Facetime or PhotoBooth?

FaceTime and Photo Booth appear to work normally. FaceTime used the camera, made one call ignored and another answered. Seemed to be working normally for an external camera. Photo Booth also worked. Changing filters and taking successive photos. All opened and quit as expected.

Bumping to keep this thread open.

I think I’ve figured out what’s causing this:

2 Likes

Great! Thanks for the hard work.

Try this version:
https://drive.google.com/file/d/1XvTlUMFzVkTOqEJ_SGnfDAfhR8yV--q2/view?usp=sharing

Installed, no crashing at startup, able to calibrate lens, but unable to complete the alignment wizard. After the laser cuts the alignment image, on the next page i am unable to capture the image to complete the alignment. The button turns blue with white text, but nothing happens. No prompts, just no response from the capture image button. The top left camera jog button is highlighted blue, everything else is grey. The jog commands work.

On the camera control tab, same results. Can click update overlay, but no actions.

Updated to the latest 0.9.22 version and still the same issue as above. Lightburn can see the camera, but I am unable to use it. I am using the preset for the calibration.

I was having the exact same issues on my iMac running the newest version of “Big Sur”. I had to downgrade Lightburn back to version .9.20 and then things went well setting up my new Lightburn camera (5mp 160°).

Thanks Brian, but that’s the one I had the crashing issues with. They tried a 0.9.21 specifically for Big Sur and had another bit of insight with another user. I’m glad you’ve had success with 0.9.20, but I’m still holding out for a fix from them. They’ve been good at communicating and being honest about where they are with it.
Cheers

Thanks for the update :+1:t2:

And further update there as well:

It’s unfortunately not going to be simple to fix. We’ll keep investigating.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.