Alignment issues

Hi guys

I have an issue when I engrave a batch of designs and after engraving it goes to cut and the alignment is out of whack

I have slowed down the laser as I thought this to be the issue but that didn’t help

When I create a layer for each image and engrave cut them individually it works great but would love some help on the issue not a work around

I also looked at backlash settings in RDworks but that didn’t seem to help and my scanning offset is fine also

Any help would be great

80w Chinese 6040 laser running Ruida 6442 and Lightburn

Before you play with settings too much, make sure your rails are all clean and lubricated. If you’ve had the machine for a while and don’t clean it regularly, gunk can build up on the rails or in the bearings. Any binding in the motion system can mean the steppers have to work harder to do their jobs, and at some point they’ll slip.

If you’ve done that already, there are a few settings to play with that can help:

Idle speed is how fast the laser head moves between cuts.
Idle acceleration is how fast it gets to that speed.

Min and Max acceleration control the acceleration during cutting. (I don’t have a good understanding of what Min acceleration does).


Stepper motors have poor torque at high speeds, but high torque at low speeds, which makes this a little more complicated.

If you reduce the maximum speed, but leave the acceleration, it will move short distances quickly, but long travel moves will take a little longer. If you reduce the acceleration, but leave the speed alone, it will take longer to get to full speed. Short moves will take a little longer, but long moves will still happen faster.

In my experience, lowering the acceleration usually does a better job of preventing slips overall, and reduces the amount of shake you get from the machine when doing jobs with lots of small rapid jumps. Try dropping idle acceleration by 25% and running a low power test. If that doesn’t work, drop the idle speed 25% too. If that doesn’t help, do it once more. My red/black machine from China shipped with very “optimistic” settings, so depending on where you got yours, it might need a bit of tuning.

Thanks for the reply, I only just got the machine about a week ago

I will try what you said and post some pictures of my settings to see if I’m missing something simple

I do notice that if I engrave a vector image it’s not as bad but if I load up a raster image it’s way off

Thanks again :slight_smile:

If it’s a recent purchase from China, they sometimes (often) set the speeds a little optimistically. I know my own generic red/black was set way too high and slipped a fair bit until I dialed it down. Didn’t affect the job time much, but improved the reliability quite a bit, and got rid of a few little wobbles in the lines to boot.

here are my screen shots


Yes, those are screen shots. :slight_smile:

The “Additional Settings”, as noted on the page, affect nothing but the simulation window. They are not for the machine.

Stay away from the ‘Vendor Settings’ area of the machine settings until you understand what those are for.

You should only need to touch the four values I initially highlighted for you, and those are right at the top of Edit > Machine settings.

Too easy, so do you think just reduce both cut and engrave speeds by 25% to start with

And run the same file

From the very first reply:

Came up better but the top line is still out a lot

Currently reduced 50% for each of the settings

Try dropping your “Min Acceleration” value to 200. How big is your machine? Bigger means heavier.

6040 and I will try that change

I changed the speed and the design to squares to see the skewing

The first squre image was using a jpg square and this is using a vector square

Very different results

this is the current settings

It’s closer, certainly. You might just have a loose set screw or something mechanical. If the machine is new, it’s not uncommon for the little grub screws that hold the belt pinions on the steppers to loosen out a little. It doesn’t have to be much to cause slip.

It looks like it’s only on your X, so check that.

2 posts were split to a new topic: How do I align cuts to a printed design?

Here is the engrave in the middle and then cut rectangles around the engraved rectangle

You can see it’s not a simple shift in alignment from the engrave to the cut it looks like it’s getting worse as the engrave continues(possible slipping but only when it engraves at higher resolution)

Also I slowed the machine down to as slow as 300 and it’s the same results as the original 3000mm

I checked backlash but that didn’t help and my line scan offset is perfect at 0.8 but the finer I get the more it skews

I’m lost and I’m sorry my technical terms/speak is that of a noob


Is this a new machine? If so, check everything mechanical first. Make sure everything is tight, including (especially) set screws holding the belt pinions in place. If those slip a little every time you change direction, it wreaks all kinds of havoc.

After checking everything mechanically, the next thing I would check is the motor pulse polarity:

Don’t assume it’s software or configuration until you’ve eliminated everything else. If the settings were actually correct when it arrived and you change a bunch of them, it’ll be hell to figure it out later.