Can't run Sculpfun s9 on UBUNTU

Hello m trying to use my Sculpfun S9 with Lightburn on UBUNTU. And It doesn’t connect. The drivers seems to be installed, I followed the installation instructions or linux and tried all USB/portsof my laptop.
I tested the lases on a WndowsPC and it was running fine.
Now I need to get it connected to my own Laptop, thats runing with Ubuntu.
Thanks for all help

(I am new on Lightburn and not that experementet on Linux)

Can you confirm that you applied the user group changes as described in the documentation?

sudo adduser $USER dialout && sudo adduser $USER tty

Installation & Setup - LightBurn Software Documentation

Der Benutzer »anna« ist bereits ein Mitglied der Gruppe »dialout«.
Der Benutzer »anna« ist bereits ein Mitglied der Gruppe »tty«.

My system is in german, Il try to change it to english… but yes my user is also part of these groups


Okay. Let’s move to some other checks.

Can you provide the following:

  1. Output of this command in Terminal:
ls /dev/*usb*

[EDIT - note that this should actually be ls /dev/*USB*. Leaving in place for Topic consistency]
2. Full screenshot of LightBurn
3. Any output from Console window in LightBurn when trying to connect

anna@anna-Inspiron-15-3567:~$ sudo ls /dev/usb
[sudo] password for anna:

I have also connecte an USB-mouse, so I guess, it doesn’t recognize the laser

Is this all that was listed? Can you run lsusb in Terminal and return results? Want to make sure at least the device is detected.

Separate from that, it looks like you don’t have a device configured. You may need to create a device manually.

Click the “Create manually” button and then follow these prompts:

  1. GRBL
  2. Serial/USB
  3. Pick your own name
  4. 410x420mm
  5. origin front-left
  6. Disable auto-home
anna@anna-Inspiron-15-3567:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0cf3:e005 Qualcomm Atheros Communications 
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 0c45:6a05 Microdia Integrated_Webcam_HD
Bus 001 Device 008: ID 046d:c050 Logitech, Inc. RX 250 Optical Mouse
Bus 001 Device 007: ID 1a86:7523 QinHeng Electronics CH340 serial converter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

That’s what I get from that. Seems to be detected…

I created a device manually. but it doesn’t respond when I try to move the laser in lightburn.

Can you pull down the Ports field in Laser window and take a screenshot?

Do you mean this one? there are no options to select the port. list is empty

You mean to say that you pushed the button currently showing as “(Auswählen)” and there are no choices there?

If so, I think that confirms that for some reason you’re not getting a Serial device setup. So looks like the device is detected, LightBurn is setup but you don’t have a Serial device.

Let’s try to figure out why.

Can you run these commands in Terminal and return results??

lsb_release -a
lsmod | grep ch341
dmesg | grep ch341

Yes, i pushed the byutton down and there are no choices

anna@anna-Inspiron-15-3567:~$ lsb_release -a
LSB Version:	core-11.1.0ubuntu4-noarch:printing-11.1.0ubuntu4-noarch:security-11.1.0ubuntu4-noarch
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04.1 LTS
Release:	22.04
Codename:	jammy
anna@anna-Inspiron-15-3567:~$ lsmod | grep ch341
ch341                  24576  0
usbserial              57344  1 ch341
anna@anna-Inspiron-15-3567:~$ dmesg | grep ch341
dmesg: read kernel buffer failed: Operation not permitted
anna@anna-Inspiron-15-3567:~$ sudo dmesg | grep ch341
[sudo] password for anna: 
Sorry, try again.
[sudo] password for anna: 
[  709.383563] usbcore: registered new interface driver ch341
[  709.383610] usbserial: USB Serial support registered for ch341-uart
[  709.383638] ch341 1-1:1.0: ch341-uart converter detected
[  709.384302] usb 1-1: ch341-uart converter now attached to ttyUSB0
[  713.231022] usb 1-1: usbfs: interface 0 claimed by ch341 while 'brltty' sets config #1
[  713.232059] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
[  713.232132] ch341 1-1:1.0: device disconnected

Looks like there’s a device conflict which is hijacking the terminal. This is a known issue.
Information here for reference:

Can you run this in Terminal:

grep 7523 /usr/lib/udev/rules.d/*
~$ grep 7523 /usr/lib/udev/rules.d/*
/usr/lib/udev/rules.d/85-brltty.rules:# Device: 1A86:7523
/usr/lib/udev/rules.d/85-brltty.rules:ENV{PRODUCT}=="1a86/7523/*", ENV{BRLTTY_BRAILLE_DRIVER}="bm", GOTO="brltty_usb_run"

Is this the same, or should I look for the device ID?

It’s the same. No worries there.

Edit this file and comment out the line that matches the second line from the grep command:

Add a # symbol to the start of the line.

Once you do that, save the file and then run in Terminal;

udevadm control --reload-rules

This will reload the rules.

Then rerun:

dmesg | grep ch341
ls /dev/*usb*

There should now be a terminal device listed.

If not, try rebooting and retest.

Hurra! It seems tobe working now!
the laser is moving now with the Move panel!

here the output:

anna@anna-Inspiron-15-3567:~$ sudo dmesg | grep ch341
[sudo] password for anna: 
[   25.709170] usbcore: registered new interface driver ch341
[   25.709554] usbserial: USB Serial support registered for ch341-uart
[   25.710612] ch341 1-1:1.0: ch341-uart converter detected
[   25.714275] usb 1-1: ch341-uart converter now attached to ttyUSB0
anna@anna-Inspiron-15-3567:~$ ls /dev/*usb*
ls: cannot open directory '/dev/vboxusb': Permission denied
anna@anna-Inspiron-15-3567:~$ sudo ls /dev/*usb*

thank you so much! tomorrow I try to do some cuts

That’s great. Hope you get to have some fun now.

@berainlb supper support! My copliments!:trophy::trophy::trophy:

1 Like