Creality 5W Falcon Laser Not Discoverable with Mac OS, Firmware Update Issues, & More

I’ve been trying for the past few hours to get my new Creality 5W Falcon Laser Engraver to connect to my Mac.

I have explored several different solutions without luck, which I will detail below.

First off, I was able to plug in and run the laser with the gcode that is supplied from Creality (I made a charming little engraving of a doggy). The laser is functional. The problems arise when I tried to link my 2017 Macbook Pro (13 inch) to the laser via USB-C cable (I have used two different cables both of which I know work and can transfer data).

The laser does not show up in LB when I try and use “Find My Laser.”

After trawling around the web I found this forum where someone had a similar problem to me that they fixed using a firmware update.

I have tried to update the firmware on my Creality Falcon Laser Engraver by following these instructions from Creality’s website:

Update description of TF card firmware:

  1. Prepare a TF card whose capacity is larger than the firmware size, for example, an 8GB TF card.

  2. Place the firmware to be updated (CV-30_V3.0.20_20220427.bin) in the TF card.

  3. Insert the TF card into the slot.

  4. Restart the device.

  5. Wait about 3 to 5 seconds. If the device beeps, the update is in progress.

Note: the firmware update time is about 30 seconds, depending on the firmware size and TF card quality, the update time will be different.

This has failed to produce any result. Upon starting up the laser does beep and seem to be trying to do something, then it stops and repeats the process, beeping again, as if it is caught in some kind of loop.

I wondered if perhaps it just needed a great deal of time so I went and watched a movie and the process was still not complete two hours later. For such a small file it seems silly it would take any kind of significant time, but I didn’t know what else to do.

There is also a video from Creality on Youtube that seems to show a different path than using the “find my laser” that uses “import” instead, but this example is flawed because it is from a windows machine and not a mac. On top of that, I have not been able to discover the file shown in the video anywhere (it is not included with the startup documentation supplied on the thumb drive provided).

I am at a loss. I can manually run the laser by creating gcode and putting it onto a drive and then plugging it in, but I want to be able to run things from my computer without needing to physically transfer the data.

Any help would be greatly appreciated.

Create the device manually by importing the .lbdev file included in the LightBurn download zip from the Creality site:
CR-Laser Falcon Laser Engraver Software& Firmware Download - Creality 3D

Also, confirm that your device is being detected by the OS in System Report->Hardware->USB.

Also, check that the serial device shows up by running this in Terminal:
[EDIT] - fixed command

ls /dev/*usb*

This probably won’t give you the desired results, as it probably needs to be ‘ls /dev/*USB*’

The USB part on all of mine are all capitol letters … just a typo…

:smile_cat:

Ugh. You’ve caught me on that twice. Thanks for the callout.

1 Like

No perspiration… Probably because I use it more than you with all my broken stuff…

Usually I’m looking for both USB or ACM type devices.

jack@Kilo:~/mnt/dev-test$ ls -l /dev/*[UA]*
crw-rw----+ 1 root dialout 188, 0 Sep 10 16:24 /dev/ttyUSB0
jack@Kilo:~/mnt/dev-test$ 

Just a habit…

:smile_cat:

1 Like

I’ve been having 100% this same issue. I’m using the 10w with an M1 MacBook Air. I have no Windows machine with which to use the laser, so this is my only hope. The laser works fine offline, I’ve done a few projects with just the TF card. I’ve tried numerous firmware files, been back and forth with a Creality rep, but not luck. It does exactly what you say - firmware on the card, insert card, power on, crazy beeping cycle that will just endlessly loop to no avail. Mac doesn’t see anything connected at all, so obviously isn’t showing in LightBurn either.

Sorry this isn’t much help, but somewhat reassuring to know it’s not just me!

1 Like

Did you run the 2 tests from my post above? Can you take screenshots of both results?

Yes I’ve added it manually to LB, and also verified it isn’t detected when connected (also tried three different cables).


Usually lack of terminal device is due to missing driver.

What do you get in System Report?

No love there either …
Screen Shot 2022-09-12 at 9.57.04 AM

Does ‘lsusb’ give you anything useful? You might have to install it… it might give you similar results to your ‘usb tree’…

jack@Kilo:~$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 056a:0011 Wacom Co., Ltd ET-0405A [Graphire2 (4x5)]
Bus 003 Device 003: ID 1af3:0001 Kingsis Peripherals ZOWIE Gaming mouse
Bus 003 Device 015: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
jack@Kilo:~$ 

The “QinHeng” entry is my led laser…

As @berainlb pointed out, this is usually indicative of a driver issue…

Good luck

:smile_cat:

If the device is not showing in System Report then that means the computer is not seeing the hardware at all.

Can you confirm the machine was turned on when you check System Report? If so, then you may have a more fundamental problem. Either bad controller, bad cable, or bad USB port.

Can you confirm the port works for other devices? How are you connecting the laser to the computer?

Do you have any other computer which you can use to confirm that the controller gets recognized?

Yes I the machine was turned on at the time. I’ve tried 3 separate cables, USB-C to USB-C. The port does work, as I type this I’m connected to both power and an external display in the same port (when trying the laser it’s the only thing I have connected).

Sadly I don’t currently have another machine to use for testing.

This pretty much leaves the drivers for that usb port.

Maybe someone with one of these machine can check the module (driver) that is loaded and compare them.

:smile_cat:

Did you by chance leave the TF card in the machine while trying to plug into USB? I’m wondering if the presence of the TF card disables USB mode.

Nope, I actually tried it both with and without, same result.

I just got my Falcon laser today.

I have the same problem with a 10W Falcon Laser and my M1 Macbook Pro Monterey (OS 12.6). LightBurn would not see the laser. Mac did not see the USB device.

I pulled out my old 2012 Intel Macbook Pro running Catalina (OS 10.15) and connected it. LightBurn recognized the laser immediately and it works perfectly.

Based on that, I’m going to guess that either Apple Silicon Macs or the current Mac OS is incompatible with the Falcon Laser.

I’m thankful I have a mac to use, otherwise I’d probably return the laser.

This issue with macs seems to be mostly related to the proper driver, might double check that…

I had an issue with the JL1 and, to my surprise, it was a driver, fortunately it was not a drunk driver :face_with_spiral_eyes: not used to that with Linux.

Good luck

:smile_cat: