Creality CV-30 Laser Falcon

Just got my Creality CV-30 setup and working. Lightburn doesn’t connect (USB connection). Does anyone have the correct info for a setup on this hardware?

Hi Tim,

May you provide some more info about what it’s looking like when it’s not connecting? e.g what stage of the setup process are you getting stuck on/ where are you looking to find the ‘no connection’ info and any error codes you’re seeing?

Also have you seen our setup guide? It has a page on adding a laser.

I imagine given this is a Creality that it’s running Marlin firmware (which it will ask you as part of the manual setup process), but this is just an assumption based on knowledge of their FDM printers, so I can’t be sure (would be nice to know though, if you can confirm!).

It just came out 4/26/22. Link: Creality CV-30 Falcon Laser. Took me a while to even figure out what the model number was.

Docs are pretty much non-existent. They include the LightBurn software, and LaserGRBL. I’d rather use LightBurn (I’m on a Mac).

When I installed, software wanted to find the device - I selected that, and USB, and it didn’t find anything. Gcode seems to indicate it’s a GRBL device - but don’t know which GRBL. I manually set it up, and just selected GRBL 1.1f or above.

Here’s a sample of the Gcode they included:
; LightBurn 1.0.06
; GRBL device profile, absolute coords
; Bounds: X136.1 Y150.4 to X264.9 Y265.5
G00 G17 G40 G21 G54
; Image @ 6000 mm/min, 70% power
; Layer C00

Not Marlin I believe. I’ve got one of their FDM printers, this appears to be GRBL based on the gcode. Gcode runs. I’ve looked over the docs on setting it up - but even after manually setting it up - no communication when connected. Stopped/started the engraver, stopped/started Lightburn - just doesn’t seem to connect via USB

Gotcha! Thanks for that, in the time since my last post one of our fabulous devs told me that it looks like this machine is using a Grbl esp32 board, and last we heard they were using FluidNC.

From your last comment, am I right in thinking you’re connected now, but the commands aren’t working? Are you able to screenshot your console window for us so we can see a bit more info?

Cannot connect. Only 3 ports show up, cu.BLTH, cu.URT1, and cu.Bluetooth-Incoming-Port. I’ve tried all 3, the console just says “Waiting for connection…”, and immediately comes back with “Port failed to open - already in use?” And I don’t see any USB ports defined in the devices that I don’t normally see

Ran the “ioreg -p IOUSB” on command line (similar to lsusb on Linux). Connected, and disconnected I get back the same results (yes, I have a few external USB drives…):

tim@iMac27 ~ % ioreg -p IOUSB
+-o Root  <class IORegistryEntry, id 0x100000100, retain 24>
  +-o AppleUSBVHCIBCE Root Hub Simulation@80000000  <class AppleUSBRootHubDevic$
  | +-o FaceTime HD Camera (Built-in)@80200000  <class AppleUSBDevice, id 0x100$
  | +-o Apple T2 Controller@80100000  <class AppleUSBDevice, id 0x10000054b, re$
  | +-o Headset@80400000  <class AppleUSBDevice, id 0x100000550, registered, ma$
  | +-o Ambient Light Sensor@80300000  <class AppleUSBDevice, id 0x100000557, r$
  +-o AppleUSBXHCI Root Hub Simulation@00000000  <class AppleUSBRootHubDevice, $
  | +-o USB3.0 Hub@00200000  <class AppleUSBDevice, id 0x100000571, registered,$
  | +-o P9237 Desktop@00100000  <class AppleUSBDevice, id 0x1000005a2, register$
  +-o AppleUSBXHCI Root Hub Simulation@14000000  <class AppleUSBRootHubDevice, $
    +-o USB2.0 Hub             @14100000  <class AppleUSBDevice, id 0x100000591$
    +-o USB3.0 Hub             @14f00000  <class AppleUSBDevice, id 0x1000005c0$
    +-o MacBook Air SuperDrive@14300000  <class AppleUSBDevice, id 0x1000005d5,$
    +-o USB2.0 Hub             @14200000  <class AppleUSBDevice, id 0x1000005ed$
    +-o USB3.0 Hub             @14e00000  <class AppleUSBDevice, id 0x10000060f$
    +-o IOUSBHostDevice@14800000  <class AppleUSBDevice, id 0x100000629, regist$
    +-o USB2.0 Hub@14700000  <class AppleUSBDevice, id 0x100000645, registered,$
tim@iMac27 ~ %

And it prints fine from the microSD using their supplied files. And I can manually change values (speed, etc.) in the gcode, and it does what it should.


Have you tried a different USB cable?
Is the usb cable from the laser cutter plugged directly into the computer (no splitter/converter/etc)?

Let me check that - this should be power/TX/RX - but I’ll have to buy one. Uses USB-C, and I’ve only got 2-3 of those, and they’re too short.

That could be it!
It could also be that you don’t yet have the right driver, or a few other things.

Here’s a page with some more info to help:
Connection Issues - LightBurn Software Documentation

Some success. It “connects” now, and a new serial port shows up (more Mac-like)


and console now shows:
Waiting for connection…

e[0;32mI (200672) usbtiny: Line state changed! dtr:0, rst:0e[0m

e[0;32mI (203857) usbtiny: Line state changed! dtr:1, rst:1e[0m




[MSG:Using machine:ESP32S2_V1]



b dir:3 head:0

tarx=-660.000000 tary=-660.000000 xmm=-52800 ymm=-52800 xstep=-52800 ystep=-52800

b dir:0 head:0

tarx=10.000000 tary=10.000000 xmm=800 ymm=800 xstep=800 ystep=800

cycle stop

b dir:3 head:0

tarx=-660.000000 tary=-660.000000 xmm=-52800 ymm=-52800 xstep=-52800 ystep=-52800

[MSG:X Axis limit switch on pin GPIO(40)]

[MSG:Y Axis limit switch on pin GPIO(42)]

stop st_go_idleok

But repeated attempts to “find” the device fail. I still don’t know yet if this is enough to “control” it, and start the laser, or it “connects”, but still won’t be able to do anything. I’ll have to poke around some more

Is there a reason why you’re trying to “Find” the device when it looks like you’ve already configured it? You can edit your device in Devices window if required.

Try moving the laser head in the Move window. If you haven’t already, enable the Fire button in Edit->Device Settings. Then in Move window try using Fire button to turn on laser. Do you see a light. Does light change intensity as you increase power?

If motion and laser work, then you should be in a position to start running jobs and testing.

well, it seems connected, but trying to use the “home”, “go to origin” doesn’t work. Nothing on the engraver, nothing in the console. “Busy” seems to be about as long as it would take for one to use the front button on the engraver, and then it goes “off” - but nothing happens.

Everytime I startup Lightburn, I have to select the USB port - it doesn’t seem to “remember” that - one reason I try to “find” it. There isn’t anything I’ve seen once manually configured that allows me to select the port so it will use it again. Or are you expecting “floating” USB ports from a Windows system?

So - seems connected - but nothing works from the “Laser” toolbox.

LB does remember the last used port. However, this can be impacted on order of operation because if the laser is not connected and on before LightBurn is open, the port is not made available by the OS.

So to avoid having to manually pick the port, have the laser connected and on before opening LightBurn. And close LightBurn while the laser is still connected. If you follow these steps you won’t have to manually select the port. If you ever start LightBurn without the laser connected then you’ll need to select port once the laser is connected.

Did you try the jogging controls in Move window or the Fire button?

Once connected, try entering these commands in Console. What is the reaction?

G0 X10 Y10

Separately, can you confirm if your laser has homing switches? Does the laser go through a homing process at power-on?

Jog buttons - nothing happens, nothing shows up in console.

G0 X10 Y10

Commands show up in console, nothing happens.

It has homing, that happens on power on/startup. No separate homing switch. So yes, it goes through a homing sequence at power on.

Can you provide the following:

  1. Screenshot of Edit->Device Settings
  2. Push Devices button in Laser window. Select your laser, then take a screenshot
  3. Full screenshot of LightBurn
  4. Copy paste Console output after first connection

Also, have you tried connecting to the laser using LaserGRBL? If so, what was the behavior?

Separately, this video about the CV-30 indicates that there’s a device configuration file. Did you use this when configuring the device?

Creality CV-30: CR Laser Falcon | Unboxing and Assembly - YouTube

Reply to question 1: Edit → Device settings:

Sorry for the delay, I was unable to post due right after making the above post on the website. Website refused to let me post another reply.

To answer - yes, I used the parm file that came with the unit. I had questions about the firmware, the website they point to is really - terrible. The manual is - not much of any manual. Basic instructions on assembly - nothing much on operation, or software configuration. They have software on the page for the CV-30, that I don’t think applies. A slicer, and a “printer” - which looks like a very basic Cura. Shows a 3D volumetric view - not applicable to a laser, really.

Anyway, got an answer about the firmware (they had two which appeared to be identical - but if they’re identical - why 2?) Applied the firmware, and immediately, LB connected, and will control the unit. On my 3rd small test burn now.

So the issue was the firmware needing to be updated. The firmware that came on the unit appeared to be from 4/21/22, the firmware I downloaded appears to be 4/27/22 - and that fixed the issue. If anyone runs into this - the extracted filename is CV-30_V3.0.20_20220427.bin. It will download with some garbage filename like, and if you try to extract it on a Mac - you get an error. It extracts - but some weird error.

Webpage to use for the download is - there is no link to this page that I’ve found from the main Creality site. The firmware file to download on that page is shown below:

1 Like