Device not found BJJCZ Device - Laser Mark Control Board V1

Hello, I’m having trouble migrating my CO2 laser galvo system from Ezcad to Lightburn. I’ve tried on both Linux (Xubuntu) and Windows 11, but Lightburn fails to recognize the laser control board in both operating systems. I’ve successfully performed the same migration process on another machine and computer without any issues. I’ve searched the forums for solutions, but I haven’t found anything helpful. I may have overlooked something. Can you assist me?

Attached is an image showing the name of the card as recognized by Windows in the previous installation (Ezcad).

Screen

Haven’t heard of the Laser Mark Control Board V1. does it run EZCad2?


With windows, you’ll probably have to use a different driver than EZCad uses.

I would think it would work with Linux, mine does…

Can you see the device with lsusb (linux) and the device manager from windows?

:smile_cat:

Hi there,

Yes, it should work with Ezcad using the same drivers as another 64-bit Fiber V2 machine. I used to have an old fiber laser with a V1 board, but it had its own drivers and was only for 32 bits.

I have attached images of the device manager in Windows (where Ezcad works) and the lsusb command in Linux. In Linux, I have highlighted the two devices that appear when the machine is connected.

I tested it on a clean Windows installation and Lightburn also did not recognize it. Please note that this is a CO2 tube machine.

I apologize for my poor English and I hope for your help, I would really like to be able to use Lightburn on this machine as well.


With Ubuntu

jack@Kilo:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 25a7:fa67  
Bus 001 Device 003: ID 062a:4102 MosArt Semiconductor Corp. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 9588:9899 BJJCZ USBLMCV4
Bus 003 Device 003: ID 056a:0011 Wacom Co., Ltd ET-0405A [Graphire2 (4x5)]
Bus 003 Device 002: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
jack@Kilo:~$ 


It’s the BJJCZ USBLMCV4 entry. I’ve never seen that ID, but I’m sure that applies to more than this one.


I was asking about EZCad2, which is supported by Lightburn compared to EZCad3, which is not.


I know on Windows, there isn’t a driver that will support both Lightburn and EZCad2.

Might be wise to ask for help here… maybe @JohnJohn could clarify if this board is supported or not.

:smile_cat:

I’ve tested the board on another Windows PC with installed Lightburn drivers, but it didn’t recognize the device. I’ve also tried using Lubuntu and Ubuntu on Linux, even though there shouldn’t be any difference in terms of driver compatibility. Occasionally, the device is listed as “BJJCZ USBLMCV4” when using the lsusb command.

That’s odd it isn’t consistent.

If it was going to work, I’d think it’s more likely on a Linux box… I don’t know which driver it’s using… I’ll have to see if I can chase that down.

:smile_cat:

If it is recognized on Windows as a BJJCZ device it means you did not install the LightBurn driver, and have the EZCad2 driver installed.

2 Likes

Yes, it is listed with BJJCZ on a computer where the machine is running with EZCAD. I only used it for illustration purposes. I tested it on another Windows installation with Lightburn drivers, including this same one that recognized a Fiber Laser without problems, and a clean Ubuntu installation, Lightburn did not recognize it in either case.

I am migrating the equipment to Lightburn and this is the fourth machine. The previous ones were very simple and only needed the specific adjustments for each one, but we have to have this one with an unsupported board.

Hello, until today we did several tests on different OS (Windows 7 32 bits, WIndows 10 and 11 64 bits, Ubuntu 24.04) and Lighburn didn’t recognize the machine, I rolled back the drivers, tested on new OS installations and nothing . Could it be that the controller is a similar/unofficial JCZ model?

Sorry to step in.
Have you read this topic?
We don’t know if it worked because there was no feedback from the OP.

Hello, thank you for your contribution,

If I understand correctly, the drivers you indicated there are for Ezcad, I had no problems with it, I can’t get Lightburn, with its specific drivers, to recognize the machine.

Unfortunately don´t have a Galvo. I don´t know if they are the same as the EZCAD ones.

I took a look at the INF files, the range of VID/PIN that each driver covers are different

EZCAD Driver:
[Standard.NTamd64]
%LoaderName% =USB_Install, USB\VID_9588&PID_9990
%DeviceName% =USB_Install, USB\VID_9588&PID_9999

Lightburn Driver:
[Standard.NTamd64]
%LoaderName% =USB_Install, USB\VID_9588&PID_9980
%DeviceName% =USB_Install, USB\VID_9588&PID_9899

This is one of the reasons why the LB driver is not supported.

Is there any way to adapt this?