Dots appear all around engraving

Not too long ago random dots started appearing around engraved text, which seemed like a loose optics issue. I’ve triple checked and aligned all of the mirrors and the lens to perfection. The tube has been replaced recently as well as the power supply and the optics.
The dots were getting progressively worse at speeds over 60mm/s, so I decided to go over the setting, I was running GRBL C3D mini. The card was old and something burned out on it a while back, but it was still functioning. Long story short, the board finally gave out and I replaced it with a Ruida controller. After finally wiring everything up and fine tuning every single setting, the damn dots were still there. I even went over the grounding points, shortened the high voltage cable to the tube, tried to separate all of the wires and electronic components checked the belt tension, removed air assist nozzle, ran the laser without exhaust, or air assist etc.
At some point I decided to download RDWorks. Set up the text for engraving at 300 mm/s 12% power and holy crap, it came out perfect. I went back to lightburn and ran the file again, there were no more dots at high speed.
I haven’t touched any components between the tests in RDW and LBRN. It seems like running a file in RDWorks fixed the issue in lightburn.
I don’t know how this could be possible, but I would like to get some input from you guys.
The laser is a K40 btw, but the only thing that is left stock in it is the Y motor and all of the iron.

If you have not observed that your laser head jumps from one point to the next, which will be very visible and very unlikely, then it is reflections from something that disturbs your laser beam.

Are you engraving on metal? If so, that looks like beam reflection / splash.

Eliminated that conclusion too. I covered the entire bottom part of the gantry and the nozzle with masking tape and made a little box around the engraving area. There was no effect whatsoever.

If you engrave on plywood, do you still get the little dots?

No, the material is forbon, it is also known as vulcanized fiber. It is not reflective, in texture it is similar to cardboard, or stone.

Yes, the spots were much less visible, but you could see them with a magnifying glass. Forbon picks up the spots best, which is what on the picture.

if you have a spare lens you should try with it

do you have an air compressor connected to your system?

Yup, tried two sets of old optics, no result.

Yes, ran the scan with it on and off as well as completely detaching it from the head.

I asked about the compressor because if there is once in a while a small bit of water with the air it will “explode” in the nozzle and affect the lens and the mirror, but, it is only a vague conjecture.
Another possibility, is it conceivable that your laser beam hits the inside of the nozzle, just quite a bit?

I have one of the standard aftermarket (Light Object) air assist heads for k40. I didn’t see any moisture inside of the nozzle cap. I did an alignment of the beam with tape over the tip and the beam hits it dead center in all 4 corners. The condensation from the compressor is a good point, I will double check that just to make sure, maybe some water remained on the lens when I took the air assist off.

I hope you find a problem solution. But it will surprise me a lot if it is not reflections of some kind.

So far it has been working great, so the problem is technically solved. The solution itself was unexpected and I still cannot explain it. It does indeed look like a reflection problem, but I’ve gone over every possible step to resolve this mechanically.
I hope this thread helps someone in the future, those K40 machines are strange little things.
Thank you for your input, this is all valuable info.

I have the same problem and haven’t been able to solve it yet. It’s also a K40, but heavily modified (basically a complete rebuild to a 600x300 bed). Similarities between your setup and mine:

  • K40
  • aftermarket LightObject blue head
  • GRBL board (Awesometech Mini Gerbil)
    I get the same random dots on a variety of materials. It’s the most obvious on acrylic.

Hello, I think that we have the same problems…

I know this is an old thread, but today I did a test again on thermal paper and the problem seems to be worse than I thought. the dot’s don’t show up on acrylic, or regular paper, only on very sensitive materials. I’m starting to think that this is a power supply issue. This started happening around the time when I replaces the stock PSU with a LO 20W~45W PWM CO2 Laser Power Supply. I’m gonna try contacting them and see if they’ve run into this problem.

1 Like

Hello very good idea to use a termal paper, I will try too !

We have discussed it before, a laser beam can not divide into several different directions, it is not physically possible. That it is so clear on thermal paper shows that it is hot water, not much but water.
But of course I’m not right if you do not drive with compressor air at all.