Engraving Misalignment - Firing slightly delayed on specific lines?

Hi all,

I wonder if anyone can help me please? I’ve just started having a strange engraving issue on my lightly used one year old 60w Aeon Mira 7 (Ruida). I am using the latest version of Lightburn. I have used this file multiple of times without any issues whatsoever. Mirror alignment is fine, mirrors and lenses are clean and the belts are correctly tensioned. No vibration issues, as far as I can tell, and everything is fastened securely.

I am using scan/fill engraving at the speed I normally use 250mm/s with 16% power.

As you can see on my photo, the right hand side of my box/boarder is a jagged line when it should be straight. Interestingly, the misalignment pattern/shape of the jagged line follows the rows of text next to it. On rows where the laser is engraving multiple times when it scans horizontally, the line misalignment is towards the left. On rows where there is nothing else to engrave except the jagged line itself, the misalignment is towards the right.

The same issue occurs at different starting positions on the bed and the x-axis feels smooth when manually moving the laser head side to side and there is no resistance, grinding noise, or anything like that.

It seems there is a fraction of a second delay on the ‘busy’ scan rows where there are multiple engraving points on that horizontal row, or in another words, when there is more engraving required on the same row for text or other lines/objects on that row. The theory would be the laser does not fire quick enough due to a controller processing delay, power supply delay, failing tube, etc., but since Lightburn is set to engrave in both directions, this does not make as much sense as the jagged line would be one of the first things to be engraved in one direction but one of the the last things in the other direction. It seems the left or right bias of the jagged line is engraved over multiple rows of backward and forward engraving leading me to believe the Ruida controller is specifically telling the laser to fire at the wrong time. My photo shows two engraved signs, as you can see the pattern of the jagged line is exactly the same on both.

I have started to get a slight misalignment on some of my other files, mainly consisting of engraved text where the vertical lines on some of the letters are jagged but it is more noticeable on the file in this post.

I have not updated the firmware on the Ruida controller but I have recently upgraded Lightburn, although I don’t think this is related to it.

It seems the controller is telling the laser to fire at slightly the wrong time on busy rows with multiple points to engrave.

If anyone has any idea what could cause this I would really appreciate it.

Thank you very much for your help.


Don’t know if I can help.
I noticed it’s only on the box outline, not present in the lettering, is this correct?
What is this layers settings. Is all the work on a single layer?
Assuming this is the x axes?

Thanks Jack, the misalignment is only happening to the box on this one but happening slightly to the text on another file I tried yesterday. The other file does not have any boxes/boarders. It is an x-axis issue and all engraving (both text and shapes) is done on a single layer.

Downgraded Lightburn to the version I used last year just in case it was a software glitch but this didn’t help. Still think it is some kind of fault with the electronics, maybe even x-axis stepper but not sure. Laser tube hasn’t done that many hours and kept at a constant temperature with a CW-5200. If anyone has seen this happen before and can point me in the right direction of which component may have failed I would be grateful. Thank you

Here is another example, out of a entire sheet of labels, these ones had misalignments on them. This is only a recent issue starting within the last few days. I wonder if it is a faulty stepper?

It’s similar to the 'Offset Adjustment’ but rather than single forward and reverse rows that are misaligned, my issue is for groups of several rows which are misaligned with other groups of rows. The pattern seems to be the number of engrave points on the row which dictates the misalignment.

I’m guessing something is wrong with the x-axis electronics since exactly the same misalignment is produced anywhere on the bed. So x-axis stepper, driver or even Ruida controller.

Before I start dismantling the machine if anyone has any more suggestions I would be grateful. Thank you.


Don’t update any firmware. Until you KNOW it’s the firmware, that just adds another variable to the process. It worked then didn’t, not software. Hardware breaks, software has bugs.

Unless you can point it otherwise, I’d venture it’s mechanical. I’m advising to ‘play the odds’ until eliminated or at least reasonable doubt.


Thanks Jack, I agree. Should be no need to upgrade the firmware as it was working fine until recently with existing firmware.

I have done some more tests last night. I checked the backlash/scanning offset and for the speed range I normally engrave at and there was virtually no misalignment whatsoever.

I saved the test job to the Ruida controller and ran it from there and the jagged edge still occurred.

I also ran test files in RD Works as well as Lightburn and the same jagged edges occurred.

Interestingly, when restricting the scanning to single direction in Lightburn (so the laser only engraves on the left to right pass) there is no misalignment and the test file engraved perfectly (but obviously much slower).

Misalignment still occurs on rows where there happens to be more points to engrave. When dual direction scanning is re-enabled you would expect the left to right scan to engrave the line in the correct position but the return right to left scan would add the misalignment to to just one side of the existing line due to some kind of offset however this doesn’t seem to be the case if you look closely at the line. What seems to be happening on dual direction scanning is the entire engrave of the line is shifted to the left on rows where there is more points to engrave. This would indicate the misalignment is occurring on both scan directions which is why it doesn’t make much sense single direction scanning corrects the misalignment.

From the tests this evening I’m still leaning towards a fault with the x-axis stepper motor, stepper driver or the Ruida controller.

Hey Richard,

there is an option in the Ruida DSP for the step pulse signal handling, it’s a long shot but worth trying (if you haven’t already):

Experimenting with this setting has recently helped to solve some wired drifting issues of another user so maybe it will be able to make a difference for you as well.

Good luck and cheers,

If you think this is a mechanical issue, I wonder. The physics of the head movement is the same, the only difference is the laser is only active in one direction. As far as I know. It could be running at a different speed on the return trip… Doubt it’s the mass of the stream of photons :slight_smile: It shifts to the right when you’re doing right to left pass… The interesting part is that it actually corrects itself.

If as you say, it was working, and you didn’t ‘mess’ with the Ruida settings, don’t start. This just complicates trying to diagnose the real issue. ALWAYS ensure you have a complete backup of the configuration before changing anything.

It’s strange it’s right shifted only where there is blank space to the right. And a ‘symptom’ of the the shift is occurring on the right to left pass…

You don’t have any kind of kerf or other settings on the layer enabled do you? I’ve had strange results when I ‘goofed’ and did that. Maybe a good time to review all the setting for aberrations that you didn’t expect sneaking in there. I would think you’d see this on the preview…

I was going to ask if you found this issue with other files you’ve lased?

Good luck :slight_smile:

Thanks Brian and Jack for your help and suggestions. I really appreciate it.

I have double checked the tightness of the laser head, focus lens, etc. Apparently a loose focus lens can cause this but all were secure as far as I can tell. I have observed that the misalignment tends to occur at the right hand edge of the engrave scan at the point where the laser head changes direction specifically from right to left and not the other way around. Within a few milliseconds the laser head has caught up and there is no further misalignment on the rest of the scan row.

Last night, I decided to replace the belt connecting the x-axis stepper motor to the main belt on the x-axis linear rail just to see if it would help. I checked the the components while this section of the machine was disassembled and I may have identified the fault. The x-axis stepper motor seems to catch slightly when manually rotating the pulley. It feels smooth and then catches at the same point on each rotation. I carefully disassembled the casing of the motor and could not see anything obviously wrong with it, but during reassembly, if I gave each case screw a similar tightness/torque (diagonal order) and the motor rotated smoothly. Hoping I had fixed the issue, I reassembled the machine but unfortunately the misalignment still occurred. I am guessing if something isn’t machined correctly inside the motor, or has worn, or the motor shaft is slightly out of alignment. When the belts are reattached, even under low tension, it is just enough to cause it to catch and restrict the operation of the motor, especially at low speed. So my current theory is a stepper motor mechanical fault.

Thanks everyone, hopefully a new x-axis stepper will fix it. I hope the new one lasts a bit longer, this current one hasn’t been used much from new.

Sounds like your on the right trail… Anything you get from China probably hasn’t had the best quality control or built from high quality components. :slight_smile:

I would think that if an aggravating issue, such as a direction changed, then anywhere that occurred it would duplicate the problem.

Good luck :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.