Eratic behaviour on positioning

I’ve posed these concerns before, but not in the same light. Originally I thought it was just my CO2 but I’ve noticed the behaviour on my diode as well now. Not all, just the framing problem.

Just wondering if anyone has any suggestions as to where I could start investigating. This is really driving me nuts and I don’t know where to go now to be honest. Likely multiple problems, but hoping it’s all related.


  1. On both lasers my frame command is reversed. It’s a crapshoot depending on the day. One day it works normal (rubber band vs. extents) trace, next they are reversed. Nobody I’ve talked to has ever encountered so I’m just adding this in hopes that someone with good knowledge can connect the dots for me if they all happen to be related. Previous post here: Frame commands reversed and cannot get the rubber band to work properly

  2. I’ve abandoned my rotary unit on my CO2 which sucks, there was just too much inconsistency, costing me a lot of money with Yeti’s.
    Steps per rotation setting I don’t think should ever change once you know the value for your unit. Mine has to be checked each time doing a test burn. Very erratic
    issue. I send my program to the laser (with rotary) and it does one program, send it again and everything can be completely skewed. If you look at this article, it will explain.
    Odd behaviour of rotary, also not following conventions
    Does steps per rotation change from part to part?

  3. Once in a while (most often when the rotary is attached, but not always) my gantry runs into the right side at the start of the program when I hit frame and keeps trying to go that way until I hit the e-stop. If I don’t the belt starts skipping over the teeth of the sprocket until I shut it down. Reset and everything is normal. I wired up a selector switch and added an additional connector so that I wouldn’t have to keep disconnecting the Y axis each time I wanted to use the rotary. Wondering if I connected to the wrong source for power and this is somehow influencing this? . Also the power on button has a weird electrical pop/fizzle sound once in a while, but heck I can make the light switch in my bathroom do that most days so probably nothing there.

  4. The latest issue is when using my Lightburn camera to line things up, then I frame, I can tell something is off. (This is NOT A CALIBRATION ISSUE, if I shut the whole system down, it will reset and everything is back to normal, pretty sure it is the resetting of Lightburn that corrects it). This is an intermittent problem, doesn’t always do this. When framing my image, what I would expect actually is shifted say 1/4" north (not always, just an example). So I assume the camera is out of calibration so I ignore the picture and trust the frame, I put the piece down on the bed and sure enough, it runs the laser in the path of what looked correct on the picture from the Lightburn camera, not the frame.

  5. When I shut down my Mac and turn back on, it sets the units in Lightburn to Inches/ mm/sec. I never use these units. It’s always mm/sec for CO2 and mm/min for Diode. The reason I know this is happening usually is because my gantry, when trying to jump to a position, moves at a snails pace. Somehow Lightburn has rest my units. Another giveaway obviously if I didn’t see it first, is the speed units in my layers are screwed up and totally not what I expect them to be.

@lightburn, I’m wondering if you have any suggestions on #4 and #5. Pretty sure this is out of my control. I’d be up for drastic things at this point like starting a fresh install and abandoning all my settings or something. Any suggestions?

I’m honestly wondering if I would be best to hire someone to come to my place and look at my entire system. I know it would cost a ton, but something needs to be done. I’m across the border from Detroit if anyone knows someone good. I’d also be happy to give a reward to anyone that finds the magic bullet for these issues, though I doubt they are all going to be rectified together.

Additional info.

I’m running a Mac mini (which honestly seems to behave erratically itself it seems but it behaved this way when I had a Macbook so I’m pretty sure it’s not that), so my ports are limited, so I’m using a USB hub which my Ethernet is connected to for my CO2, but my Diode is directly to the Mac. Also I changed the motherboard of the CO2 thinking there was something there, nothing though.

My kingdom for a solution!
Thanks if you’ve read this far.

To keep this simple let’s isolate to your diode laser. Can you confirm that this is a GRBL based machine?

If so, try this please:

  1. Enable “Show all” in Console
  2. With a simple design loaded, run square frame multiple times until you the rubberband frame symptom.
  3. Capture all the text generated in Console and upload here

Is it possible that you’re not consistently enabling the rotary before each rotary job? And inadvertently using the non-rotary mode which would result in different settings being used?

How is your machine connected to your computer? Is this via the ethernet adapter that’s on the USB hub?

Does this occur often enough where you can rely on it happening within a certain number of attempts? Any custom wiring does raise some question marks but not sure what type of thing would cause this issue.

I want to make sure I absolutely understand what you’re saying here.

You’re saying that you’ve updated the overlay, placed your design image in workspace to fit where you like against the overlay, then run a frame and notice that it’s not located where you’d like. After burning, you’re saying that the actual burn more closely matched position on-screen against the overlay and did not match the frame? Please confirm.

For a given design, does this occur every single time?

You’re saying it’s setting this in the Preferences section?

Have you customized the location of your prefs file at all? Is there anything of note about how storage works on your computer?

I find this curious. Why would a units change affect the speed? Are you updating the values for speed as if they were in mm/s?

Did you have all the same symptoms or a limited subset of these on the Macbook?

1 Like

First, thanks for any attempt to help. As ever I am eternally grateful.

Quick question, since the Diode is rarely the one that screws up in regard to the frame issue, and of course it’s not doing it now (probably need to restart the machine fifty times and do a bunch of jobs etc before it will do it), I hopped onto my CO2 as it does it almost 90% of the time on it. The issue wouldn’t repeat there either, so I switched files hoping to trigger it, Instead I noticed my gantry moving tremendously slow. This means, switching programs, switched my units over (was on Inches/mm/sec and I had to switch back to mm/sec (wish I could remove the inches one, I never use it and quite frankly don’t know what it means.). Once the units switched over, the move speed dropped to almost nothing for some reason and I had to change that back as well (pic below). Is this normal? I know that the file was originally created on my Diode but I wouldn’t think it should mess with all my units and especially not my speed… Would think if anything it would just convert the speed to the equivalent in the new units.

On with your questions:

Yes, it is an Ortur LM2P

As mentioned above, I’ve attempted multiple times to get this to work on my diode but it won’t right now. I’ll need to come back to this once it happens. Sorry. Very intermittent for the diode.

No, definitely not. If you see the example below, I didn’t touch anything and from one side of the cup to the other it screwed up. I run through a checklist each time too before running the rotary.

I do notice however that even though I load my rotary settings and they are set to make the checkbox green for “enable rotary”, I still have to come and enable it on the “laser” menu as well.

Correct, Mac–>USB Hub (ethernet port)–>ethernet hub (which is connected via ethernet cable to internet connection)–> machine. Wondering if I should get a dedicated Apple approved USB to Ethernet and bypass the hub.

There was a period where it happened 10X in a day. It’s rarer now. Haven’t plugged in the rotary in a long while because of it. Wondering now that I’m thinking of it, it could be my procedure for attaching the rotary. I was getting mixed reviews on how to connect the rotary. Seemed to me the, connect and disconnect the X axis while the machine was on, was the best way, another reason I wanted to install the selector switch instead of constantly switching out the main connection, doing this while hot was a bit unnerving to me. Just wondering if doing this when the machine is off or the settings weren’t loaded at the right time etc., wonder if I was screwing up the order of operations there. I swear I tried everything though.


No, intermittent


I don’t think so because I can’t even figure out where it’s located on this darn Mac. I know how to see everything in Lightburn but I cannot access a folder specifically. I’m looking at contacting Apple to understand why this folder is hidden. Mac environment is frustrating to me. Below pic is a shot of it.

Exactly! As you already know it happened real time today when I switched files (top).

Seems it was limited on the Macbook. This has been progressive. I’ve had this Mac for a year and it seems things are popping up more now. Then again, I also received the Mac and the Rotary around the same time.

I’m honestly ready to wipe everything and start over. but then I will lose everything I’ve had to work through to this point.

Thanks for any and all help

By programs here, are you referring to a LightBurn project?

I wouldn’t be surprised if units could change if you also changed devices but sounds like you did not do that in this case. Can you confirm?

I don’t believe I’ve ever heard of this.

This definitely has the feel of something related to the dynamic shifting of settings that occurs when device changes occur. However, something may be going wrong in the process.

Can you go to File->Export prefs, save a file, and upload that file here? I’d like to review your device setup.

Also, can you confirm that you only have a single version of LightBurn installed on your system?

No worries. If you can get this to occur then that would be the easiest way to see what’s happening. Messages to the Ruida would be harder to capture and interpret.

The bit about having to enable the rotary in the Laser menu is interesting. How are you loading your rotary setings to begin with?

Some sort of comms issue I could see possibly creating the issue with framing but I don’t see that as causing the units issue. That would not explain having the framing issue with the diode, however.

Do you have Raspberry Pi that you could load Pi Bridge to? That could potentially rule out some part of USB Hub or adapter issue.

I inititially thought comms could be the primary issue but doesn’t seem to be adding up to the rest of what you’re saying. Especially if you’re not getting any other telltale comms issues signs.

What’s the reason for disconnecting X?

I think doing the actual rotary connection should be done with the laser off. However, the controller should be on and connected when you enable the rotary from LightBurn.

Do you have access to any other computers that you could use to rule out a computer side issue? Ideally something on another OS type, Windows or Linux.

Correct my apologies

Correct, literally just opened up a new Lightburn project.

Exactly, but even if that is true, I NEVER use the units it switches to for either machine inches/mm/sec. Always in mm/sec or mm/min. But I agree it does seem reminiscent of this. As I mentioned, the program was originally created for my diode and I opened in my CO2, not sure that has any effect.

CO2prefs.lbprefs (45.2 KB)
diodeprefs.lbprefs (45.2 KB)

I saved prefs using both profiles. I feel like they are both the same, but just in case.

Yes, only one.

Isn’t there only one way to do it? I go to edit machine settings and then load the one I saved that is set up specifically for rotary.

I do not unfortunately. I suppose I could buy one if there are no other options.

Sorry I meant “Y”. So that the rollers of the rotary are used instead of the gantry.

Maybe I just never did it in that order. I’d be surprised though.

Yeah, I’ll have to request another license from Lightburn.

I wonder if perhaps this is the source of the issue. You should not need to change anything in Machine Settings.

Enabling the rotary itself should make any necessary changes on the machine side.

I don’t think you’re at that point yet. If we could identify a reliable scenario that failed you could prove out a communication issue by transferring the RD file via USB drive. You don’t have other likely signs of a comms issue at this point.

Okay, gotcha. I was worried I didn’t fully understand your workflow.

All LightBurn licenses allow 3-seats now in case you’re not aware.

If you can rule out computer as a factor that would go a long way to isolating the root cause.

I must have watched a bad tutorial or just took it the wrong way. I thought I needed to because some of the settings need to be different when using the rotary vs gantry. What you are saying makes complete sense though. I always wondered why you’d need to enable rotary. I guess this should just take care of everything switching over and I just have to toggle back and forth. This makes so much sense now.

Maybe I have bad machine settings under my rotary settings and switching back and forth is screwing things up. However, that doesn’t explain how the image burned on one side of the cup changes when done to the other side.

Do you know if there is way to get the default machine settings in LB? I feel maybe I just need to start over from scratch there.

This can be true for GRBL devices. Is that possibly the video that you saw?

There may be something I’m missing in your setup, though, so please test.

Yeah. I can’t work out the timeline there. I’m just hoping there were too many moving parts to track.

LightBurn itself has no default machine settings. If you’ve exclusively used LightBurn to make your machine settings there may be a full history of all the changes over time but that may not be something you want to rely on.

Did you ever take a full backup of your settings at some point? Hopefully before any modifications were initiated.

If I can chime in here…

I got hooked on this with my CNC3018 machine… it was mm/m

After a co2 arrived, I found that I didn’t do well with mm/m since most of the work was mm/s on the co2.

In the end I have all of my machines using mm/s … I can look at a machines operation and tell about how fast it’s running since I’m used to looking at mm/s … Kind of like k/h or m/h, speed is speed and I use what I’m comfortable and used too…

@berainlb is correct, this shouldn’t be an issue… with or without a rotary. You’re in good hands… I just thought I’d comment about this. When you get a speed change, I wonder about the units.


Yes, we actually discussed this before. But my concern is, this keeps jumping to units I never use (inches/mm/sec). I suppose it might not do that if I stay consistently on one set of units. I can give that a try.

I did not. I will just find someone at some point to give me all of a new install’s settings for a Omtech 80W CO2 laser, enter them in and start fresh I guess.

I suppose that by this question, if I were to add another (fake) CO2 laser to LB (as if I got a new one and I’m setting up for the first time), you would tell me that the machine settings would not be recreated from scratch. I assume that LB would draw the settings from the machine itself. In which case I’d have to do a factory reset of the machine if even possible?


Correct. LightBurn has no role in setting up the controller’s initial settings.

Absolutely do not do this unless you specifically have a backup of all your settings. Resetting on a Ruida does not get you to a clean working state for your machine. It gets you basically to an unconfigured default controller state.

OK thanks. I guess all I can do is ask the community for someone that is 100% certain they have never modified their machine settings and send me a snap of every single setting. Not sure what else to do. Actually, I suppose I can just ask anyone that feels 100% confident that their settings are working for their own version of LB using a CO2 and go through and scrutinize everything comparatively.

Do you have photos of your machine? I have an 80W but OmTech sells multiple 80W models so want to make sure they’re indeed the same.

IMHO, I’d suggest you do a backup now. Better to have some good values that a box that doesn’t work.

The same looking case means nothing … no telling what’s changed inside between manufacturing runs.

No different than my Dodge truck… you had to know the trucks VIN to get the right part. Mine changed in the middle of a run…

Do yourself a favor and click on the save button in the Machine Settings…

We both are asking you to CYA…

Good luck


We appear to have the same machine.

Here are the settings from factory. Note that I had to adjust PWM Rising Edge for one of the axes to correct for slanted engraving. I’m fairly certain that’s not reflected here.

Instead of actually applying these settings you could simply use this as a reference.

If you backup and upload your settings I can take a look at the differences for anything that might look strange.

OMTech 80W 700x500 Factory Settings.lbset (12.6 KB)

It would be simple if he backs it up, then loads yours…

If it doesn’t work, he can recover, at least back to where he was when he backed it up…

This is only a couple clicks to check this…


Simply loading the file doesn’t provide much value. Knowing what’s different could provide some insight.

No, on the surface… if it works then?

It’s a simple check… that’s easily recovered from if it fails…

The files are xml, so you can just do a diff in Linux, I assume there are similar tools in Windows.


1 Like